Bug 57169 - FORMATTING: The Freeze setting and the cell position return to A1 starting with Sheet3
Summary: FORMATTING: The Freeze setting and the cell position return to A1 starting wi...
Status: RESOLVED DUPLICATE of bug 50982
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86 (IA32) Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-15 19:47 UTC by Zé Silva
Modified: 2013-11-16 18:14 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is the document stated above. (7.50 KB, application/vnd.ms-excel)
2012-11-15 19:47 UTC, Zé Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zé Silva 2012-11-15 19:47:17 UTC
Created attachment 70140 [details]
This is the document stated above.

I created a document in XLS format with four sheets. This was done by selecting File->Spreadsheet. Sample data was entered in A1, A2, A3, B1, B2, B3, C1, C2 and C3 (the same on all 4 sheets). The top row in each sheet was frozen by selecting Window->Freeze. The cell C3 was left selected in all sheets. Then I selected Sheet1 and saved the file. When the file is opened again, the Sheet1 and Sheet2 behaved as expected but, starting with Sheet3 onward, the Freeze setting is not selected and the cell A1 became the selected cell, not the C3.
In ODS format, all four sheets behave as expected.
Comment 1 billhook 2012-11-15 23:35:58 UTC
Reproduced exactly as described on LO 3.6.3 Windows Vista 32bit.

There are many other similar reports of bugs with saving the Freeze Pane. This is a good reproducible test case though.
Comment 2 billhook 2012-11-15 23:51:18 UTC

*** This bug has been marked as a duplicate of bug 49742 ***
Comment 3 ign_christian 2013-05-09 09:17:57 UTC

*** This bug has been marked as a duplicate of bug 61060 ***
Comment 4 ign_christian 2013-05-30 14:36:02 UTC
I'm really sorry..this bug isn't duplicate (only partially) of bug 61060

> sheets. Then I selected Sheet1 and saved the file. When the file is opened
> again, the Sheet1 and Sheet2 behaved as expected but, starting with Sheet3
> onward, the Freeze setting is not selected and the cell A1 became the
> selected cell, not the C3.
> In ODS format, all four sheets behave as expected.

Saw 2 problems:
1. Freeze setting not saved on Sheet3 & Sheet4 after saving & reopening file 
-> bug 61060
2. Cell A1 became selected on Sheet3 & Sheet4 (not cell C3) after saving & reopening file

Still reproducible on LO 4.0.4.1 (Win7 32bit)
Comment 5 Urmas 2013-08-13 16:08:32 UTC

*** This bug has been marked as a duplicate of bug 50982 ***