Download it now!
Bug 57184 - : Sort with Header sorts the Header too
Summary: : Sort with Header sorts the Header too
Status: RESOLVED DUPLICATE of bug 53482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-16 08:04 UTC by John Ervin
Modified: 2012-11-23 05:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Notice that the header line is at the end of the selected sort after the sort. (78.21 KB, image/png)
2012-11-16 08:04 UTC, John Ervin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Ervin 2012-11-16 08:04:54 UTC
Created attachment 70147 [details]
Notice that the header line is at the end of the selected sort after the sort.

Problem description: In Libreoffice Spreadsheet, when doing a Sort of a few rows and after using option "Range includes Column Labels", it seems to sort the header row along with the other rows.  It should be left at top of selected block.  Behavior changed when I updated my Ubuntu system from 12.04 to 12.10.

Steps to reproduce:
1. Select Rows to Sort including a header row.
2. Select Data/Sort
3. Select "Options" Tab
4. Check "Range includes Column Labels"
5. Select "Sort Criteria" Tab
6. Select Sorts Keys as required, note that they do contain the Column labels that were included because of checking "Range includes Column Labels"
7. Click on OK to do the sort.

Current behavior:
Lines are sorted correctly except that the Header Line is also sorted

Expected behavior:
Lines selected should be sorted, minus the header Line which should be left as the first line.

Platform (if different from the browser): Ubuntu 12.10
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 Julien Nabet 2012-11-20 21:51:58 UTC
I didn't find the other fdo but normally, this should be fixed in 3.6.3
Could you give it a try and tell us if it's ok or not?
Comment 2 John Ervin 2012-11-21 01:14:01 UTC
3.6.2.2 is in the Ubuntu repository.

On 11/20/2012 04:51 PM, bugzilla-daemon@freedesktop.org wrote:
> Julien Nabet <mailto:serval2412@yahoo.fr> changed bug 57184 
> <https://bugs.freedesktop.org/show_bug.cgi?id=57184>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEEDINFO
> CC 		serval2412@yahoo.fr
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=57184#c1> 
> on bug 57184 <https://bugs.freedesktop.org/show_bug.cgi?id=57184> from 
> Julien Nabet <mailto:serval2412@yahoo.fr> *
> I didn't find the other fdo but normally, this should be fixed in 3.6.3
> Could you give it a try and tell us if it's ok or not?
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 Julien Nabet 2012-11-21 11:54:58 UTC
John: I propose you to uninstall you current LO version and test deb packages from download Libreoffice website or perhaps a ppa.
Anyway, I put it as RESOLVED/DUPLICATE (of fdo 53482) for the moment. Don't hesitate to reopen it if you still reproduce it, don't hesitate to reopen this bug.

PS : don't answer to the email sent by Freedesktop but, instead, add a comment here: https://bugs.freedesktop.org/show_bug.cgi?id=57184
(since I'm on cc of this bug, I'll got automatically an email from Freedesktop if you add a comment)

*** This bug has been marked as a duplicate of bug 53482 ***
Comment 4 John Ervin 2012-11-23 05:31:28 UTC
Yes, I updated from my 3.5.x version to 3.6.3.2 version and found that I no longer have the problem.  Thanks, I appreciate the assistance...