Bug Hunting Session
Bug 57198 - Mac OSX Daily installation package too small and invalid
Summary: Mac OSX Daily installation package too small and invalid
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-11-16 15:30 UTC by Jorendc
Modified: 2013-05-10 19:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2012-11-16 15:30:32 UTC
I think there is something wrong with the compilation of the installation packages for LibreOffice 4.0.0.0alpha.

Since version of November, 15 (master~2012-11-15_06.52.00_LibO-Dev_4.0.0.0.alpha0_MacOS_x86_install_en-US.dmg) the package size is only about 20MB.
Todays version is only 16MB (master~2012-11-16_10.08.10_LibO-Dev_4.0.0.0.alpha0_MacOS_x86_install_en-US.dmg).

When I download the package and double click on it, a message appears with: 'no activatable file systems' (roughly translated).

The last correct version is the version of November 14 (master~2012-11-14_01.45.48_LibO-Dev_4.0.0.0.alpha0_MacOS_x86_install_en-US.dmg) where the package size is 155MB.
Comment 1 Jorendc 2012-11-16 15:32:31 UTC
@Roman: I think this bug also will interest you. If not, I'm sorry that I add you to the list :).
Comment 2 Roman Eisele 2012-11-16 16:10:08 UTC
@ Joren:
Thank you very much for noticing this!


CONFIRMED. This problem occurs in the builds from
http://dev-builds.libreoffice.org/daily/MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm/master/
i.e. builds from tinderbox 27, owned by thb@libreoffice.org

The daily master builds from
http://dev-builds.libreoffice.org/daily/MacOSX-Intel@1-built_no-moz_on_10.6.8/master/
seem to be OK, i.e. tinderbox 1, owned by nthiebaud@gmail.com, still produces valid builds.

So the problems seem to be related to the build settings/enviroment/etc. of tinderbox 27.
Comment 3 Roman Eisele 2012-11-16 16:15:52 UTC
(I wrote via private e-mail to thb@libreoffice.org; seems he does not have an bugzilla account for that mail address.)
Comment 4 Michael Meeks 2012-11-16 18:09:49 UTC
I wonder what's up there :-)
Comment 5 Thorsten Behrens (CIB) 2012-11-16 21:38:23 UTC
I'll look into that once I'm home with reliable 'net ...
Comment 6 Jorendc 2012-11-17 18:00:18 UTC
The newest daily works again (master~2012-11-16_23.17.46_LibO-Dev_4.0.0.0.alpha0_MacOS_x86_install_en-US.dmg). Again a file size of 155MB. Is this problem 'permanently' solved?

Thanks for your time anyway!
Comment 7 Jorendc 2012-11-19 10:30:16 UTC
The version of 2012-11-18_05.13.57/ as well as version of 2012-11-18_23.28.45/ works fine. I think we can close this bug?
Comment 8 Thorsten Behrens (CIB) 2012-11-19 13:15:59 UTC
Looks fixed indeed.
Comment 9 Jorendc 2012-11-26 11:12:03 UTC
I think that the compilation is still a bit unstable. The version of 2012-11-23_03.51.01 works fine and has a good package size (153MB). The next build (and same day) 2012-11-23_22.16.23 has only a build size of 33MB (not working). 2012-11-25_10.56.53 has got a bigger package size 126MB, but still not able to install properly (translated message: 'no activatable file systems'). Today's version master~2012-11-26_00.28.52 works fine and has a good file size (153MB)...

I'm not sure to reopen this bug, because this is a very unstable 'daily' release...
Comment 10 Thorsten Behrens (CIB) 2012-11-26 15:23:10 UTC
Hmm. Norbert, it seems rsync either times out, or the files vanish too early. Can the latter be prevented, and the former be reported in tinbuild?
Comment 11 Jorendc 2012-11-30 22:05:40 UTC
Again a faulty daily version master~2012-11-30_15.22.24. Only 34 MB 'big'.
Comment 12 Jorendc 2012-12-06 10:08:01 UTC
I reopen this bug because the last correct daily dates from November 28 (master~2012-11-28_00.26.43_). Build of master~2012-11-30_15.22.24_ is not valid (only 34MB size). From then ... there is no daily-build anymore. Windows still have daily builds, so this is a bug.

We can't test the new changes anymore! Please fix as soon as possible. We can't locate the time range where a bug was entered (if a bug appears).
Comment 13 Jorendc 2012-12-06 21:40:19 UTC
The first daily build for 4.1 (master~2012-12-05_01.41.56_LibO-Dev_4.1.0.0.alpha0_MacOS_x86_install_en-US.dmg) has still the same specifications: a low file size (21MB), and off course not working.

(No worry, I won't repeat this every time; but I will just alert everybody on the list that this bug still appears in the builds for 4.1)

Kind regards
Comment 14 Joel Madero 2013-01-08 17:35:42 UTC
Is this still a problem in current releases? If so we can set as NEW instead of REOPENED (REOPENED is just UNCONFIRMED after it has gone from UNCONFIRMED to RESOLVED). 

@Joren - can you set this to NEW if it's indeed still a problem? Seems obvious that a lot of people have confirmed it's an issue
Comment 15 Jorendc 2013-01-08 18:19:25 UTC
The Daily build for Mac OSX is still buggy. There is no file to download: http://dev-builds.libreoffice.org/daily/libreoffice-4-0/MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm/

(and no other mac versions): http://dev-builds.libreoffice.org/daily/libreoffice-4-0/
Comment 16 Thorsten Behrens (CIB) 2013-01-10 10:19:08 UTC
(In reply to comment #15)
> The Daily build for Mac OSX is still buggy. There is no file to download:
> http://dev-builds.libreoffice.org/daily/libreoffice-4-0/MacOSX-Intel@27-
> OSX_10.7.0-gcc_4.2.1_llvm/
> 
> (and no other mac versions):
> http://dev-builds.libreoffice.org/daily/libreoffice-4-0/
>
restarted the box, which got somehow stuck.
Comment 17 Michael Meeks 2013-01-10 10:24:46 UTC
It's nice to have master builds of course; I see some here:

http://dev-builds.libreoffice.org/daily/master/MacOSX-Intel@1-built_no-moz_on_10.6.8/current/

And none here:

http://dev-builds.libreoffice.org/daily/master/MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm/
http://dev-builds.libreoffice.org/daily/libreoffice-4-0/MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm/

So - looks like we don't have current libreoffice-4-0 snapshots of 4.0 development, though the tinderbox is building ~now.

http://tinderbox.libreoffice.org/libreoffice-4-0/status.html

I'd love to get this off the -4-0 MAB list but without snapshots it looks quite reasonable there :-) hopefully Thorsten's build will complete and we can close this...
Comment 18 Michael Meeks 2013-05-10 19:19:38 UTC
Seems like this is all fixed, and working nicely just now - and has been for a while :-) Closing this out - thanks for the report.