Bug 57231 - CRASH when FILEOPEN particular old .odp
Summary: CRASH when FILEOPEN particular old .odp
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other macOS (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-17 17:29 UTC by Mart
Modified: 2013-10-22 22:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File, that crashes impress on opening (2.62 MB, application/vnd.oasis.opendocument.presentation)
2012-11-17 17:29 UTC, Mart
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mart 2012-11-17 17:29:46 UTC
Created attachment 70194 [details]
File, that crashes impress on opening

Problem description: 
Crashes on opening.

Steps to reproduce:
1. find file
2. open file
3. crash

Current behavior:
crash

Expected behavior:
open and view / work with the presentation

Platform (if different from the browser): 
Also drash on Mac OS x 10_7_xx      
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4
Comment 1 Mart 2012-11-17 17:32:46 UTC
Both impress and draw seems highly unstable, crashing on opening old files.
Also on changing order of slides in left panel.
Comment 2 Rainer Bielefeld Retired 2012-11-18 17:00:37 UTC
NOT Reproducible with "LibreOffice 3.6.4.1 rc" German UI/ German Locale [Build-ID: a9a0717] on German WIN7 Home Premium (64bit) 

MAC related
Comment 3 Mart 2012-11-18 21:49:01 UTC
Yes Mac related or Danish related (hate to acknowledge!)
Comment 4 Leif Lodahl 2012-11-19 07:56:09 UTC
Tried with Version 3.6.3.2 (Build ID: 58f22d5) + Danish language pack on Ubuntu 32bit without any problems.

So it could be a Mac problem or a problem solved in recent releases.
Comment 5 Rob Snelders 2012-11-19 22:15:32 UTC
Not reproducible with LO 3.5.4.2 on Ubuntu 12.04 x86_64 without Danish language-pack.
Comment 6 Rob Snelders 2012-11-19 22:39:22 UTC
(In reply to comment #5)
> Not reproducible with LO 3.5.4.2 on Ubuntu 12.04 x86_64 without Danish
> language-pack.

I got the version wrong I tried with. That's LO 3.6.0.1
Comment 7 Julien Nabet 2012-11-20 19:35:30 UTC
On pc Debian x86-64 with master sources updated today and 3.6 sources updated yesterday, I don't reproduce this bug.
Just for the test, could you rename your LO profile (see http://wiki.documentfoundation.org/UserProfile) and test again?
If you still reproduce, we may have extra information if you follow this:
http://wiki.documentfoundation.org/BugReport#How_to_get_debug_information_.28on_Mac_OS_X.29

About comment1, it makes me think about fdo#56335 (see https://bugs.freedesktop.org/show_bug.cgi?id=56335).
Comment 8 Emir Sarı 2012-11-23 02:23:20 UTC
Not reproducible on LO 3.6.4.1 OS X 10.7.5

Seems like not Mac-related.

Setting status to NEEDINFO.
Comment 9 Rainer Bielefeld Retired 2012-11-23 06:26:04 UTC
@Emir Sarı
You forgot to tell what info you need?!
<http://wiki.documentfoundation.org/QA-FAQ#How_to_use_Status_or_Keyword_NEEDINFO>
(I added some more precise info)
Comment 10 Julien Nabet 2012-11-23 06:30:17 UTC
Mart: could you provide extra information by following this link? http://wiki.documentfoundation.org/BugReport#How_to_get_debug_information_.28on_Mac_OS_X.29

Moreover, did you install any LO specific extensions?
Comment 11 QA Administrators 2013-07-18 06:16:15 UTC
Dear Bug Submitter,

Please read the entire message in its entirety before continuing - also please respond directly to FDO when replying - do not reply via email.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 12 QA Administrators 2013-09-24 02:06:35 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO