Bug Hunting Session
Bug 57290 - EDITING: Text formatting keyboard shortcuts do not work when on non-Latin keyboard layouts (e.g. Arabic, Russian)
Summary: EDITING: Text formatting keyboard shortcuts do not work when on non-Latin key...
Status: RESOLVED DUPLICATE of bug 41169
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-19 20:05 UTC by hilobakho
Modified: 2012-11-24 03:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hilobakho 2012-11-19 20:05:52 UTC
Problem description: 
When on Ukrainian or Russian, changing bold italic and underline with hotkeys doesn't work. Everything's OK in English.
Steps to reproduce:
1. Switch to Ukrainian
2. Try to change font style with ⌘B, ⌘I etc.
3. ???
4. Fail.

Current behavior:
Doesn't switch.
Expected behavior:
Switches.
Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11
Comment 1 Emir Sarı (away) 2012-11-23 02:31:41 UTC
Reproducible on OS X 10.7.5 LO 3.6.4.1

Not reproducible under XP SP3 LO 3.6.2.2

Important info: This issue is not only Cyrillic-related, non-Latin keyboard layouts do not work at all. 

Tried with:
-Generic Russian layout
-Generic Kazakh layout
-Generic Arabic layout
-Custom Arabic layout
Comment 2 Emir Sarı (away) 2012-11-23 02:33:52 UTC
Reproducible also in Calc, so setting component to Libreoffice.
Comment 3 Emir Sarı (away) 2012-11-24 03:30:59 UTC

*** This bug has been marked as a duplicate of bug 41169 ***