Download it now!
Bug 57297 - MAILMERGE: Mail Merge Wizard won't proceed past selecting an address book
Summary: MAILMERGE: Mail Merge Wizard won't proceed past selecting an address book
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2012-11-19 22:59 UTC by Leon Arundell
Modified: 2017-07-14 12:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Arundell 2012-11-19 22:59:04 UTC
Problem description: When using the mail merge wizard I can select an address book, but the wizard won't let me proceed past that point.

Steps to reproduce:
1. Open a text document
2. From the menu, select "Tools > Mail Merge Wizard ..."
3. Select "Use the current document" and click "Next >>"
4. Select "Letter" or ""Email message" and click "Next >>"
5. Click "Select address list ..."
6. If necessary, create a suitable address list
7. Click on a suitable address list and click "OK"

Current behavior: 

A. From the end of Step 2 above, the following mail merge steps are greyed out and inoperative:
. "Create salutation"
. "Adjust layout"
. "Edit document"
. "Personalise document"
. "Save, print or send."

B. The "Next >>" and "Finish" boxes are greyed out and inoperative.

Expected behavior: The "Next >>" box will be available and will allow me to proceed.

Platform (if different from the browser): Ubuntu 12.04
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 humphries.edwin 2013-06-12 03:30:24 UTC
I have noted the exact same issue on LibreOffice 4.0.3.3 running under Linux Mint 13 x64.
Comment 2 Giorgio 2013-11-02 21:17:08 UTC
Hello, same faulty behaviour with linux UBUNTU 13:10 and Libre Office and Version: 4.1.2.3  Build ID: 410m0(Build:3)
Comment 3 Doug Naphas 2013-11-24 21:03:17 UTC
I reproduced this with version 4.3.0.0.alpha0+, Build ID 393ece995a0761a72c8341bf56e40fe4c57a4824, on Ubuntu 12.04.
Comment 4 Björn Michaelsen 2014-04-25 12:44:07 UTC
I cant reproduce this in current master (38b9fe826903e661238388a93c9a283467e2d9f7 from  Fri Apr 25 10:41:08 2014 +0200). The wizard steps are all active and the buttons operate. Can you recheck if this still in an issue on current master?
Comment 5 Leon Arundell 2014-04-26 01:00:05 UTC
The problem is worse in LibreOffice 4.2.3.3 under Ubuntu 14.04.

At Step 7, "OK" is greyed out and I cannot select an address list.
Comment 6 Rod 2014-08-30 11:10:07 UTC
+1
Comment 7 pablito 2014-11-01 14:27:09 UTC
+1 under LO Writer 4.2.6.3. Tried using CSV and ODS as source. Same problem, 'Ok' button remains greyed out.
Comment 8 pablito 2014-11-02 11:40:03 UTC
(In reply to pablito from comment #7)
> +1 under LO Writer 4.2.6.3. Tried using CSV and ODS as source. Same problem,
> 'Ok' button remains greyed out.

Oh and that was under Linux Mint 17. I also tried 4.3.3.2 (latest) under Windows 8 and that worked a great.
Comment 9 Joel Madero 2014-11-04 16:37:20 UTC
So - typically without QA confirming we don't move these forward but with a few independent confirmations. I'm going to go ahead and mark this as NEW, REOPENED is incorrect. Thanks
Comment 10 QA Administrators 2015-12-20 16:14:05 UTC Comment hidden (obsolete)
Comment 11 JcFR 2017-05-09 11:03:04 UTC
Tested with LibreOffice 5.3.2.2 x64 : the bug is still present.

Mailmerge was broken sometimes after version 5.1.5.2 (this is the latest functional version for me).
Comment 12 dd 2017-06-22 12:10:11 UTC
Yes, I can confirm this is still a problem.

In some of the other reports, there were mentions of the MM wizard saving configuration/states in the user profile. I have tried deleting/emptying the profile folder in Windows but this did not help. I also tried Safe Mode with different options, but this did not help either.

Any more suggestions on how to reset the LO and/or Mail Merge configuration in any other wat?
Comment 13 Timur 2017-07-14 10:42:52 UTC
This bug was reported for LO 3.5 when MMW had 8 steps. There was a change in LO 5.2 to have 5 steps. That doesn't automatically renders this bug invalid but I did notice the following.

I tested 5.1, when it had 8 steps:
3. Insert Address Block you can't pass ("Next >>" and "Finish" greyed out) until you "Select address list ..." which is correct. 
Once you select list, you cannot proceed until you select block with matched fields, which is not correct, but it's not what's reported in this bug. 
4. "Create salutation" "Next >>" is greyed out if personalized salutation is checked but not matched. Can be unchecked. Correct. 
5. "Adjust layout" "Next >>" is available.
6. "Edit document"  "Next >>" is available (but not relevant anymore)
7. "Personalise document"  "Next >>" is available (but not relevant anymore)
8. "Save, print or send." "Next >>" not possible. Logic was to use buttons below options, so "Finish" available after that. Not relevant anymore.

I tested 6.0+, which is how it looks from 5.2:
3. Insert Address Block you can't pass ("Next >>" and "Finish" greyed out) until you "Select address list ..." which is correct. 
Once you select list, you cannot proceed until you match fields, which is correct. You may turn off address block. 
4. "Create salutation" "Next >>" is greyed out if personalized salutation is checked but not matched. Can be unchecked and then both ("Next >>" and "Finish" are available. Correct. 
5. "Adjust layout" Last step "Next >>" not possible and "Finish" available.


I'll set this to WorksForMe. If the problem is clearly reproduced again with current LO, feel free to set again to New since it was confirmed before, but explain what exactly is expected and where. 
Please test with fresh 5.3 or better with master 6.0+ available from http://dev-builds.libreoffice.org/daily/master/.
Important: test with empty address list or clean profile per https://wiki.documentfoundation.org/UserProfile. Or be aware of existing address list and report it's behavior. 

Please note that I intend to report block and matched fields logic separately because the bug was not originally about it.