Bug 98799 - MAILMERGE: Wizard: after in Step#3 selecting with "This document shall.." the Next/Finish button don't work any more
Summary: MAILMERGE: Wizard: after in Step#3 selecting with "This document shall.." the...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Mail-Merge 102930
  Show dependency treegraph
 
Reported: 2016-03-21 13:02 UTC by Cor Nouws
Modified: 2017-07-14 15:29 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2016-03-21 13:02:34 UTC
Version: 5.2.0.0.alpha0+
Build ID: b86b97e54590872fc0ea85fbea22c2d00d241181
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:master, Time: 2016-03-19_00:48:09
Locale: nl-NL (nl_NL.UTF-8)

1. New Writer document
2. Start Tools > Mail Merge Wizard
3. Step #1; take default: Use the current document; Next
4. Step #2; take default: Letter; Next
5. Step #3; select: "This document shall .."
   > Buttons Next or Finish are not functioning
   
6. Step #3; deselect: "This document shall .."
   > Buttons Next or Finish are again working

(for testing the next bug - to be filed - check  "This document shall .." and continue with Finish.
Then close LibreOffice)
Comment 1 Cor Nouws 2016-03-22 07:29:40 UTC
well, I did write that I never used the Wizard, did I?

So this behavior exists too in 5.0.5.2, and if I'm not mistaken in 3.6.6.1. It has nothing the do with the current changes.
Comment 2 Buovjaga 2016-03-31 10:42:32 UTC
Reproduced.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 15b53976e5d119877e53f34b34cee33a5f2883fd
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-03-22_23:57:30
Locale: fi-FI (fi_FI)
Comment 3 Julien Nabet 2016-12-30 15:12:25 UTC
I think it's because you must match fields first.
If you give a try to tdf#105002, it seems the match is automatically ok.
I must recognize I don't very few about MM since I don't use it :)
Comment 4 Gabor Kelemen 2017-03-08 10:26:14 UTC
Gave this a try, indeed you need first match the fields with the Match Fields button.

Maybe we could document this part a bit better? Current help page does not mention the necessity of this step.
Comment 5 dd 2017-06-22 12:00:57 UTC
Gabor, do you perhaps have a link to the help page you are referring to? Perhaps I can make a change there.
Comment 6 Buovjaga 2017-06-22 12:20:23 UTC
(In reply to dd from comment #5)
> Gabor, do you perhaps have a link to the help page you are referring to?
> Perhaps I can make a change there.

There is not yet a simple way to edit help, but the documentation mentor has kindly agreed to input help additions sent to him in a simple format (Writer file). The doc team really needs more people, so do consider joining for a longer period of time.

http://documentation.libreoffice.org/en/join-community/update-help-contents/

The help files for mail merge seem to be here, see at the bottom, the ones starting with mailmerge or mm_:
https://gerrit.libreoffice.org/gitweb?p=help.git;a=tree;f=source/text/swriter/01

You could install offline help and find the pages there more easily..
Comment 7 Gabor Kelemen 2017-06-22 12:44:48 UTC
Already submitted a patch, comments are welcome:
https://gerrit.libreoffice.org/#/c/38546/
Comment 8 Commit Notification 2017-07-13 18:37:59 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=5e623a924db3b7de6c39419f1a7b764a23de1b96

tdf#98799 tdf#102930 Document the logic of the MM wizard 3rd page
Comment 9 Timur 2017-07-14 10:55:51 UTC
https://bugs.documentfoundation.org/show_bug.cgi?id=57297#c13:
In 6.0+ (before the patch), which is how it looks from 5.2:
3. Insert Address Block you can't pass ("Next >>" and "Finish" greyed out) until you "Select address list ..." which is correct. 
Once you select list, you cannot proceed until you match fields, which is correct. You may turn off address block. 
4. "Create salutation" "Next >>" is greyed out if personalized salutation is checked but not matched. Can be unchecked and then both ("Next >>" and "Finish" are available. Correct. 

(In reply to Gabor Kelemen from comment #4)
> Gave this a try, indeed you need first match the fields with the Match
> Fields button.
UI order needs to be changed, not Help.

In my view, this bug was NotABug. 
But now, if documentation was changed, OK. 
We should close this one and report this block and matched fields logic and order separately, what I intend to do. 

MM needs Help update on a number of steps, F1 often shows empty page.
Comment 10 Timur 2017-07-14 15:29:37 UTC
On rethinking this, I give up the idea of UI change. 
Whole point of "3. Insert Address Block" is to insert address block with matched fields and current order is fine. 
Or we can simply use Data Sources, without Wizard.