Download it now!
Bug 57315 - Unknown option -Embedding when try CoCreateInstance() of com.sun.star.ServiceManager
Summary: Unknown option -Embedding when try CoCreateInstance() of com.sun.star.Service...
Status: RESOLVED DUPLICATE of bug 57203
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: sdk (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-20 09:58 UTC by Andrzej Kilijański
Modified: 2013-11-16 18:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
WriterDemo VBScript (6.40 KB, text/plain)
2012-11-30 05:32 UTC, Eugene Kin
Details
com.sun.star.ServiceManager (83.31 KB, image/jpeg)
2012-11-30 05:35 UTC, Eugene Kin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrzej Kilijański 2012-11-20 09:58:56 UTC
Hello, 
When I try connect to LibreOffice with COM brige using CoCreateInstance() with class "com.sun.star.ServiceManager" LibreOffice shows Unknown option -Embedding error.

Connecting to LibreOffice works in 3.6.2.2 release but not working in 3.6.3.2 and 3.6.4.1.

Tested on Win7 32bit and WinXP.
Comment 1 Eugene Kin 2012-11-30 05:32:58 UTC
Created attachment 70812 [details]
WriterDemo VBScript
Comment 2 Eugene Kin 2012-11-30 05:35:20 UTC
Created attachment 70813 [details]
com.sun.star.ServiceManager
Comment 3 Eugene Kin 2012-11-30 05:35:50 UTC
Confirm the issue with com.sun.star.ServiceManager since LibO 3.6.3.1 (including 3.6.4.3)
There is no such problem in LibO 3.6.2.2
Tested with WriterDemo.vbs on Windows 7 SP1
Comment 4 Jan Keirse 2012-12-03 09:10:17 UTC
I have the same problem (Win 7, 64 bit). Note that it only happens if LibreOffice is not already running. So in order to reproduce it you have to first stop all running instances of LibreOffice.
Comment 5 Roman Polach 2012-12-06 13:12:26 UTC
This problem seems to be same as 57203 (?)
Comment 6 Aurimas Fišeras 2012-12-15 13:49:10 UTC
Duplicate of 57203.

*** This bug has been marked as a duplicate of bug 57203 ***