Download it now!
Bug 57368 - FORMULA SUMIF with brackets
Summary: FORMULA SUMIF with brackets
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-21 13:49 UTC by Alexander Urban
Modified: 2015-01-19 12:51 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
ODS file with above steps done. (7.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-11-21 13:49 UTC, Alexander Urban
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Urban 2012-11-21 13:49:38 UTC
Created attachment 70365 [details]
ODS file with above steps done.

Problem: SUMIF does not work when selecting by Text with brackets.

How to reproduce:

(Either see attached file or)

In empty spread sheet
Enter A1 Text: "VK 3001 (H)"
Enter B1 Number: 100
Enter D1 Text: "VK 3001 (H)"
Enter E1 Formular: "=SUMIF(A1;D1;B1)"

Enter A2 Text: "VK 3001 H"
Enter B2 Number: 100
Enter D2 Text: "VK 3001 H"
Enter E2 Formular: "=SUMIF(A2;D2;B2)" (or just pull down from E1)

Result E1: Number 0
Result E2: Number 100

I am using German version. Info window says 
"LibreOffice 3.5.6.2 
Build-ID: e0fbe70-5879838-a0745b0-0cd1158-638b327"
Comment 1 Alexander Urban 2012-11-21 16:16:10 UTC
I just updated LibreOffice.

Now I can confirm that

Version 3.6.3.2 (Build ID: 58f22d5)

is also affected by this bug.
Comment 2 Alexander Urban 2012-11-21 21:58:26 UTC
I just found out that escaping the brackets is a workaround.

How to reproduce:

Change A1 to "VK 3001 \(H\)"
Result E1: Number 100

Excel does not behave this way.

Please Change To Status: WORKSFORME ;)
Comment 3 m.a.riosv 2012-11-27 00:41:21 UTC
There is an option to disable regular expressions in:
Menu/Tools/Options/LibreOffice Calc/Calculate - Enable regular expressions in formulas.

I think is not a bug, it is how regular expression works.

Change status to:
Resolved NotaBug.

If you are not agree, please reset the status to unconfirmed.