Bug Hunting Session
Bug 57413 - Tools > Options > Language Settings > Languages > CRASH
Summary: Tools > Options > Language Settings > Languages > CRASH
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Eike Rathke
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-22 15:05 UTC by Korrawit Pruegsanusak
Modified: 2012-12-11 17:21 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
WinDbg session log (29.41 KB, text/plain)
2012-11-30 21:34 UTC, Korrawit Pruegsanusak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Korrawit Pruegsanusak 2012-11-22 15:05:50 UTC
As $subject says, Tools > Options > Language Settings > Languages > CRASH

with official 4.0.0.0.alpha1, new user profile, on Windows 7 x64 Home Premium, without Java Runtime Environment installed.
Comment 1 Korrawit Pruegsanusak 2012-11-22 15:17:52 UTC
Note: I've installed through administrative installation (msiexec /a $filename)

Note2: I've tried multiple times, sometimes it worked correctly, but sometimes crashed.

Deleting all program files and user profile, and reinstalling again (still msiexec /a) doesn't solve this problem.
Comment 2 Korrawit Pruegsanusak 2012-11-22 15:44:02 UTC
Nagy Ákos reported on l10n mailing list [1] that:

> I try it with windows 8 x64, without java and works fine (Romanian regional settings). 
> In windows 7 x64 enterprise with java (Hungarian regional settings) works fine too.

[1] http://nabble.documentfoundation.org/libreoffice-l10n-ANN-LibreOffice-4-0-0-ALPHA1-test-builds-available-tp4020240p4020274.html

My answer:
I've installed only from LibO-Dev_4.0.0.0.alpha1_Win_x86_install_multi.msi which is a multi-language installer. I didn't install any helppacks nor language packs. I use Thai regional settings for my Windows.
Comment 3 Rainer Bielefeld Retired 2012-11-22 16:10:15 UTC
NOT reproducible with parallel installation of  "LOdev  4.0.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: a2b3ee)]"  {2012-11-22} on German WIN7 Home Premium (64bit) with separate /4 User Profile for 4.0
I tried with Java 1.6 and without each 4 times
Comment 4 m.a.riosv 2012-11-22 21:34:04 UTC
Not reproducible.
Win 7x64 Ultimate
LODev Version 4.0.0.0.alpha0+ (Build ID: 04f2f0)
LODev Version 4.0.0.0.alpha0+ (Build ID: e05988) MinGW
LODev Version 4.0.0.0.alpha1+ (Build ID: 470029)
LODev Version 4.0.0.0.alpha1+ (Build ID: 9c4f31) MinGW
Java 1.0.9_09
Comment 5 baffclan 2012-11-23 07:01:55 UTC
Reproduce with Windows Vista-JA(Ultimate)
LibO UI is Japanese.
Comment 6 Petr Mladek 2012-11-23 10:51:45 UTC
Korrawit, what UI localization are you using, please?

I wonder if it visible only with non-en_US localizations and builds. I can't test it easily.
Comment 7 Korrawit Pruegsanusak 2012-11-23 11:10:10 UTC
(In reply to comment #6)
> Korrawit, what UI localization are you using, please?

English UI.

I started a newly installed, with new user profile created, and en_US should be the default UI, right? :)
Comment 8 baffclan 2012-11-23 12:50:06 UTC
I use custom install.
Languages UI selected Key ID, en-US and Japanese.
en-US and Japanese is No crash.
however, installed KeyID Language, Crash.
Comment 9 Petr Mladek 2012-11-27 11:38:36 UTC
baffclan, great catch. I see the crash as well when I install KeyID localization in 4.0.0.0.alpha1 build on Windows.

Andrash, could you please have a look? It might break testing of our translations community.
Comment 10 Korrawit Pruegsanusak 2012-11-30 21:32:50 UTC
Set to NEW as confirmed by comment 5 and comment 9.

I tried to build locally at tag libreoffice-4.0.0.0.alpha1 on Windows 7 x64, Visual C++ 2008 Express. My autogen.lastrun is:

--with-distro=LibreOfficeWin32
--with-mozilla-build=C:/mozilla-build
--with-ant-home=C:/apache-ant-1.8.4
--disable-directx
--disable-activex
--disable-atl
--with-lang=ALL
--enable-debug
--with-package-format=installed
--without-help

and got the WinDbg session log (see next comment). Hope it will be useful :-)
Comment 11 Korrawit Pruegsanusak 2012-11-30 21:34:39 UTC
Created attachment 70844 [details]
WinDbg session log

Following steps in comment 0, this log was generated.
Comment 12 Petr Mladek 2012-12-03 16:09:27 UTC
Thanks a lot for the backtrace. It points to the langtag stuff.

Eike, does it trigger any bell?
Comment 13 Eike Rathke 2012-12-03 16:33:07 UTC
No bell yet, and I haven't a Windows build ready. Taking over.
Comment 14 Eike Rathke 2012-12-06 18:11:15 UTC
So, after 2 days building I tried an installation (build dev-install, not msiexec stuff) on Windows 7 and attempted to fake the 'qtz' key ID resources by creating a corresponding share/registry/Langpack-qtz.xcd and I see the new "Default" entry in the "User interface" listbox, but no crash whatsoever.

The 'qtz' private use locale currently isn't properly handled so needs work anyway, but I have no clue what might cause the crash. Actually the liblangtag routines that according to the backtrace are involved in the crash, correctly say that this isn't a BCP47 registered locale..

Is the crash reproducible in current later than alpha1 builds?
Comment 15 Korrawit Pruegsanusak 2012-12-07 15:23:17 UTC
(In reply to comment #14)
> Is the crash reproducible in current later than alpha1 builds?

NOT REPRODUCIBLE with official 4.0 beta1 build. But note that I *can't* find KeyID language in language selection list. Also, I *can't* find KeyID language in installation wizard either.

Thanks for investigation, Eike :-)
Comment 16 Andras Timar 2012-12-07 18:19:24 UTC
(In reply to comment #15)
> NOT REPRODUCIBLE with official 4.0 beta1 build. But note that I *can't* find
> KeyID language in language selection list. Also, I *can't* find KeyID
> language in installation wizard either.

Yes, KeyID language was removed, because it did not work (not to mention the crash). I'd like to bring it back until beta2. I'll check, if it crashes, when I have a test build.
Comment 17 Eike Rathke 2012-12-11 12:14:37 UTC
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-0&id=19095016e005bc084a1b032ac5c70abf82178e02
brings back 'qtz' as known locale for key ID resources.
Comment 18 Eike Rathke 2012-12-11 17:21:06 UTC
I'm closing this for now with WORKSFORME, handling was changed and for locales known to us the liblangtag routines aren't called anymore, so in beta2 this wouldn't be reproducible anyway.