Download it now!
Bug 57419 - Thunderbird address book support not available
Summary: Thunderbird address book support not available
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:4.0.0 target:3.6.5
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-11-22 16:19 UTC by Lionel Elie Mamane
Modified: 2013-11-16 18:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot - do not see some non-latin symbols (11.84 KB, image/png)
2013-03-05 13:15 UTC, Nick222
Details
Screenshot - do not see some non-latin symbols (11.84 KB, image/png)
2013-03-05 13:18 UTC, Nick222
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2012-11-22 16:19:51 UTC
Version 4.0.0.0.alpha1 (Build ID: dec8fe) downloaded from http://dev-builds.libreoffice.org/pre-releases/deb/x86_64/

File / Wizards / Address Data Source

No "Mozilla / Netscape", nor "Thunderbird / Icedove" choice. It seems our new mork driver is not active, at least in my exact setup:

 - Debian GNU/Linux
 - Icedove from Debian package version 3.0.11-1+squeeze14

Was there in 3.6 and earlier (when compiled with mozilla, so not with packages made by Debian & Ubuntu, but was in our official builds, including our .deb packages).

On the other hand, 3.6 says 'no thunderbird address book exists', although there *is* an icedove address book.

Aha. After:

 $ ln -s .icedove .thunderbird

3.6 finds my icedove address book.

But 4.0.0.0.alpha1 still has no "Thunderbird / Icedove" choice. So regression.
Comment 1 DavidO 2012-11-22 21:52:05 UTC
have you tried it with your own build?
Comment 2 Lionel Elie Mamane 2012-11-23 10:19:41 UTC
(In reply to comment #1)
> have you tried it with your own build?

No, haven't build LibO/master/3.7-4.0 yet.
Comment 3 Julien Nabet 2012-12-01 14:21:55 UTC
On pc Debian x86-64 with master sources updated today (commit 1c6b63fa9aac2a80ca952e98678e186b9097db50), I don't reproduce this.

However, without the link .thunderbird to .icedove (when on Debian for example), I made 2 tests:

1) Base
I had connectivity/source/drivers/mork/MConnection.cxx:140: Can not parse mork file! in console when did this:
- start LO base
- Connect to an existing database
- chose Thunderbird/Icedove Address book
- Next
No table.

2) Writer
I did this:
- start LO Writer
- Menu File/Wizards/Address Data Source
- Select Thunderbird/Icedove
- Next
I had a popup telling "The file $filename$ could not be loaded."


After searching about "icedove" with OpenGrok, I found this:
79 { ".thunderbird/", ".mozilla-thunderbird/", ".mozilla/thunderbird/", ".icedove" }
in file: connectivity/source/drivers/mork/MNSFolders.cxx
Notice there's no "/" at the end of .icedove

So I just added one and both cases were ok (Writer and Base).
However noticed this on console during Writer test:
warn:legacy.osl:2183:1:/home/julien/compile-libreoffice/libo/unotools/source/config/confignode.cxx:425: OConfigurationNode::setNodeValue: could not replace the value: caught an IllegalArgumentException!
warn:legacy.osl:2183:1:/home/julien/compile-libreoffice/libo/connectivity/source/sdbcx/VCollection.cxx:114: OCollection::reFill: collection isn't empty

Last thing:
I noticed the same lacking of "/" in connectivity/source/drivers/mozab/bootstrap/ so updated it too.

See https://gerrit.libreoffice.org/gitweb?p=core.git;a=commitdiff;h=ea5a96a5c771ee2c2ebbe4c12c4e7f3b1cba29a7
Comment 4 Julien Nabet 2012-12-01 14:39:26 UTC
I runned the test on 3.6 sources, I had the same problems than with master (when there's no link .thunderbird to .icedove)
So my commit 8d7e1a6e13008bd7d35896e676796196038f1105 was buggy (see  http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d7e1a6e13008bd7d35896e676796196038f1105)

I asked on IRC for pushing this fix on 3.6 branch. I'll keep you informed.
Comment 5 Julien Nabet 2012-12-01 14:49:27 UTC
Since on IRC Markus advised me to use gerrit or to send a post on dev mailing list, I sent a post here:
http://nabble.documentfoundation.org/PATCH-for-3-6-Lacking-quot-quot-with-icedove-prevents-to-use-Icedove-addressbook-td4021928.html
Comment 6 Lionel Elie Mamane 2012-12-02 20:19:38 UTC
Verified fixed in
Version 4.0.0.0.alpha1+ (Build ID: 82949bd170719fcdfaff4a53809551ceb5136da)
from
http://dev-builds.libreoffice.org/daily/Linux-x86_64_11-Release-Configuration/master/current/master~2012-12-01_23.49.48_LibO-Dev_4.0.0.0.alpha1_Linux_x86-64_install-deb_en-US.tar.gz

@julien: when preparing a "ready to commit" patch concerning a bug, please start the commit message with "fdo#NNNNN" where NNNNN is the bug number. This allows the system to automatically put a comment in the bug log and update the target:x.y.z in whiteboard
Comment 7 Julien Nabet 2012-12-02 21:00:03 UTC
Lionel: you're right. In fact, I didn't think it would solve your problem (anyway, should have put at least "related to fdo...").
I'm quite astonished it resolved yours since in all the cases, I could see the options (even if without .thunderbird, it didn't work).
Comment 8 Nick222 2013-03-05 13:15:33 UTC
Created attachment 75957 [details]
Screenshot - do not see some non-latin symbols
Comment 9 Nick222 2013-03-05 13:16:15 UTC
Xubuntu 12.10-64 Rus
Thunderbird 17.0.3
LibreOffice 4.0.1.1 (ID: 400m0(Build:1))

When opened Thunderbird address book by LO Base:

1) I can not see some non-latin symbols (see screenshot in attachment).

2) I can see contact records only from main address book ("Personal address book"), not from user-created address book.
Comment 10 Nick222 2013-03-05 13:18:01 UTC
Created attachment 75958 [details]
Screenshot - do not see some non-latin symbols
Comment 11 Lionel Elie Mamane 2013-03-05 13:18:47 UTC
(In reply to comment #9)
> Xubuntu 12.10-64 Rus
> Thunderbird 17.0.3
> LibreOffice 4.0.1.1 (ID: 400m0(Build:1))
> 
> When opened Thunderbird address book by LO Base:
> 
> 1) I can not see some non-latin symbols (see screenshot in attachment).
> 
> 2) I can see contact records only from main address book ("Personal address
> book"), not from user-created address book.

Please open new bugs for each of these different *new* issues / bugs instead of reopening *several* *different* bugs, and mixing two issues in the same bugzilla entry. As to non-main address book (user-created address books), did it work before (ANSWER IN THE NEW BUG YOU ARE GOING TO REPORT)?