Bug 57444 - Wizards for Fax and Letter do not launch
Summary: Wizards for Fax and Letter do not launch
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Andras Timar
URL:
Whiteboard: target:4.2.0 target:4.1.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-11-23 06:08 UTC by Rainer Bielefeld Retired
Modified: 2017-06-04 18:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-11-23 06:08:48 UTC
This problem has been reported by Pedro Lino on <libreoffice-qa@lists.freedesktop.org>

[Reproducible] with parallel installation of Master "LOdev  4.0.0.0.alpha1   -  ENGLISH UI / German Locale  [Build ID: dec8fe)]"  {tinderbox: @6, pull time 2012-11-13 06:07:28} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch

Steps how to reproduce:
1. Launch LibO
2. In Start center: menu 'File -> Wizards Letter...'
   Expected: Writer document opens in wizard
   Actual: Nothing

I do not know whether that's related, I tried with Java 1.6 and Java 1.7
Comment 1 Rainer Bielefeld Retired 2012-11-23 06:15:49 UTC
Already [Reproducible] with server-installation of Master "3.7.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: b255de8]" (tinderbox: Win-x86@6-fast, pull time 2012-06-05 23:16:58)

Works fine with "LibreOffice 3.6.4.1 rc" German UI/ German Locale [Build-ID: a9a0717] on German WIN7 Home Premium (64bit), so REGRESSION
Comment 2 m.a.riosv 2012-11-23 09:11:23 UTC
Win 7x64 Ultimate

Reproducible with:
LODev Version 4.0.0.0.alpha1+ (Build ID: 9c4f31)MinGW
master~2012-11-21_22.41.41_LibO-Dev_4.0.0.0.alpha1_Win_x86_install-arc_en-US.tar

Not reproducible with:
LODev Version 4.0.0.0.alpha1+ (Build ID: 470029)
master~2012-11-22_00.49.34_LibO-Dev_4.0.0.0.alpha1_Win_x86_install_en-US.msi
Comment 3 Pedro 2012-11-23 11:56:49 UTC
Problem fixed in build Version 4.0.0.0.alpha1+ (Build ID: f1035c16609e03827f912d53e183e54585169f0)

Wizard no longer requires Java.

Apparently someone was working on this. It was just bad luck that Alpha1 coincided with a non-working wizard :)
Comment 4 Rainer Bielefeld Retired 2012-11-23 12:44:07 UTC
Correct Version due to  Comment 3
AFAIK we still are in the branch, so that the fix should be in 4.4.0

@Pedro:
please always contribute info concerning the pull date of the build
Comment 5 Pedro 2013-01-16 11:06:06 UTC
Reopened the bug. Both wizards don't work in 4.0.0.1 although they work correctly in LOdev builds. Maybe there are some hard coded paths?
Comment 6 Rainer Bielefeld Retired 2013-01-16 13:02:25 UTC
[Reproducible] with parallel installation of  "LOdev  4.0.0.1 rc   -  GERMAN UI / German Locale  [Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)]"  {tinderbox: @6, pull time 2013-01-10(?)} on German WIN7 Home Premium (64bit) with separate new/40 User Profile for Master Branch

Vanished again with server  installation of  "LOdev  4.0.0.1+   -  ENGLISH UI / German Locale  [Build ID:  fa16c2d432c6054edd2dede556876f5455b7e26)]"  {tinderbox: Win-x86@6, pull time 2013-01-15 06:44:14} on German WIN7 Home Premium (64bit) with own separate User Profile.

But I hesitate to close this on WFM, we should not risk to have a not working Wizard every third build.

This one would affect many users, so MAB
Comment 7 Jean-Baptiste Faure 2013-01-16 13:23:39 UTC
For me this bug is the same as bug 59248 which is fixed by https://gerrit.libreoffice.org/gitweb?p=core.git;a=commit;h=b5c1b435378e1e4c99416eb865477123ab596c85

Best regards. JBF
Comment 8 Joel Madero 2013-01-16 16:09:06 UTC
Confirming Jean's comment, look like that patch fixed it.

Marking as FIXED. If I'm incorrect please reopen it as NEW (not REOPENED since it's not actually assigned to anyone). Thanks all
Comment 9 Pedro 2013-01-17 11:58:57 UTC
(In reply to comment #8)
> Confirming Jean's comment, look like that patch fixed it.
> 
> Marking as FIXED. If I'm incorrect please reopen it as NEW (not REOPENED
> since it's not actually assigned to anyone). Thanks all

Again I repeat: this bug has been fixed in Windows daily builds (LOdev) since November 2011. However it does NOT work in 4.0 RC1. Proving that it does work in any Daily build is no guarantee that it will work on the Final release. This should remain open until it is tested on RC2.
Comment 10 Rainer Bielefeld Retired 2013-01-17 15:29:29 UTC
(In reply to comment #9)
@Pedro 
I think you are wrong. 2011 a Bug with similar / same problem has been fixed.
I am pretty sure that the fix mentioned by  Jean-Baptiste Faure really fixes the current "somehow new" problem.

Still WFM with server  installation of  "LOdev  4.0.0.1+   -  ENGLISH UI / German Locale  [Build ID:  072fc07107e9849ed7050d18575b42049db9657)]"  {tinderbox: Win-x86@6, pull time 2013-01-16 09:31:57} on German WIN7 Home Premium (64bit) with own separate User Profile
Comment 11 Valter Mura 2013-11-01 13:11:02 UTC
I reopened the bug, because I cannot use the Wizards for Letter, Fax and Agenda.

If I click on File/Wizards/Letter, etc, the program does nothing.

I can use the Web Page or Presentation

I don't know if it is something related to Templates, which are currently empty.

My System:

Kubuntu 13.10 (64-bit) / KDE 4.11.2
Recognised Java version: 1.7.0_25 (Oracle)
Comment 12 Jean-Baptiste Faure 2013-11-01 16:20:18 UTC
(In reply to comment #11)
> I reopened the bug, because I cannot use the Wizards for Letter, Fax and
> Agenda.

These wizards have been rewritten in python. You should check your python installation.

Best regards. JBF
Comment 13 Andras Timar 2013-11-19 13:02:46 UTC
It works for me with builds from both libreoffice-4-1 and master branches, I've just closed bug 68788.
Comment 14 NoOp 2014-02-18 04:42:51 UTC
This issue is not resolved in 4.1.5.3
LibreOffice_4.1.5.3_Linux_x86-64_deb
Version: 4.1.5.3
Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24

Runing the File|Wizard|Letter:

$ /opt/libreoffice4.1/program/soffice
Traceback (most recent call last):
  File "/opt/libreoffice4.1/program/wizards/letter/LetterWizardDialogImpl.py", line 105, in startWizard
    self.initializePaths()
  File "/opt/libreoffice4.1/program/wizards/ui/WizardDialog.py", line 118, in initializePaths
    xPropertySet.getPropertyValue("Template_user")[0]
IndexError: tuple index out of range

The File|Wizard|Presentation and Address Data Source are the only wizards that work.
Comment 15 NoOp 2014-02-18 04:55:59 UTC
Closing as works for me. I nuked the previous user profile and restarted LO - the Wizards now work with the new user profile. Sorry for the noise.
Comment 16 vihsa 2017-06-04 04:06:03 UTC
according to comment 13, 15; verified, hence status change.
Comment 17 Jean-Baptiste Faure 2017-06-04 18:57:55 UTC
Not sure if it is a good idea to set status to verified when the status was WorksForMe (we do not know which commit fixed the bug) and you did not check yourself (at least you did not say that you verified yourself that it work as expected). So set status back to WorksForMe.

Best regards. JBF