Bug 57500 - EDITING: CRASH when manage conditional formatting - double click range
Summary: EDITING: CRASH when manage conditional formatting - double click range
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:4.0.0
Keywords: regression
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-11-25 07:04 UTC by Rainer Bielefeld Retired
Modified: 2012-11-25 10:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample Document (7.92 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2012-11-25 07:30 UTC, Rainer Bielefeld Retired
Details
bt with symbols + console logs (2.28 KB, text/plain)
2012-11-25 08:35 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-11-25 07:04:22 UTC
Steps how to reproduce with parallel installation of  "LOdev  4.0.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: a2b3ee)]"  {2012-11-22} on German WIN7 Home Premium (64bit) with separate /4 User Profile for 4.0

1. open attached sample document "sample2.odt"
   > should open showing sheet "step2", cell cursor at H35
2. Menu 'Format -> Conditional Formatting -> Manage'
   > Dialog opens, shows 1 Range B2:K35
3. Double click in dialog on range  B2:K35 below column heading "Range"
   CRASH

Same with Attachment 60391 [details] of Bug 48970 and other documents

Was still ok with 
- parallel installation of "LOdev  4.0.0.0.alpha1  -  German UI / German Locale  [Build ID: dec8fe)]"  {tinderbox: @6, pull time 2012-11-13 06:07:28} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch
- server-installation of Master "3.7.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: b255de8]" (tinderbox: Win-x86@6-fast, pull time 2012-06-05 23:16:58)
- unzipped MinGW Master "3.7.0.0.alpha+ [Build ID: 4deb9d4] English Locale/UI {Win-x86@7-MinGW   pull time 2012-08-31 05:20:19} on WIN7 Home Premium (64bit)
Comment 1 Rainer Bielefeld Retired 2012-11-25 07:30:05 UTC
Created attachment 70534 [details]
Sample Document

Still  [Reproducible] with parallel installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: af60316514f3ae3d4c475819bf86f2af837171e)]"  {tinderbox: Win-x86@6, pull time 2012-11-23 22:10:31} on German WIN7 Home Premium (64bit) with own separate User Profile
Comment 2 Julien Nabet 2012-11-25 08:35:52 UTC
Created attachment 70535 [details]
bt with symbols + console logs

On pc Debian x86-64 with master sources updated today (commit a4f0c2696b1b32a9a233d377c28570135c29b5a1), I reproduced the problem.

    215 IMPL_LINK_NOARG(ScCondFormatManagerDlg, EditBtnHdl)
    216 {
    217     ScConditionalFormat* pFormat = maCtrlManager.GetSelection();
    218 
    219     if(!pFormat)
    220         return 0;
    221 
    222     boost::scoped_ptr<ScCondFormatDlg> pDlg;//(new ScCondFormatDlg(this, mpDoc, pFormat, pFormat->GetRange(),
    223                                               //  pFormat->GetRange().GetTopLeftCorner(), condformat::dialog::NONE));
    224     if(pDlg->Execute() == RET_OK)
    225     {

pDlg isn't initialized here (since commit ffadab26d62a24f3a142c497669db5a933ba1251 I suppose)
Comment 3 Julien Nabet 2012-11-25 08:36:22 UTC
Markus: one for you I suppose?
Comment 4 Markus Mohrhard 2012-11-25 10:19:47 UTC
This bug has the same reason as the disabled Add and Edit button. Till the feature freeze I'll fix this.
Comment 5 Not Assigned 2012-11-25 10:24:05 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5edf0adc8594aedd3c26d424ffd99c734028b138

disable this for now, fdo#57500



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.