Bug Hunting Session
Bug 57514 - FORMATTING: Function FORMAT PAINTBRUSH doesn't work properly in several ways
Summary: FORMATTING: Function FORMAT PAINTBRUSH doesn't work properly in several ways
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 75696 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-25 12:29 UTC by A (Andy)
Modified: 2015-01-02 17:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file from 'steps to reproduce' in the description. (9.47 KB, application/vnd.oasis.opendocument.text)
2013-10-26 10:15 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2012-11-25 12:29:44 UTC
Problem description: 
If you copy the format of a text string to another text string, so the function FORMAT PAINTBRUSH doesn't work properly and copies the format only partly correct.  It works in several ways not correctly respectively as desired.  

Steps to reproduce:
1. Open WRITER.
2. Write any sentence with several words and then write a further sentence on the next (second) line and on the third and fourth line.
3. Select the first half of the sentence in line 1 and format it as BOLD and UNDERLINED.
4. Select the whole sentence in the second line and format it in another FONT TYPE and FONT SIZE.
5. Select the whole sentence in the third line and choose the icon FONT COLOR and format in a different color.
6. Select only a part of the sentence in the fourth line and choose the icon HIGHLIGHTING and highlight it in any color.


Bug 1 & 2:
7. Now select the whole sentence in the second line and choose the icon FORMAT PAINTBRUSH and select only a part of the sentence in the first line.

Current behavior:
Not only the selected part in the first line gets the new font, but the whole line even if it is not selected.
Furthermore, there is another bug, that you can't undo this formatting if you choose the icon UNDO.

Expected behavior:
Only the selected text string should get the new font type and size, but not the whole line.
The function UNDO should work.


Bug 3
Steps to reproduce:
8. Now select the text string in the first line which is not bold and underlined and choose the icon FORMAT PAINTBRUSH and select only the text string which is bold and underlined.

Current behavior:
Nothing happens.

Expected behavior:
The text string should no longer be bold and underlined.


Bug 4
Steps to reproduce:
9. Now select the whole text string in the third line with the different font color and choose the icon FORMAT PAINTBRUSH and select only a part of the text string in the first line.

Current behavior:
The whole sentence in line 1 gets the new color.

Expected behavior:
Only the selected text string should get the new color.


Bug 5
Steps to reproduce:
10. Now select only a part of the text string in the second line (which is not in another font color and not highlighted) and choose the icon FORMAT PAINTBRUSH and select only the part of the text string in the fourth line which is highlighted.

Current behavior:
It still remains highlighted.

Expected behavior:
It should no longer be highlighted.
Operating System: All
Comment 1 ydutrieux 2012-12-14 16:37:57 UTC
in libo Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Win7 32 bits.

>>> Bug1&2 not reproduced. formating is only on the selected part.

Bug3 : reproduced (text formating doesn't apply).

>>> Bug4 : not reproduced. formatting is only on the selected part.

Bug5 : reproduced (text remain highlighted.)

Yves.
Comment 2 Rainer Bielefeld Retired 2013-01-24 09:04:03 UTC
Problem 1 INVALID
---------
is not a Bug, but a user error.
Because  character formatting of line 2 is for the whole paragraph, it has become a paragraph style element, and so character style will be transferred as paragraph style to paragraph 1. By default 3.6.5 transfers Paragraph formatting + Character formatting, please see help. so observed behavior is correct

Problem 2
---------
I will have to think about that

Problem 3
---------
I will have to think about that

Problem 4 INVALID
---------
See Problem 1

Problem 5
---------
I will have to think about that 


I did a lot of tests for "Bug 59643 - Format Paintbrush cannot be correctly undone" and found different behavior in different Versions and rather complex relations. We will need a common sample document here and different Bugs for different problems with relation to the sample document here.

Currently the descriptions are too imprecise: Is a blank included into formatting, selected range or not? from where to where will the formatting be transferred. Such details can be very important.

@A:
Please leave a sample document here and create additional Bugs with reference to this bug and it's sample here due to <https://wiki.documentfoundation.org/QA-FAQ#How_to_use_attached_sample_documents_for_multiple_Bug_Reports>.
In those Bugs please add these details to your bug descriptions.
Please add in those bugs "57514" to "See also" and me to CC, I will try to reproduce aour results within short time.
Please cite HELP concerning your expectations
Comment 3 Rainer Bielefeld Retired 2013-03-07 21:43:48 UTC
Bug 61985, Bug 59643 might represent Problem 2 of this report,

To keep overview I added a note to whiteboard.

@A
Concerning your expectation for problem 3 please contribute a complete reasoning with citations of Help or similar.
Comment 4 QA Administrators 2013-09-24 02:01:11 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 5 Robinson Tryon (qubit) 2013-10-23 17:02:12 UTC
Remove unknown terms from the Whiteboard: "Terminated Problems: 1,2,4"

(No documentation of either term in our docs:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard)
Comment 6 Owen Genat (retired) 2013-10-26 10:15:44 UTC
Created attachment 88145 [details]
Test file from 'steps to reproduce' in the description.

I am providing an update for this bug. The original "steps to reproduce" create a document like that attached (Note: just the steps, NOT the subsequent bug testing). From my testing here under Ubuntu 10.04 running LO v4.1.2.2 only the initially indicated #3 problem (turning bold/underline formatted text back to something other than bold/underline) would still appear to behave in the indicated manner. All the other tests work as expected (i.e., no problem) under this version. 

The instructions in bug #59029 (comments 5 and 11 in particular) indicate that the format paintbrush facility has been altered to now only copy character attributes by default. Even so, I tried changing either the entire text "is sentence" on the first line to something other than bold/underline via click, CTRL+click, and CTRL+SHIFT+click all without success.

Is bold/underline somehow treated differently? Is this particular case (bold/underline) still valid?
Comment 7 sophie 2014-03-07 17:13:37 UTC
*** Bug 75696 has been marked as a duplicate of this bug. ***
Comment 8 Buovjaga 2015-01-02 17:20:41 UTC
Closing as INVALID per comment 6 and discussion with the QA team.