Bug 59029 - Format Paintbrush default changed to paste character formatting
Summary: Format Paintbrush default changed to paste character formatting
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: All All
: highest minor
Assignee: Not Assigned
URL:
Whiteboard: BSA bibisected40
Keywords: regression
: 48331 61577 62569 62715 63387 68314 74292 87092 97270 (view as bug list)
Depends on:
Blocks: Clear-Formatting
  Show dependency treegraph
 
Reported: 2013-01-04 17:11 UTC by Roy Dyton
Modified: 2018-01-07 14:20 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect #59029 (2.66 KB, text/x-log)
2013-01-10 16:09 UTC, Joel Madero
Details
odt document with two paragraphs, each one with different character and paragraph format. (17.45 KB, application/vnd.oasis.opendocument.text)
2013-02-28 07:59 UTC, Reinhard Lamsfuss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roy Dyton 2013-01-04 17:11:09 UTC
Wished to amend the default tab position for auto numbering.
Manually achieved desired change.
Attempted to use format painter then to amend all subsequent paragraphs to the desired one.  Format painter did not achieve.
Needed to make a manual alteration to EACH paragraph.
Had an earlier problem with the format painter failing to operate as it usually does but this was for paragraph spacing, not tabbing.

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Windows XP
Version: 4.0.0.0.beta1
Comment 1 Jorendc 2013-01-09 17:39:03 UTC
Hi,

Thanks for reporting!

As far I can understand this is an enhancement request. Is it possible to be a bit more clear what you mean?

I'm sorry about that. I'll set this bug status to NEEDINFO; When it's totaly 100% clear what you mean, we can set it as 'NEW' and 'enhancement'.

Thanks in advance,
Joren
Comment 2 Roy Dyton 2013-01-09 19:24:37 UTC
This is not an enhancement request.  In earlier releases of Writer I was 
able to make a manual alteration to, say,

  * The indent and the spacing positions of numbered or bulleted paragraphs
  * The 'line spacing' after a specified paragraph style


and then use the format painter to transfer the manually altered style 
to all the other paragraphs I wanted to have an identical layout or 
indent appearance.  I was unable to do this and had to make a manual 
alteration to each paragraph.

Rgds

Roy Dyton
On 09/01/2013 17:39, bugzilla-daemon@freedesktop.org wrote:
> Joren De Cuyper <mailto:joren.libreoffice@telenet.be> changed bug 
> 59029 <https://bugs.freedesktop.org/show_bug.cgi?id=59029>
> What 	Removed 	Added
> CC 		joren.libreoffice@telenet.be
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=59029#c1> 
> on bug 59029 <https://bugs.freedesktop.org/show_bug.cgi?id=59029> from 
> Joren De Cuyper <mailto:joren.libreoffice@telenet.be> *
> Hi,
>
> Thanks for reporting!
>
> As far I can understand this is an enhancement request. Is it possible to be a
> bit more clear what you mean?
>
> I'm sorry about that. I'll set this bug status to NEEDINFO; When it's totaly
> 100% clear what you mean, we can set it as 'NEW' and 'enhancement'.
>
> Thanks in advance,
> Joren
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
> No virus found in this message.
> Checked by AVG - www.avg.com <http://www.avg.com>
> Version: 2013.0.2805 / Virus Database: 2637/6019 - Release Date: 01/08/13
>
Comment 3 Joel Madero 2013-01-10 15:43:00 UTC
Confirmed, regression.

Steps to reproduce:
Open writer
Type "this is a test" on one line in writer
Next line type "this is another test"
Make the first line indented several times
Highlight the first line and click the format paintbrush tool
Now highlight the second line

Expected:
The formatting on the first line should apply to the second

Observed:
Doesn't apply as expected

Marking: 
New (Confirmed)
Minor (makes it substantially harder to make high quality work but does not prevent high quality work, you can manually just edit your paragraphs/number lists, etc... to be the same as others, paintbrush just makes it tremendously more useful)
Highest (regression, hopefully fixed before stable release next month)

Roy thanks for reporting and clarifying
Comment 4 Joel Madero 2013-01-10 16:09:33 UTC
Created attachment 72787 [details]
Bibisect #59029
Comment 5 Michael Stahl (CIB) 2013-01-10 21:41:36 UTC
it's not a bug, it's a feature :)

with the bibisect range it is trivial to find this commit:

  commit 1574c76ec20d1da479ed7e9c85a6cefacc132dfe
  Author: Maxime de Roucy <mderoucy@linagora.com>
  Commit: Caolán McNamara <caolanm@redhat.com>

    Format paintbrush default behaviour
    
    Don't copy paragraph formats by default

which simply changes the default action from copying the
paragraph attributes to copying the character attributes.
this works as documented in the Help (index entry Paintbrush):

  By default only the character formatting is copied ; to include paragraph
  formatting, hold down Ctrl when you click. To copy only the paragraph
  formatting, hold down Ctrl+Shift when you click.
Comment 6 Joel Madero 2013-01-10 21:50:37 UTC
Thanks for the clarification Michael!
Comment 7 Rainer Bielefeld Retired 2013-02-28 06:58:30 UTC
*** Bug 61577 has been marked as a duplicate of this bug. ***
Comment 8 Reinhard Lamsfuss 2013-02-28 07:10:11 UTC
However, behavior seems not to be consistent. Sometimes some paragraph format settings are copied,but others are missing.
Comment 9 Reinhard Lamsfuss 2013-02-28 07:53:12 UTC
Sorry, but the behavior is a bit hard to understand:
  
"copy only the paragraph formatting, hold down Ctrl+Shift when you click" as described by comment #5 (https://bugs.freedesktop.org/show_bug.cgi?id=59029#c5)

Does not apply anymore to Version 4.0.1.1 rc, now Ctrl+Shift will apply all the format settings, character AND paragraph settings, try in attached file.
Comment 10 Reinhard Lamsfuss 2013-02-28 07:59:41 UTC
Created attachment 75666 [details]
odt document with two paragraphs, each one with different character and paragraph format.

text with two paragraphs with, the first with direct formatting. When you try to apply the settings of the first to the second with "Format paintbrush" holding ctrl+shift ALL the format setting are applied.
Comment 11 Maxime de Roucy 2013-02-28 09:50:17 UTC
I understand why you are confused…

It's a problem of definition of character and paragraph format. The paragraph formats are the format applied to the whole paragraph.
The character format are those applied to a portion of the paragraph.

Be careful though, if you apply the bold format to a whole paragraph, so the bold format is a paragraph format, and then unblod a portion of this paragraph, the bold format is still a paragraph format. This paragraph is divided in to parts, one without character format and one with the "unbold" character format.

I hope it's clearer.

I think I will modify the help.
Comment 12 manj_k 2013-03-20 19:17:49 UTC
*** Bug 62569 has been marked as a duplicate of this bug. ***
Comment 13 Michael Stahl (CIB) 2013-06-20 21:32:32 UTC
*** Bug 63387 has been marked as a duplicate of this bug. ***
Comment 14 Joel Madero 2013-08-07 16:40:33 UTC
*** Bug 62715 has been marked as a duplicate of this bug. ***
Comment 15 Stanislav Horacek 2013-09-05 19:24:56 UTC
*** Bug 68314 has been marked as a duplicate of this bug. ***
Comment 16 Joel Madero 2014-07-12 04:50:10 UTC
*** Bug 74292 has been marked as a duplicate of this bug. ***
Comment 17 Kevin Suo 2014-12-08 08:02:04 UTC
*** Bug 87092 has been marked as a duplicate of this bug. ***
Comment 18 Kevin Suo 2014-12-08 08:13:30 UTC
I see there are so many duplicates for this one, while this bug was closed as NOTABUG.

I am wondering what's the logic behind the change to paintbrush's default behaviour to not copy paragraph format.

Users will never know this "feature" unless they are told that this is a "feature", that if they want to copy the paragraph format they have to do "CTRL + SHIFT + paint".

It seems that MSO 2010 behaves like this:
* If only chars are selected for the painting, then only char formats are copied.
* If a whole paragraph is selected for the painting, then paragraph formats are copied.
Comment 19 Kevin Suo 2014-12-08 08:17:57 UTC
See:
Copying Attributes With the Format Paintbrush
https://help.libreoffice.org/Common/Copying_Attributes_With_the_Format_Paintbrush

Which says:
> By default only the character formatting is copied ; to include paragraph formatting, hold down Ctrl when you click. To copy only the paragraph formatting, hold down Ctrl+Shift when you click.
Comment 20 Cor Nouws 2016-01-21 12:40:47 UTC
*** Bug 97270 has been marked as a duplicate of this bug. ***
Comment 21 Cor Nouws 2016-01-21 12:42:43 UTC
*** Bug 48331 has been marked as a duplicate of this bug. ***