Download it now!
Bug 87092 - Format painter does not apply bullets and numbering style
Summary: Format painter does not apply bullets and numbering style
Status: RESOLVED DUPLICATE of bug 59029
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0 beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected
Depends on:
Blocks:
 
Reported: 2014-12-08 07:29 UTC by Kevin Suo
Modified: 2015-12-15 11:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-12-08 07:29:52 UTC
The format painter does not work to bullets and numbering any more in Writer. This is a regression against previous versions.

Steps to reproduce:
1. New Writer;
2. Type "a", hit ENTER; then type "b", hit ENTER.
3. Bullets (or numbering) on for paragraph "a".
3. Select paragraph "a", then click the format painter icon button.
4. Paint on paragraph "b".

Current behaviour:
Bullets (or numbering) is not applied to paragraph "b".

Expected behaviour:
After format painting is applied, paragraph "b" should show the same bullets (or numbering) style as paragraph "a".

Reproduded with:
Version: 4.4.0.0.beta1
Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e
Locale: zh_CN

Version: 4.3.5.1
Build ID: 8fd0451cc08e6a5310bed8b7ad1c46b93c1c6889

Windows 7 X64 and Linux
Comment 1 Kevin Suo 2014-12-08 07:49:53 UTC
Already broken in 3.7.0 alpha 1.

Bibisected using bibisect-42all:

1bfe96acc2fce1aa77ceca4c16ad93d85b033b39 is the first bad commit
commit 1bfe96acc2fce1aa77ceca4c16ad93d85b033b39
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon Dec 10 00:39:03 2012 +0000

    source-hash-836822522a2e9f009c0870cbbcd48d45bbd3c622
    
    commit 836822522a2e9f009c0870cbbcd48d45bbd3c622
    Author:     Rafael Dominguez <venccsralph@gmail.com>
    AuthorDate: Sat Jul 14 15:53:42 2012 -0430
    Commit:     Rafael Dominguez <venccsralph@gmail.com>
    CommitDate: Sun Jul 15 08:15:19 2012 -0430
    
        Create overlay for online templates.
    
        Change-Id: Ie09c91e23527d3e1389fc13bd13a8234bda080f3

suokunlong@KevinVirtualBox:~/lo/bisect/bibisect-42all$ git bisect log
# bad: [eb01a04acbb7373331312a2ee3d9d90d20548fca] source-hash-ce90f99a2d66c2b998ad3f9f028e2ea623a757f5
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'last40onmaster' 'oldest'
# skip: [6091cff9527caea089e10f9bea3d3226e396b2c6] source-hash-c77918bb03974ff9be90c889f77e62ea0755052f
git bisect skip 6091cff9527caea089e10f9bea3d3226e396b2c6
# skip: [5478f58adef21d3378257c60396d29a8653bafd3] source-hash-c52ba433491afbca70aa1977a624c795bdd5b9ef
git bisect skip 5478f58adef21d3378257c60396d29a8653bafd3
# skip: [d51fc64c5993aab4a267af8b9425b2b24c2cd3ce] source-hash-877c96a601e6e50d0c7a8f704d57baec22f089c5
git bisect skip d51fc64c5993aab4a267af8b9425b2b24c2cd3ce
# good: [410e72033bef9d3ef638865addab23ca28107212] source-hash-14c4c26cea838b3fffb0b17ba440c29a6066fad1
git bisect good 410e72033bef9d3ef638865addab23ca28107212
# skip: [189d40d0ae631ee1d46da7aaf019c27cbdf1e026] source-hash-b0f170d7df9cff12535d2ecfd146b32b745a8ef8
git bisect skip 189d40d0ae631ee1d46da7aaf019c27cbdf1e026
# bad: [769583027b0158ac4b497355b0495fca5c54f53b] source-hash-a43a76cd5aa2f145f2cb43fcdbc8f21fb6c89af0
git bisect bad 769583027b0158ac4b497355b0495fca5c54f53b
# skip: [5bf3b624cdeb593e55402f44c730209f12813961] source-hash-4b4ca8030285bd66526ff5bb2b6ea5a75a6c6bc7
git bisect skip 5bf3b624cdeb593e55402f44c730209f12813961
# skip: [fb0ce84a03588593a081ac3a26b2ada2d960b76c] source-hash-1aa91a2d8e7db5cebff5b47f3005f1acff64d25e
git bisect skip fb0ce84a03588593a081ac3a26b2ada2d960b76c
# skip: [517b06fcbaceee61aa0ce4cc51663cc835444966] source-hash-06f20d73da21342046a480a6b22af69901351328
git bisect skip 517b06fcbaceee61aa0ce4cc51663cc835444966
# bad: [bed22df5ce7a2799abcd1ac6bd6b590d293482ce] source-hash-558476135865d9ae7b8801a82c177fd1098386ff
git bisect bad bed22df5ce7a2799abcd1ac6bd6b590d293482ce
# good: [09b9b2bf979295d83b5a96c42dc2e4dbdc11e8a2] source-hash-13cb9d9d1ac672d6ef22cee98237b0285e03cda3
git bisect good 09b9b2bf979295d83b5a96c42dc2e4dbdc11e8a2
# bad: [fdbec4dce86360a09cf6b4af98e2971d638bc509] source-hash-82c25249e624cb54ca6d3293d1c3d0d8ebc208e0
git bisect bad fdbec4dce86360a09cf6b4af98e2971d638bc509
# good: [35fd7cf09ace604a04af0232a26eeb1256f67f1e] source-hash-6bf50c8d50a599d820289831ec4175136882b0d4
git bisect good 35fd7cf09ace604a04af0232a26eeb1256f67f1e
# bad: [bb8ed88d57a361495aca9de668df80050d41ebc5] source-hash-36170cd0dbc3409270cf3cf998805a790ee6228f
git bisect bad bb8ed88d57a361495aca9de668df80050d41ebc5
# good: [3501400226747f76691878608ef47b5148362858] source-hash-15af925c254f27046427de70a59011e2ac3d6bdb
git bisect good 3501400226747f76691878608ef47b5148362858
# bad: [e3fca4693fc359630ec1bbf45821875104da8928] source-hash-45c8db7ec89978029db2027585da986794971f7c
git bisect bad e3fca4693fc359630ec1bbf45821875104da8928
# bad: [1bfe96acc2fce1aa77ceca4c16ad93d85b033b39] source-hash-836822522a2e9f009c0870cbbcd48d45bbd3c622
git bisect bad 1bfe96acc2fce1aa77ceca4c16ad93d85b033b39
# first bad commit: [1bfe96acc2fce1aa77ceca4c16ad93d85b033b39] source-hash-836822522a2e9f009c0870cbbcd48d45bbd3c622
Comment 2 Kevin Suo 2014-12-08 08:02:04 UTC
Well, based on the bibisect result, it seems that this commit causes this bug:

1574c76ec20d1da479ed7e9c85a6cefacc132dfe
Format paintbrush default behaviour
Don't copy paragraph formats by default 

Mark as a duplicate of Bug 59029 - Format Paintbrush default changed to paste character formatting.

*** This bug has been marked as a duplicate of bug 59029 ***
Comment 3 Robinson Tryon (qubit) 2015-12-15 11:03:39 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]