Download it now!
Bug 97270 - copying formatting with paint brush does not copy/apply (some?) paragraph properties (line spacing, distance above)
Summary: copying formatting with paint brush does not copy/apply (some?) paragraph pro...
Status: RESOLVED DUPLICATE of bug 59029
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-20 09:07 UTC by Daniel
Modified: 2016-01-21 13:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test case for styles not being copied using brush (15.86 KB, application/vnd.oasis.opendocument.text)
2016-01-20 16:44 UTC, Daniel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2016-01-20 09:07:50 UTC
Even when clear direct formatting is applied first and followed by style copying (via brush in top toolbar), line spacing is not copied properly.

Font family, size etc. is copied, but line spacing is not copied and needs to be adjusted manually. In my understanding og how style copying should work - this is a bug.
Comment 1 Cor Nouws 2016-01-20 16:33:43 UTC
Hi Daniel,

Thanks for your report!

Can you please attach a sample document to test this?

Ciao,
Cor
Comment 2 Daniel 2016-01-20 16:44:50 UTC
Created attachment 122118 [details]
Test case for styles not being copied using brush

First clear direct formatting for the line "try to change line spacing for this two lines by copying styles from below" and then copy/apply styles using brush form the lines below that paragraph with the line "try to change line spacing for this two lines by copying styles from below".

It won't work, signle line spacing will be kept even when 1.5 line spacing is copied from below.
Comment 3 Cor Nouws 2016-01-21 12:36:31 UTC
Thanks Daniel.
I confirm the problem.

TODO: check for regression and duplicates
Comment 4 Cor Nouws 2016-01-21 12:40:47 UTC
Ah, it's a feature :)
 https://bugs.documentfoundation.org/show_bug.cgi?id=59029#c5
(I never use it, so didn't know it from the top of my head.)

*** This bug has been marked as a duplicate of bug 59029 ***
Comment 5 Daniel 2016-01-21 12:46:20 UTC
Thanks for the information.

However, if something needs to be explicitly explained and furthermore when there are multiple bug reports regarding this feature, we could assume that this behaviour is non-standard and unexpected by users.

I am not sure how other systems (MS Office, Google Docs) handle this, but if there is some common ground, it would be beneficial to change it in accordance from the UX point of view.
Comment 6 Cor Nouws 2016-01-21 13:42:19 UTC
(In reply to Daniel from comment #5)

> However, if something needs to be explicitly explained and furthermore when
> there are multiple bug reports regarding this feature, we could assume that
> this behaviour is non-standard and unexpected by users.

A better tool tip? Look eg. at "Zoom & Pan (CTRL to zoom out, SHIFT to pan)" on the tool bar Zoom in Draw.

Maybe you want to write an issue/enhancement request for that?

> I am not sure how other systems (MS Office, Google Docs) handle this, but if
> there is some common ground, it would be beneficial to change it in
> accordance from the UX point of view.

I've no idea either. But seeing the number of similar issues, it would have been poped up already if people expect something different from what they know from X and Y ?