Bug 63387 - FORMATTING: Format Paintbrush only copies Character (Font) format but not Paragraph format
Summary: FORMATTING: Format Paintbrush only copies Character (Font) format but not Par...
Status: RESOLVED DUPLICATE of bug 59029
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2013-04-10 15:29 UTC by karatzes
Modified: 2015-12-17 07:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A sample .odt file with instructions to reproduce (17.86 KB, application/vnd.oasis.opendocument.text)
2013-04-10 15:29 UTC, karatzes
Details
The .odt file printed as .pdf (58.45 KB, application/pdf)
2013-04-10 15:31 UTC, karatzes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karatzes 2013-04-10 15:29:39 UTC
Created attachment 77757 [details]
A sample .odt file with instructions to reproduce

Trying to copy the format from a paragraph to another, using Format Paintbrush, it only copies Font Format (i.e. Character style, Font size and style), but not Paragraph Format (i.e. Paragraph style, Indent, Spacing Above and Below, Line spacing, Alignment, Tabs, Background color).

This problem appears only in Writer 4.0.1.2 and 4.0.2.2 but not in Writer 3.6.5.2.

Look the Writer_4.0.x_Sample.odt and Writer_4.0.x_Sample.odt.pdf files with instructions to reproduce.

I confirmed the problem using Writer 4.0.1.2 and 4.0.2.2 in various O.S. (Mint13/MATE - Mint14/Cinnamon - Ubuntu12.04/Unity - Win7 Home Premium Gr)
Operating System: Linux (Other)
Version: 4.0.1.2 release
Comment 1 karatzes 2013-04-10 15:31:21 UTC
Created attachment 77758 [details]
The .odt file printed as .pdf
Comment 2 Petko Alov 2013-06-19 21:32:03 UTC
Observed in releases 4.0.2.2 and 4.0.3.3
Comment 3 Joel Madero 2013-06-20 17:44:03 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Minor - doesn't prevent high quality work but can slow it down
Medium - low is default but as this is a regression, bumped it up

Keywords - regression

Whiteboard Status - bibisected

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 4 Joel Madero 2013-06-20 17:44:38 UTC
1bfe96acc2fce1aa77ceca4c16ad93d85b033b39 is the first bad commit
commit 1bfe96acc2fce1aa77ceca4c16ad93d85b033b39
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon Dec 10 00:39:03 2012 +0000

    source-hash-836822522a2e9f009c0870cbbcd48d45bbd3c622
    
    commit 836822522a2e9f009c0870cbbcd48d45bbd3c622
    Author:     Rafael Dominguez <venccsralph@gmail.com>
    AuthorDate: Sat Jul 14 15:53:42 2012 -0430
    Commit:     Rafael Dominguez <venccsralph@gmail.com>
    CommitDate: Sun Jul 15 08:15:19 2012 -0430
    
        Create overlay for online templates.
    
        Change-Id: Ie09c91e23527d3e1389fc13bd13a8234bda080f3

:100644 100644 4139633eaae48833b5c99a8a96585d0419a26950 1b321839f886ee139062bb17a393d2a1affcd31a M	ccache.log
:100644 100644 9545b4da47ee1c814cc0f31514d40f8ab30194f2 2fd76f1416c514a6eea9cf04265ec460c860bfb5 M	commitmsg
:100644 100644 e679fecbd0522e3550cd8dc8b8b194671479a3ea df767f7d664fd5e785b597da65b0ee263346b212 M	dev-install.log
:100644 100644 a091e2c0d6b47e9cb56363e109e824b248b03f18 2ed5b8ab92fb1e963bd71441b275ed24e9e87569 M	make.log
:040000 040000 2a400d18b834fe0b7c04a75aa24b82d18195a41d 238648981137ddd02dbc39393d122f00e9ad4e96 M	opt


+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

# bad: [5b4b36d87517a6ea96ff8c84c46b12f462fc9a1a] source-hash-8450a99c744e9005f19173e4df35d65640bcf5c4
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
git bisect good 16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9
# bad: [f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a] source-hash-a581d31b227623e09d2970a91214fda398f98eda
git bisect bad f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a
# good: [5bf3b624cdeb593e55402f44c730209f12813961] source-hash-4b4ca8030285bd66526ff5bb2b6ea5a75a6c6bc7
git bisect good 5bf3b624cdeb593e55402f44c730209f12813961
# bad: [70771b69f427dcd3ace8caea819338f104b88c43] source-hash-83837d6514217c82ebe8d56dddf89fa34f4b5435
git bisect bad 70771b69f427dcd3ace8caea819338f104b88c43
# bad: [517b06fcbaceee61aa0ce4cc51663cc835444966] source-hash-06f20d73da21342046a480a6b22af69901351328
git bisect bad 517b06fcbaceee61aa0ce4cc51663cc835444966
# bad: [e3fca4693fc359630ec1bbf45821875104da8928] source-hash-45c8db7ec89978029db2027585da986794971f7c
git bisect bad e3fca4693fc359630ec1bbf45821875104da8928
# good: [3501400226747f76691878608ef47b5148362858] source-hash-15af925c254f27046427de70a59011e2ac3d6bdb
git bisect good 3501400226747f76691878608ef47b5148362858
# bad: [1bfe96acc2fce1aa77ceca4c16ad93d85b033b39] source-hash-836822522a2e9f009c0870cbbcd48d45bbd3c622
git bisect bad 1bfe96acc2fce1aa77ceca4c16ad93d85b033b39
Comment 5 Michael Stahl (CIB) 2013-06-20 21:32:32 UTC
it's not a bug, it's a feature.

see comment #5 of the duplicate bug for details.

*** This bug has been marked as a duplicate of bug 59029 ***
Comment 6 Robinson Tryon (qubit) 2015-12-17 07:13:49 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]