Download it now!
Bug 57516 - FORMATTING: Conditional formatting lost
Summary: FORMATTING: Conditional formatting lost
Status: RESOLVED DUPLICATE of bug 56316
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-25 12:36 UTC by p_kongstad
Modified: 2012-11-27 14:10 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Showing checked options in paste special (40.30 KB, image/png)
2012-11-25 17:58 UTC, p_kongstad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description p_kongstad 2012-11-25 12:36:28 UTC
Problem description: 

When you paste values using paste special (Text, Numbers, Date & Time) the conditional formatting is lost.

Steps to reproduce:
1. A1 Index A, B1 Index B in a new sheet.
2. A2 we fill with a
3. In B2 we add conditional formatting (Cell Value | Equal to| A2) and give it a style. I have used green as backgound.
4. Before pasting using paste special (Text, Numbers, Date & Time) we check that conditional formatting (Cell Value | Equal to| A2) is ok. It should be.
5. Now we copy value in A2 to B2 using copy and paste special (Text, Numbers, Date & Time). Both A2 and B2 now have same value and background should change. It doesn't.
6. Once again we check for conditional formatting.It is lost
7. Using CTRL+Z should restore conditional formatting, but does not return spreadsheet previous state.

Current behavior:
Conditional formatting is lost when pasting value using paste special (Text, Numbers, Date & Time). 

Expected behavior:
Conditional formatting should be preserved.
              
Operating System: Ubuntu
Comment 1 Markus Mohrhard 2012-11-25 13:27:57 UTC
Did you check Formats when using paste special?
Comment 2 p_kongstad 2012-11-25 17:58:02 UTC
Created attachment 70545 [details]
Showing checked options in paste special
Comment 3 Markus Mohrhard 2012-11-26 11:42:11 UTC
This will not copy conditional formats. You need to check the formats option too.
Comment 4 p_kongstad 2012-11-26 12:15:04 UTC
On 11/26/2012 12:42 PM, bugzilla-daemon@freedesktop.org wrote:
>
> *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=57516#c3> 
> on bug 57516 <https://bugs.freedesktop.org/show_bug.cgi?id=57516> from 
> Markus Mohrhard <mailto:markus.mohrhard@googlemail.com> *
> This will not copy conditional formats. You need to check the formats option
> too.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Dear Markus,

This is not at matter of conditional copying.

Let me explain what I use this for. When I receivea Purchase Order from 
our client containing a lot of information and I need to compare that to 
my own information.

So for me the value of cell A2 is my expectation, while I copy / paste 
the information from the received Purchase Order using 'Paste Special' 
into cell B2 only with the options Text, Numbers and Date & Time. In 
reality I have many more records, but it is left out for now not to 
complicate.

So cell B2 is having conditional formatting. I use a background color to 
find the information I need to verify /controland this is activated if 
B2 is not equal to A2.

The issue is that the 'Conditional Formatting' in B2 when 'Paste 
Special' with the options Text, Numbers and Date & Time is lost. So I do 
not wish to change formatting in B2.
Comment 5 Markus Mohrhard 2012-11-27 14:10:06 UTC
Ah ok, so I don't see this issue because I already fixed it.

*** This bug has been marked as a duplicate of bug 56316 ***