Bug 57539 - FILESAVE: table with nested table has broken formatting in XHTML export
Summary: FILESAVE: table with nested table has broken formatting in XHTML export
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 57575
Blocks: HTML-Export
  Show dependency treegraph
 
Reported: 2012-11-26 07:56 UTC by callow.mark
Modified: 2021-05-19 09:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Document with problematic table (24.20 KB, application/vnd.oasis.opendocument.text)
2012-11-26 07:59 UTC, callow.mark
Details
document with alternate table layout (14.69 KB, application/vnd.oasis.opendocument.text)
2012-11-26 23:19 UTC, Peter Jentsch
Details
Exported XHTML with LO 7.2 Alpha0: Firefox on left, LO preview on right. (216.36 KB, image/png)
2021-05-18 10:44 UTC, stragu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description callow.mark 2012-11-26 07:56:47 UTC
My document has a table containing another table in one of its cells. The exported XHTML (File->Export->XHTML) is broken such that some of the table borders do not line up vertically and some other borders are missing completely.
Comment 1 callow.mark 2012-11-26 07:59:01 UTC
Created attachment 70569 [details]
Document with problematic table

Export this document to XHTML and compare the original and exported results. The problem is easy to spot.
Comment 2 Peter Jentsch 2012-11-26 20:45:11 UTC
created separate issue for the missing borders: https://bugs.freedesktop.org/show_bug.cgi?id=57575
Comment 3 Peter Jentsch 2012-11-26 20:45:45 UTC
Test 57575
Comment 4 Peter Jentsch 2012-11-26 23:15:38 UTC
The nested table formatting seems rather difficult to fix right now, or it would rather require more in depth knowledge of how browsers handle table layout with nested tables. 

You could redesign your table to use spanning instead of nested tables, though. I'm attaching a sample document.
Comment 5 Peter Jentsch 2012-11-26 23:19:09 UTC
Created attachment 70627 [details]
document with alternate table layout
Comment 6 Xisco Faulí 2017-09-25 08:21:51 UTC
Dear Peter Jentsch,
This bug has been in ASSIGNED status for more than 3 months without any activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 7 QA Administrators 2018-09-26 02:43:40 UTC Comment hidden (obsolete)
Comment 8 Roman Kuznetsov 2018-09-26 12:10:58 UTC
some border are missed in XHTML because they missed in source file.
but there is some offset of verical border in XHTML.

still repro in 

Version: 6.2.0.0.alpha0+
Build ID: 1aa37aa6bee19099b57555a6d839992b054aa405
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-23_10:17:54
Locale: ru-RU (ru_RU); Calc: threaded
Comment 9 QA Administrators 2019-09-27 03:04:48 UTC Comment hidden (obsolete)
Comment 10 stragu 2021-05-18 10:44:05 UTC
Created attachment 172118 [details]
Exported XHTML with LO 7.2 Alpha0: Firefox on left, LO preview on right.

This is a "Works For Me", as shown in the screenshot, testing with LibreOffice 7.2 Alpha0, and opening the exported XHTML in Firefox 88.0.1

This looks like it was fixed for the 7.1 branch, as 7.0.4 still has the misalignment, but 7.1.3 doesn't.

Details for version 7.2:

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 6b09276d157abada74e1a4989700139167207778
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-05-14_04:32:30
Calc: threaded