Bug 57612 - report builder design mode CRASH on change FixedLine height to zero
Summary: report builder design mode CRASH on change FixedLine height to zero
Status: RESOLVED DUPLICATE of bug 57611
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.4.1 rc
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-27 14:04 UTC by Lionel Elie Mamane
Modified: 2012-11-27 14:04 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2012-11-27 14:04:03 UTC
Open attached .odb

Click "Reports" (in the left pane)

Right-click "Report1" (right-lower pane)

Click on the horizontal line in the middle of the "Detail" section.

If the properties don't show (at the right of the window), right click on the line and click on "Properties"

Change height to "0"

Press tab key


---------> Abort (crash); stderr says "terminate called after throwing an instance of 'com::sun::star::beans::PropertyVetoException'"



This happens with any height < .02cm


Expected behaviour: either accept the change, or reject it, but don't crash.


Origin:

reportdesign/source/core/api/FixedLine.cxx line 526:

    if ( (aSize.Width < MIN_WIDTH && m_nOrientation == 1) || (aSize.Height < MIN_HEIGHT && m_nOrientation == 0) )
        throw beans::PropertyVetoException();


Backtrace also attached. You'll notice that the backtrace contains a "try () ... catch ()" block that should catch this exception. Backtrace also goes through UNO bridge (I don't understand why???), but UNO bridge should forward UNO exceptions!
Comment 1 Lionel Elie Mamane 2012-11-27 14:04:42 UTC

*** This bug has been marked as a duplicate of bug 57611 ***