Bug 57628 - CRASH when FILEOPEN particular .odt in WinXP created with LibO 3.5
Summary: CRASH when FILEOPEN particular .odt in WinXP created with LibO 3.5
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA (target:4.0.0)
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-27 21:36 UTC by starmatz71
Modified: 2013-12-15 22:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is the odf file which cause crashing of LibO V3.6 (46.38 KB, application/vnd.oasis.opendocument.text)
2012-11-27 21:36 UTC, starmatz71
Details
This is the PDF-Version of the odf document (Hybrid-File, PDF1/A) (327.36 KB, application/pdf)
2012-11-27 21:40 UTC, starmatz71
Details

Note You need to log in before you can comment on or make changes to this bug.
Description starmatz71 2012-11-27 21:36:22 UTC
Created attachment 70693 [details]
This is the odf file which cause crashing of LibO V3.6

Problem description:

The attached odf-file created with LibreOffice V3.5 causes crashing LibreOffice Writer V3.6.x.

This document has two graphics, created in LibO Draw.
Behind the first drawing is a white box.
After deleting this box and the drawing in LibO V3.5 creates a file, which is readable in LibreOffice Writer V3.6 !
The crash must have something to do with the drawing inside this document!

Steps to reproduce:
1. Open the attached document in LibreOffice V3.5 works perfect.
2. Open the same document in V3.6 crashes LibreOffice!

I believe this is a blocker bug!
Operating System: All
Last worked in: 3.5.7.2 release
Comment 1 starmatz71 2012-11-27 21:40:15 UTC
Created attachment 70694 [details]
This is the PDF-Version of the odf document (Hybrid-File, PDF1/A)
Comment 2 starmatz71 2012-11-27 21:42:28 UTC
This issue happens in LibO V3.6.4.1 (RC1) also.
Comment 3 billhook 2012-11-28 04:35:16 UTC
I could not reproduce the crash on LO 3.6.4.1 Windows Vista 32bit. The document opens and look correct as far as I can tell.
Comment 4 Rainer Bielefeld Retired 2012-11-28 07:43:14 UTC
NOT [Reproducible] with sample "2012-11-27 21:36 UTC, starmatz71@yahoo.de " and with  "LibreOffice 3.6.4.1 rc" German UI/ German Locale [Build-ID: a9a0717] on German WIN7 Home Premium (64bit).

I can open the sample document with double click from WIN File Explorere without problems, same from LibO Files dialog.

@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? 
Please:
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what the sample "2012-11-27 21:40 UTC, starmatz71@yahoo.de" hsould
     show
  -- concerning your PC 
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration, Experimental features enabled, ...)
  -- how you launch LibO and how you opened the sample document
  –- Whether your problem persists when you renamed your user profile 
     before you launch LibO (please see
     <https://wiki.documentfoundation.org/UserProfile#User_profile_location>)
  -- everything else crossing your mind after you read linked texts
Comment 5 starmatz71 2012-11-29 20:45:41 UTC
The crash occures with two WindowsXP SP3 Systems (Professional and Home Edition).
I had tried it in Windows 7 64-Bit (Professional, German) and the file did not crash LibO.

All PCs are running LibreOffice V3.6.3.2!

I'd tried to open the file in Ubuntu 12.10 with LibreOffice V3.6.2.2 and it does not crash.

I can also open this file with Apache OpenOffice 3.4.1, LibO 3.3.4, LibO3.4.6 and LibO3.5.7 on WinXP.

This crash should only happens on WinXP with LibreOffice 3.6!

Can someone confirm this?

I cannot tell you how the drawing is created because i drew it with OpenOffice 3.x some time ago. The only thing i did is I draw a white box behind the drawing.
After this i copy and past it into the textfile with LibO 3.5.x

After Updating to LibO3.6.3.2 i want to edit the file but LibO crashes.
After some experiments and tests i remove the drawing in LibO3.5, save the file and open it with LibO3.6 and it loads without any crash.

Antialiasing and hardware acceleration doesn't has any influence in the behavior of the crash. Experimental features are always disabled.
Comment 6 billhook 2012-11-30 07:17:31 UTC
Confirmed on LO 3.6.4.1 Windows XP Professional SP3 (32bit)

This bug seems to occur ONLY on Windows XP. It does not seem to happen on Vista, Win7 or Linux.
Comment 7 starmatz71 2013-02-04 22:03:17 UTC
I can confirm, that this bug is gone in LibreOffice V4.0.0.3.

Unfortunately the bug is still present in LibreOffice V3.6.5.3.

If you affected by this crash you can update to LibO V4.0.x as a workaround.

(WindowsXP SP3 32Bit)
Comment 8 Rainer Bielefeld Retired 2013-04-20 13:37:26 UTC
<https://bugs.freedesktop.org/page.cgi?id=fields.html#status>
We should use FIXED only if a known fix has solved the problem; if the problem only disappeared without known reason, please use WORKSFORME