Bug 57665 - UI: Excess scrolling area on the main slide (Normal) view
Summary: UI: Excess scrolling area on the main slide (Normal) view
Status: RESOLVED DUPLICATE of bug 117009
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-28 21:23 UTC by Emir Sarı (away)
Modified: 2018-05-24 19:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
excess scrolling area 1 (34.83 KB, image/png)
2012-11-28 21:23 UTC, Emir Sarı (away)
Details
excess scrolling area 2 (32.92 KB, image/png)
2012-11-28 21:23 UTC, Emir Sarı (away)
Details
excess scrolling area 3 (22.16 KB, image/png)
2012-11-28 21:24 UTC, Emir Sarı (away)
Details
excess scrolling area 4 (72.98 KB, image/png)
2012-11-28 21:24 UTC, Emir Sarı (away)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı (away) 2012-11-28 21:23:15 UTC
Created attachment 70753 [details]
excess scrolling area 1

Hello, 

I think this was present all along, but decided to report it anyway,

Current Impress main window has lots of scrollable area both upwards, downwards, to the left and right. It looks ugly and non-functional. Both PP and Keynote has main slide aligned to the screen resolution. It would be understandable if the screen resolution was low and we had to scroll to see the remaining of the slide, but this is totally useless. 

Expected behaviour: Slide neatly aligned to the window with no excess scrollable area
Received behaviour: Unnecessary scrolling area resulting in a wibbly-wobbly slide.
Comment 1 Emir Sarı (away) 2012-11-28 21:23:45 UTC
Created attachment 70754 [details]
excess scrolling area 2
Comment 2 Emir Sarı (away) 2012-11-28 21:24:09 UTC
Created attachment 70755 [details]
excess scrolling area 3
Comment 3 Emir Sarı (away) 2012-11-28 21:24:37 UTC
Created attachment 70756 [details]
excess scrolling area 4
Comment 4 Roman Eisele 2012-11-30 08:00:39 UTC
Thank you for your bug report!

I can easily confirm Emir Sarı’s observations, and therefore I set the status of this bug report to NEW.

However, I propose *not* to change this without further discussion, probably on the UX list. I am no Impress expert, and I don’t know if there is not some reason for these big “margins” around the slide ...

At least on thing I can think of is that it is possible to move elements, which are currently not needed in a slide, to the “margin” of that slide, with the intention to use them later, if necessary. Or to play with different possible elements (e.g., images): leave image A on the slide, move image B to the margin; then exchange both; and observate which design looks better. This usage of the free space is common in DTP applications. (At least I know many QuarkXPress users who used the “working space” [as this free place around pages is called there, IIRC] in this way, and professional books which recommend to use the “working space” in that way. The XPress users even requested [long years ago] to increase the “working space”, because they used it so often …)

And yes, it is possible to use the “margins” around the slides in this way in Impress (I have just tested it); and all such usages of the “margin” around the slides make it necessary to have “lots [!] of scrollable area” around the slide.

Therefore I propose *not* to change the state of affairs without thorough discussion. There is no special Status for bugs of this kind, sorry ;-)
So this is either NEW or NOTABUG ...
Comment 5 Emir Sarı (away) 2012-12-01 00:24:03 UTC
No problem at all, after the input of the UX team, the fate of these spaces can be decided. :)
Comment 6 Emir Sarı (away) 2013-01-30 17:49:27 UTC
One idea, the margins could be set to extend according to user input; what I mean is, if someone moves an object towards the outer area of the slide, LO could extend the empty area in accordance with the dimensions of the object being moved.
Comment 7 Cor Nouws 2014-02-03 10:52:57 UTC
Sometimes when you past or edit stuf, it runs way out of the slide area.
Maybe that is related to this huge scrolling area?
Apart from that it's superfluous .. does it make work harder?
cheers,
Cor
Comment 8 Emir Sarı (away) 2014-02-03 15:21:24 UTC
It does look unprofessional, in my view everything should be properly oriented and be slick, and resizeable when needed.
Comment 9 Thomas Lendo 2018-05-24 19:01:39 UTC
I set the newer bug as only one as there have more people discussed the topic.

*** This bug has been marked as a duplicate of bug 117009 ***