Bug Hunting Session
Bug 57673 - Allow more than 1 Page Style for Drawing and Presentation documents
Summary: Allow more than 1 Page Style for Drawing and Presentation documents
Status: RESOLVED DUPLICATE of bug 49787
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-29 02:01 UTC by Jeremy
Modified: 2012-11-29 06:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (11.57 KB, application/x-zip-compressed)
2012-11-29 06:02 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy 2012-11-29 02:01:33 UTC
Problem description: 
Unable to set different backgrounds ('None' and 'Colour: Black') for different slides in a presentation.

Steps to reproduce:
1. Create two impress files with different backgrounds.
2. Import one into the other

Current behavior:

All slides take same background.

Expected behavior:

Slide backgrounds to match those they had in the seperate files.            

Note: ticking or not delete unused background box makes no difference.

Steps to reproduce (cont.):
3. Select slide(s) to change background of.
4. Format > Page > Background > set as wanted.
5. Click ok  
6. To prompt 'change all slides?' select No

Current behaviour:
No change made - all slides continue to have same background.

Expected behaviour:
Background of selected slide(s) to change.

Note: selecting 'yes' option at step 6 results in background of all slides changing.

Operating System: Windows XP
Comment 1 Jeremy 2012-11-29 02:03:31 UTC
Also occurs on Libre Office 3.5.7.2.
Comment 2 Rainer Bielefeld Retired 2012-11-29 06:02:33 UTC
Created attachment 70770 [details]
Test Kit

With Server Installation of "LibreOffice 3.6.2.1 release”  English UI/ German Locale [Build-ID:  da8c1e6] on German WIN7 Home Premium (64bit) I created  a document similar to attached  "Mysource.ods" with a new Page Style NEW with some differences to Page style "Defualt"
- Page orientation = Landscape
- Borders = all around, 1pt, green
- Background = yellow
- Header = Background - light blue
- Footer = Bakckground - light magenta

Page preview for "Mysource.ods" shows the differences for the pabe styles in the sheets, so the summary of this report is wrong, it IS possible to have sheets with different page styles in 1 sheet.

But Indeed, when I import that Sheet2 to a new document "Mytarget.ods", the sheet will be imported without it's page styles. 

So I can confirm the effect, but I will have to do some more investigation (did that ever work? bug or feature? ...)
Comment 3 Rainer Bielefeld Retired 2012-11-29 06:17:34 UTC
Damned, please ignore my comment 2, I tried to reproduce a Presentation issue for spreadsheets ...

This is a very old known LibO Limitation and so this one is a DUP of "Bug 49787 - Formatting: Add page styles to LibreOffice Draw"

For the Spreadsheet problem I observed I will submit an additional Bug report.

*** This bug has been marked as a duplicate of bug 49787 ***
Comment 4 Rainer Bielefeld Retired 2012-11-29 06:17:55 UTC
Comment on attachment 70770 [details]
Test Kit

Wrong bug