Bug Hunting Session
Bug 57698 - UI: dialog box moves to unusable location when two documents open
Summary: UI: dialog box moves to unusable location when two documents open
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-29 19:59 UTC by Steve Kelem
Modified: 2013-06-24 01:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Kelem 2012-11-29 19:59:16 UTC
I have two documents open at the same time, one on each screen. I leave space on each screen for LO dialog boxes such as "Styles and Formatting" or the "Navigator". None of these windows overlap.

When in one document, I open the "Fields" dialog, it usually pops up in a bad place, like on top of the other document. This, by itself, would not be bad, except that when I move my mouse to the Fields dialog, it has to cross over the other document. As soon as the cursor goes over the other document, the Fields dialog disappears because the 2nd document doesn't have an open Fields dialog!

An unsatisfactory workaround is to move the 2nd document out of the way (usually mostly off-screen) so that the cursor can be dragged to the Fields dialog when it reappears after the cursor is moved back to the 1st document. After moving the cursor to the 1st document, the Fields dialog reappears. The Fields dialog can be dragged to a better place, i.e., closer to document 1.

However, the reason I have two documents open at the same time is to refer to both of them at the same time. After repositioning the Fields dialog, I would like to move the 2nd document back to a useful position on the other screen. When I do so, the Fields dialog disappears. After moving the cursor back to the 1st document, the Fields dialog reappears, not to the useful position where I dragged it, but back on top of the 2nd document!

This repositioning of dialog boxes when multiple documents are open is really annoying. Any positioning of the dialogs for a document is undone if the cursor moves into another document!  Worse yet, if I place the document windows on top of each other at one side of the screen, if the other edge of the windows (left/right depending on which side of the screen the document is on) do not line up EXACTLY, when the cursor moves outside the top document but happens to cross over a visible pixel in another document, all the dialog boxes disappear for document 1 and appear for document 2 IN COMPLETELY USELESS LOCATIONS!

If the user moves a dialog box for a document, please remember where the user put it so that the next time the same dialog box is opened, whether to add fields again or from switching back and forth between multiple documents, the dialog box can be reopened IN EXACTLY THE SAME LOCATION WHERE THE USER PUT IT BEFORE!

P.S. If the screen layout has changed in between openings of a dialog box, such as when a laptop is docked or undocked, try to put the box where it was before. If that is not possible, such as when a secondary screen is unplugged, feel free to put the dialog anywhere where it is visible on the remaining screen.

Thank you.
Comment 1 Roman Eisele 2012-11-30 10:26:10 UTC
Dear bug reporter, a general hint:

Please do not use too many words in UPPERCASE letters. You may use UPPERCASE to emphasize single words where necessary (just like putting them in *asterisks* or _underlines_ or ... whatever), but if you use UPPERCASE too often this suggests that you are shouting at us, which is no good idea -- we bug wranglers are all pure volunteers, and there is some danger that nobody would like to process a bug report which shouts at him ;-) E.g., I will NOT (sic) try to reproduce this bug report right now; there are other important bug reports which are much more appealing to me.
Comment 2 Petr Mladek 2012-11-30 13:19:14 UTC
I agree that this behavior sounds annoying. Well, I guess that it has been there for ages and I do not see any duplicate. So, it looks like a less typical usecase. I am sorry, such bugs does not belong to MABs => removing it.

A workaround might be to dock the dialogs.

I add some experts into CC. I wonder if the location is actually defined by LO or by Windows manager. Anyway, it would be nice to somehow improve it.
Comment 3 Steve Kelem 2012-12-12 18:41:42 UTC
I didn't mean to imply that I'm yelling at anyone when I used uppercase. It was to convey the frustration I experienced when popups move and disappear. I used the uppercase to indicate when I start yelling at the computer. With people, I'm much more patient.

I don't know how to dock a dialog. I'm running Ubuntu, not Windows.

Well, the two points I would like fixed:
1. If a user moves a dialog box, the location should be remembered, on a per-document basis, so that when the same dialog box is opened again, it goes where it was put last time.
2. Dialog boxes for Document A disappear when focus moves (I use "focus follows mouse (sloppy)".) into Document B. Newly-created dialog boxes should be placed on top of the current document, not placed somewhere that makes it really difficult (e.g., having to move the mouse to avoid other document windows, similar to the game Operation.) for the user to move his mouse to get to the dialog box. Sometimes dialogs get created right in the middle of another document, making it impossible to move the mouse into the other dialog box without crossing the other document's borders, which makes the dialog box disappear.
Comment 4 Joel Madero 2013-06-24 01:29:22 UTC
As has already been mentioned - the wordiness makes it very difficult to follow the bug. In the future please write bug reports in a very simple, enumerated fashion. Then the extra words can come after. Enumeration makes it so we can follow the bug much easier. Example format:

Steps to Reproduce
1.
2.
3.
...

Observed Behavior:

Expected Behavior: 

Extra stuff....


This being said, I cannot reproduce the behavior. When I open a dialog box on a document, it opens on the document, pretty much out of the way. I then close the dialog, go to the 2nd document (on a separate workspace) and show another toolbar, it opens up on the correct document, no need for me to move back to the other screen at all. I tested with 5 different toolbars and never saw the problem.

Tested on Bodhi Linux with LibreOffice version 4.1 RC1 which is built on Ubuntu 12.04

Closing as WFM - 

@Steve - if you still see the problem with 4.0 or even better 4.1 RC (pre-release page has it) please let us know and provide easy to follow steps to test.