Download it now!
Bug 57704 - PRINTING: portrait vs. landscape printing
Summary: PRINTING: portrait vs. landscape printing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-11-29 21:57 UTC by Lachlan McDonald
Modified: 2013-08-15 09:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lachlan McDonald 2012-11-29 21:57:05 UTC
Problem description: I assume this applies to all compnents as I couldn't get any aspect of my LibreOffice to print in landscape - portrait only.  I think it's the LibreOffice print code, because I can print landscape with any other program on computer.  

Steps to reproduce:
1. Go into any component; specifically the write or spreadsheet programs
2. Create a test 
3. Try printing in landscape - it reverts back to portrait all the time

Current behavior:  LibreOffice simply refuses to print in landscape (this is not between print jobs, but when printing)

Expected behavior:  Landscape printing

              
Operating System: Windows 7
Last worked in: 3.5.7.2 release
Comment 1 retired 2013-05-31 09:56:29 UTC
Lachlan, could you please provide detailed steps of what you are doing when trying to print in landscape. Step 3 is fuzzy and to actually verify if this is a valid back please provide more detail.
Comment 2 Lachlan McDonald 2013-05-31 13:42:00 UTC
I simply don't remember because it was so long ago.  Additionally, I remember I received notification that the "bug" had been fixed about a week later - as I wasn't printing spreadsheets then, I don't think I double-checked.  As I recall, I was trying to print spreadsheets (but this problem occurred across all programs).  Spreadsheets are much more readable in landscape, but the program kept reverting to printing in portrait.  Thinking it was program (or printer software) specific, I copied and pasted it into others in the suite - all to no avail - it kept reverting and printing in portrait when landscape was selected in the print mode.  Finally, I copied & pasted it into Notepad, and that worked -demonstrating to me it was neither the printer software or my computer, but the LibreOffice Suite.  More recently, I have switched to another suite of programs so this doesn't happen again -it hasn't.  Hope this helps because I really don't remember
 much more.
 

________________________________
 From: "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org>
To: lmcd@rogers.com 
Sent: Friday, May 31, 2013 5:56:29 AM
Subject: [Bug 57704] PRINTING: portrait vs. landscape printing
  
 
James  changed bug 57704  
What 
Removed 
Added  
Status  UNCONFIRMED   NEEDINFO    
Ever confirmed      1    
Comment # 1 on bug 57704 from James  
Lachlan, could you please provide detailed steps of what you are doing when
trying to print in landscape. Step 3 is fuzzy and to actually verify if this is
a valid back please provide more detail.  

________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 3 D. Hugh Redelmeier 2013-08-14 16:58:56 UTC
Perhaps this is related to https://bugs.freedesktop.org/show_bug.cgi?id=66748#c1
Comment 4 retired 2013-08-15 09:47:09 UTC
Just tested this. Landscape is set at Format > Page. Printing a spreadsheet in that format works perfectly fine on OS X 10.8.4, LO 4.1.1.1.

If anybody on M$ Windows can still reproduce this bug with the latest LO release, please reopen.

WORKSFORME.