Download it now!
Bug 57709 - Font replacement doesn't work as expected
Summary: Font replacement doesn't work as expected
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2012-11-29 23:58 UTC by Urmas
Modified: 2019-09-27 18:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-11-29 23:58:19 UTC
1. Add a font replacement entry with "Screen only"
2. Nothing happens.

To see it applied, you need to check "Always" option. That is unexpected and not intuitive.
Comment 1 Joel Madero 2012-12-06 21:15:02 UTC Comment hidden (obsolete)
Comment 2 Joel Madero 2012-12-06 21:19:18 UTC
Sorry didnt' explore enough, here are steps:

Tools -> Options -> Fonts

Check "Apply replacement table"

Font: Select a font that's in use on screen, "Replace with" choose another font

Click Green Check Mark

Check "Screen only" option in dialog

Click OK



Agreed, nothing happens and that's no good, might be useful just to disable the feature (screen only) until it's fixed - this would probably be an easy hack.

Marking:
New (Confirmed)
Minor (not a common feature, doesn't prevent high quality work, work around is just manually changing font)
Low (really uncommon feature to use, easy work around)

Thanks for reporting this one
Comment 3 Joel Madero 2012-12-06 21:20:04 UTC
Also changing version to 3.6.3.2 as I've confirmed it on that version (Version is the oldest version that the bug is confirmed on, not the latest version it's confirmed on).

Also updating Platform


Thanks again
Comment 4 Harald Koester 2013-08-25 16:48:46 UTC
I ‘m sorry, but I think the behaviour in the mentioned case is correct. I assume that you replaced a font which is installed on your system. For this case the help says „Font replacement only on screen, but only if font is not available.“. 

The problem is, that the word „Always” is misleading. If checked the meaning is: Also replace font if used font is installed. If not checked the meaning is: Only replace font if used font is not installed. In order to improve this, “Always” could be replaced by “Also if font is installed”. Or another possibility: Add a hint to this option page, where the meaning of “Always” is explained.

But I think in the other case, where the font which shall be replaced is not installed, the behaviour is not correct:
[1] Create a short text and assign a font to this text, that is not installed on your system. The font name is displayed in italic and a tip is displayed, that the font is substituted (since LO Version 4.1.0). Perhaps you know, but I don’t know which font is used in this case. I call it here “standard replacement”.
[2] Change option: Replace the not-installed font with a font which is installed. Check “Screen only” and don’t check “Always”. I expect in this case, that the font is replaced by the defined replacement font. But it is still replaced with the “standard replacement”.

I think there are some more cases where the font replacement does not work correctly. I described them in bug 43185.

Furthermore in order to make it more transparent for a user what happens, the hint could be improved: “The current font ‘ABC’ is not installed on your system and is substituted by the font ‘XYZ’". And in the other case: "The installed font 'ABC' is substituted by the font 'XYZ'". And just a bagatelle: In the hint the word “substituted” is used. I think it is better to use always the same word, in this case “to replace” or “replacement”.
Comment 5 QA Administrators 2015-04-01 14:41:01 UTC Comment hidden (obsolete)
Comment 6 Harald Koester 2015-06-22 15:01:40 UTC
Checked again with 4.4.3. The behaviour has not changed since version 4.1.0. As I mentioned in comment 4 I think the original behaviour as described in comment 2 is correct. Furthermore I also mentioned that there are other problems in connection with the font replacement (see comment 4 and bug 43185) which still exist.
Comment 7 QA Administrators 2016-09-20 10:11:29 UTC Comment hidden (obsolete)
Comment 8 Harald Koester 2016-10-01 21:10:06 UTC Comment hidden (obsolete)
Comment 9 Harald Koester 2016-10-01 21:15:03 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2018-09-18 02:49:46 UTC Comment hidden (obsolete)
Comment 11 Harald Koester 2018-09-18 14:09:03 UTC
Checked with version 6.1.1 (64 bit, Win 10). Behaviour has not changed. To my opinion not a bug.
Comment 12 QA Administrators 2019-09-19 03:14:52 UTC Comment hidden (obsolete)
Comment 13 Harald Koester 2019-09-27 18:43:35 UTC
Since there has been no contradiction against comment 4, I close this bug as NOTABUG.