Bug 57765 - FILEOPEN via FTP from Server causes General Error
Summary: FILEOPEN via FTP from Server causes General Error
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected) release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
Depends on:
Blocks: Network
  Show dependency treegraph
Reported: 2012-12-01 11:35 UTC by Rainer Bielefeld Retired
Modified: 2017-08-25 12:44 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-12-01 11:35:39 UTC
Steps how to reproduce with "LibreOffice rc" German UI/ German Locale [Build-ID: 2ef5aff] {pull date 2012-11-28} on German WIN7 Home Premium (64bit) 

1. Launch LibO, if necessary menu 'Tools -> options -> LibO -> General -> 
   Use LibO File dialog
2. From Start Center open New Text document, type few words
3. menu 'File -> Save -> <... Connect to server>
   Dialog opens
3. Name = Collab
   Type = FTP 
   Host = bielefeldundbuss.de
   Login = f0023e73
   Path = 
   > Folder becomes created in overview in "Locations" pane
4. Click "Collab" Folder in overview pane
   > Dialog appears and asks for password
5. Password = ngoagnoi6lf
   > Folder Listing on Server appears 
6. Save document as mycummy.odt,
   > you will see it in the folder
7. Close Document
8. Menu 'Open -> Location-Collab
   > Still Server Contents listed
9. Click your Dummy Document
   > Appears in File Name Pane
10. <Open>
    Bug: General Input- / Output Error
Comment 1 Julien Nabet 2012-12-01 16:47:45 UTC
On pc Debian x86-64 with 3.6 sources updated today (commit b14f981e055bde9243c82d3ca5bbd3e469a7eb40), I don't reproduce this.

I just put "test2" on the file.

Sorry if it's a naive idea/obvious..., but it could be interesting to know if it's the opening process which fails or if it's the saving process.
Did you retrieve the file from your ftp in your local disk and open it with LO to check if it was ok?
Comment 2 Rainer Bielefeld Retired 2012-12-01 17:17:30 UTC
Thank you for testing. I did not check that particular document, but for me that's a general problem i saw with various documents.

I can open your document you left on the sever via Seamonkey browser without problems (Writer is listed as helper application), and save it again. But file open fails via Libreoffice dialogs. You really followed my steps 8 and following or did you a trick like "via browser" or similar?

You can see in my steps that I saved the document on the server in step 6. I really did that from LibO, no trick with other software.

But I get the error message when I try from LibO (It does not matter whether I try from LibO dialog or OS dialog.

Same result with (you can simply use <ftp://f0023e73@bielefeldundbuss.de/> in the file name pane as in OS dialog).

Older versions and AOOo crash when I try that proceeding.
Comment 3 Julien Nabet 2012-12-01 17:28:39 UTC
Rainer: I just tried to read the file I had put from LO and saw that you added "and more tested".
To answer to your question, first I didn't understand because I didn't see "Connect to server" so I retrieved a file from Filezilla first but there was a password.

Then I understood with Libo File Dialog and made the whole thing from LO (save + open)

So, perhaps Windows only bug?
Comment 4 Rainer Bielefeld Retired 2012-12-01 17:31:00 UTC
Inspired by Julien's results I tried Ubuntu 12 64 bit with LibO, and I was able to open the documents on my server without any problems following the modified proceeding (instructions step 8 and following) for 3.5 with ftp://f0023e73@bielefeldundbuss.de/ in the  filename input pane

So this problem seems to be WIN only?
Comment 5 Julien Nabet 2012-12-02 08:15:50 UTC
On Win7 64 with (build 58f22d5), I can reproduce the problem, so put the status at "NEW".
Comment 6 Rainer Bielefeld Retired 2012-12-02 09:54:30 UTC
“Lotus Symphony Release 3.0.1 Revision 20120110.2000” on German WIN7 Home Premium (64bit) does the job without a murmur, so we should be able, too.

For the sake of completeness: I also see the problem when I try to open the document with "read only" checked.

This bug has impact to TDF documents interchange, document sharing and co working, so I increase severity to "Major"
Comment 7 Julien Nabet 2012-12-02 11:18:45 UTC
Rainer: do you have the same with WebDav, ssh or Windows shared directories?
(I don't even succeed in configuring the last one on LO)
Comment 8 Rainer Bielefeld Retired 2012-12-02 11:21:09 UTC
Unfortunately ftp is the only possibility where I know what that is ...
Comment 9 Julien Nabet 2012-12-02 15:31:25 UTC
I gave a try to ssh, impossible to save something on it.
put fdo#57806 in see also
Comment 10 Julien Nabet 2012-12-02 16:14:20 UTC
Just for information, on MacOS 10.7 with LO 3.6.3, I can save and open a file on an ftp.

(However, I can't even access ssh location)
Comment 11 Julien Nabet 2012-12-05 12:34:01 UTC
bfoman: would it be possible by any chance to have a bt (even if it's not a crash)?
Comment 12 bfoman (inactive) 2012-12-05 20:59:04 UTC
Confirmed with:
Build ID: 58f22d5
Windows XP Professional SP3

Got General Input- / Output Error and "Object not accessible. The object cannot be accessed due to insufficient user rights." error. I haven't been asked for a password while opening and did not selected Remember password at saving.

As for bt - should I break after that error?
Comment 13 bfoman (inactive) 2012-12-05 21:08:59 UTC
When Remember password at saving is selected I just have General IO error.
Comment 14 Julien Nabet 2012-12-05 21:16:40 UTC
Rainer: had you get exactly the same message as the bfoman's one? (without checking remember password)
Comment 15 Rainer Bielefeld Retired 2012-12-05 21:27:19 UTC
The first part of the message is exactly mine, I can't tell what causes that he can see additional info "Object not accessible ...", currently I do not understand that "remember password" thingy, I will do some additional tests tomorrow.
Comment 16 news4roland 2013-06-07 06:48:49 UTC
Opening a document via FTP in Writer File - Open - (example) ftp://server/document.odt causes the same error.

Tested with:

Windows 7 Professional 64-bit
Windows 8 Pro 64-bit

LibreOffice (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
LibreOffice Build ID: 5271b34bec742e190e2fe5a7dadb7334a705b54

Searched for the problem with Process Monitor (Sysinternals).

Reason for this error: LibreOffice wants to write a temporary file on C: instead of writing to the temp-directory of the user. Writing and deleting directly on C: is not allowed in Win 7 and 8 as normal user, only as admin.

When you start LibreOffice as admin, everything is ok, but not as usual (domain-)user.
Comment 17 Julien Nabet 2013-06-10 19:38:29 UTC
news4roland: thank you for your interesting feedback.

Tor: the last feedback could help to solve this tracker but looking at ucb/source/ucp/ftp with grep or Opengrok, I don't know where is the Windows specific part. Any code pointer/idea?
Comment 18 QA Administrators 2015-04-01 14:40:33 UTC Comment hidden (obsolete)
Comment 19 tommy27 2016-04-16 07:26:48 UTC Comment hidden (obsolete)
Comment 20 QA Administrators 2017-05-22 13:22:53 UTC Comment hidden (obsolete)
Comment 21 Shinnok 2017-08-25 12:44:29 UTC
Resolving this bug with INSUFFICIENT since it's so old that is probably obsolete by now, is too generic and doesn't include enough how to reproduce information.