Bug 57767 - FILEOPEN: numbering in attached .rtf file saved from Abiword makes LO hang
Summary: FILEOPEN: numbering in attached .rtf file saved from Abiword makes LO hang
Status: CLOSED DUPLICATE of bug 49587
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-01 12:04 UTC by Milan Bouchet-Valat
Modified: 2013-11-16 19:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test case RTF saved from Abiword (5.42 KB, application/rtf)
2012-12-01 12:04 UTC, Milan Bouchet-Valat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2012-12-01 12:04:21 UTC
Created attachment 70865 [details]
Test case RTF saved from Abiword

The very short attached test case makes LO 3.5.7.2 and 3.6.3.2 (tested on Linux for the first, on Mac OS X for the second) hang when opening it.

This file was saved from Abiword, and I could determine the problem happens only when a numbering is included in the file.
Comment 1 s-joyemusequna 2012-12-07 16:41:48 UTC
Confirmed with LO 3.5.4 and LO 3.6.3 under Windows XP.

Works with LibO 3.4.5.

Works again with LOdev 4.0.0.0.alpha1+ (Build ID: ac4d26e3fc2728ee80f33a485540d50b48927dd), 2012.12.03.
Comment 2 Michael Stahl (allotropia) 2012-12-12 15:41:30 UTC
loop in DomainMapper_Impl::GetPropertyFromStyleSheet

backporting 7e3923520c27ff139bc3abab35a1c01e1a785fb1
fixes it in 3.6 branch so it's a duplicate.

the document has:

{\s20\f0\lang1036\sbasedon20Normal;}

perhaps that is the looping one, style 20 and basedon 20 ?

*** This bug has been marked as a duplicate of bug 49587 ***