Download it now!
Bug 57849 - EDITING: CONDITINAL FORMATTING lost after copy / paste of all sheet contents
Summary: EDITING: CONDITINAL FORMATTING lost after copy / paste of all sheet contents
Status: CLOSED DUPLICATE of bug 61946
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-03 18:53 UTC by Rainer Bielefeld Retired
Modified: 2013-11-23 12:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-12-03 18:53:12 UTC
The first who observed this problem was andis.lazdins@gmail.com in "Bug 56316 - EDITING: CONDITIONAL FORMATTING not included in copy-paste cell"

Steps to reproduce with parallel installation of  "LOdev  4.0.0.0.alpha1   -  ENGLISH UI / German Locale  [Build ID: dec8fe)]"  {tinderbox: @6, pull time 2012-11-13 06:07:28} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch:
1. Download / Unzip  Attachment 68944 [details] of a.m. Bug
2. open "SampleSource.ods"
3. In only existing sheet click common row/column header 
   > All cells will be selected
4. <control+c> for copy
5. Click "+" Sheet tab to create nes sheet
6. Click into Cell A1 of new sheet 
7. <control+v> for paste
8. check Cell I5 in new Sheet after click with
   menu 'Format -> Contitional formatting -> 
   Conditional formatting. 
   Expected: conditional formatting
   Actual: NO conditional formatting

Still worked fine with Server installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 475d0c5-829fc92-39746e8-206648e-fefd87]" (2012-02-14) (old CF dialog

We will still have to do some research whether this bug already has been reported.
              
Operating System: Windows 7
Last worked in: 3.6.0.0.alpha1
Comment 1 Rainer Bielefeld Retired 2012-12-03 18:54:24 UTC
@andis.lazdins@gmail.com
Was that the way you observed your problem?
Comment 2 Rainer Bielefeld Retired 2012-12-03 19:00:21 UTC
Already [Reproducible] with Server Installation of  "LibreOffice 3.6.0.2 rc  German UI/Locale [Build-ID:  815c576] on German WIN7 Home Premium (64bit) 
[Reproducible] with Server Installation of  "LibreOffice 3.6.0.2 rc  English UI/ German Locale [Build-ID:  815c576] on German WIN7 Home Premium (64bit), what has the new CF dialog.

Seems the new CF handling has had this problem from the beginning.

@Markus:
Can you please check?
Comment 3 andis.lazdins 2012-12-03 19:48:05 UTC
(In reply to comment #1)
> @andis.lazdins@gmail.com
> Was that the way you observed your problem?

I provide more detailed explanation and sample file here https://bugs.freedesktop.org/show_bug.cgi?id=56316

The problem for me seems to be more complex, because I also cannot work with several complex spreadsheets with all versions of 3.6 branch. The latest stable version with working fine for me was 3.5.5
Comment 4 Rainer Bielefeld Retired 2012-12-04 05:37:25 UTC
Attachment 68944 [details] indeed shows the same problem (I believe: like all spreadsheet documents, there are no other conditions)

This is not a regression, but a problem with a new feature, so I delete key word what has been added automatically by BSA.

@andis.lazdins@gmail.com:
It is very important to contribute a very clear and specific description for such a bug so that we do not get chaos during the fixing process.
Additionally 
<http://wiki.documentfoundation.org/BugReport#General_information> item 4
is important for a determined bug fixing process.
Comment 5 Rainer Bielefeld Retired 2012-12-04 06:01:49 UTC
"to new sheet" is not a necessary condition
Comment 6 andis.lazdins 2012-12-04 06:26:21 UTC
(In reply to comment #4)
> Attachment 68944 [details] indeed shows the same problem (I believe: like
> all spreadsheet documents, there are no other conditions)
> 
> This is not a regression, but a problem with a new feature, so I delete key
> word what has been added automatically by BSA.
> 
> @andis.lazdins@gmail.com:
> It is very important to contribute a very clear and specific description for
> such a bug so that we do not get chaos during the fixing process.
> Additionally 
> <http://wiki.documentfoundation.org/BugReport#General_information> item 4
> is important for a determined bug fixing process.

Thank you for recommendations! I'm not programmer, but user of Libreoffice, and I'm contributing by donations paying much more than for a version of Microsoft office. I'm sure it is sufficient and for that I would like at least normal communication. 

I see that something is not working and it is an old feature, therefore for me it is a regression. The rest is at developers side.

The problem is not only when copy/paste whole sheet, but also certain area of cells and another problem that it is not possible to get to the initial status with undo command. If you thing that it is reasonable to open new bug report for that, I can do it, because the problem is really terrible.
Comment 7 Markus Mohrhard 2013-06-28 23:13:55 UTC
Is this still an issue in 4.0/4.1/master?
Comment 8 andis.lazdins 2013-06-29 07:19:08 UTC
(In reply to comment #7)
> Is this still an issue in 4.0/4.1/master?

Hello!

I'm not sure if it is supposed to be like it is, but in both, source and target file conditions in example file in I5 cell looks a bit strange - $Tabelle1.$T5>#REF! and $Tabelle1.$T5<=#REF!
I guess some value is converted to #REF! while opening in 4.0.4.2.
In 4.1.0.0.beta1 it looks exactly the same.

I don't have other versions of libreoffice, but in openoffice.org 2.4.2 the same condition looks the same. Probably something is messed up already in sample files.

From everyday work I have feeling, that the problem, that my problem is solved in 4.0.4
Comment 9 Eike Rathke 2013-11-23 12:23:51 UTC
Fixed with #61946

The #REF! references are unrelated and simply a result of having deleted the sheets they pointed to in the test case document.

*** This bug has been marked as a duplicate of bug 61946 ***