Bug 57931 - Text Import dialog does not take focus, which causes it to be "lost" in the stack of LibreOffice windows
Summary: Text Import dialog does not take focus, which causes it to be "lost" in the s...
Status: RESOLVED DUPLICATE of bug 32935
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-06 02:34 UTC by Ben
Modified: 2013-06-29 15:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot demonstrating that the "Text Import" dialog is not visible within LibreOffice's jump-menu on the Windows Taskbar (96.10 KB, image/png)
2012-12-06 02:34 UTC, Ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2012-12-06 02:34:50 UTC
Created attachment 71067 [details]
Screenshot demonstrating that the "Text Import" dialog is not visible within LibreOffice's jump-menu on the Windows Taskbar

If I already have one or more LibreOffice spreadsheets open, and I then open a .CSV file that requires me to choose some Import options, I find that the "Text Import" dialog does not take focus. This behavior causes me to think that the file failed to be opened for an unknown reason.

The "Text Import" dialog doesn't appear in the "stack" of LibreOffice Taskbar icons, either. Nor does the dialog appear in Windows Explorer's Alt-Tab list. So, even if I suspect that the dialog is there, somewhere, I can't ever find it -- unless I "guess" the "parent window" to which it is attached and select said window.

I notice that the dialog attaches itself to a "parent window". If I have four (4) spreadsheets open in LibreOffice, the dialog seems to attach itself to one of them at random. I know better than to believe that it's at random, but there's no readily-discernible logic behind to which open window the dialog is attached.

The attached screenshot demonstrates clearly that dialog does not appear in the so-called "jump list" on the Windows Taskbar. So, how is the user supposed to "find" this dialog when he opens a document from his Desktop, for example?

It bears mention that this issue is particularly annoying when restoring a crashed LibreOffice session. All of the restored documents open, except for the document that is waiting for me to choose "Text Import" options. And, again, the dialog does not steal focus, as it should, which leaves me guessing.

Worse yet, once the dialog is open (and "lost" somewhere within the parent stack), further attempts to open the document (e.g., from the Desktop) yield no action whatsoever. The Windows "waiting" cursor appears and spins for a moment, and then it disappears without LibreOffice, nor any of its attendant windows, ever taking focus. Bad for business.
Comment 1 Ben 2012-12-06 02:35:34 UTC
P.S. I am not the first to notice or inquire regarding this issue: http://listarchives.libreoffice.org/global/users/msg16125.html .
Comment 2 Ben 2013-06-29 15:06:54 UTC

*** This bug has been marked as a duplicate of bug 32935 ***