Bug Hunting Session
Bug 57939 - FILEOPEN kerning is always disabled in imported ODT document
Summary: FILEOPEN kerning is always disabled in imported ODT document
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.0.0.0.beta0 target:4.1.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-06 09:00 UTC by Miklos Vajna
Modified: 2013-11-13 23:35 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
ODT file reproducing the issue. (4.65 KB, application/vnd.oasis.opendocument.text)
2012-12-06 09:00 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2012-12-06 09:00:32 UTC
Created attachment 71075 [details]
ODT file reproducing the issue.

Since http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4d20a400b5c06959fd5a362a350bb4d9a6e4bd1, the attached document no longer has different widths in the first and second paragraph. Works fine with 3.6.
Comment 1 Not Assigned 2012-12-06 09:40:54 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9adfadfe380f83af8c7ff5358d2027f0babc504d&g=libreoffice-4-0

Resolves: fdo#57939 use different layout instances for differing kerning flags


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Not Assigned 2012-12-06 09:41:22 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2f80337e5eccbb7c57493eddd1d4e62de0fb1276

Resolves: fdo#57939 use different layout instances for differing kerning flags



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.