Bug Hunting Session
Bug 57947 - Option to prevent LibreOffice from switching language on keyboard input language change
Summary: Option to prevent LibreOffice from switching language on keyboard input langu...
Status: RESOLVED DUPLICATE of bug 36324
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-06 12:11 UTC by pp.publikus
Modified: 2012-12-09 21:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pp.publikus 2012-12-06 12:11:50 UTC
This behavior - while certainly useful for many people - is something that greatly disrupts some people's typing habits (or the language of the documents they write).

I know that there is a workaround: to put all my used keyboards under the same input language, but that has various other side effects, and I would like to not have to change my OS's configuration for the sake of LibreOffice.

This issue is discussed in length on the openoffice bug tracker:
https://issues.apache.org/ooo/show_bug.cgi?id=100762

Others also have this problem:
http://superuser.com/questions/417838/prevent-libreoffice-from-switching-language-on-keyboard-layout-change
http://ask.libreoffice.org/en/question/2136/writer-document-language-changes-with-keyboard/

Bottom line is, there is a significant amount of people who are annoyed by this behaviour, so a switch to turn it off would be welcome.

An addition: I could not reproduce this "feature" (bug?) in linux. Setting "setxkbmap us" and "setxkbmap hu" did not change the language of the document. This is one more reason to have this switch -- to be able to more easily operate libreoffice consistently between platforms.
Comment 1 Urmas 2012-12-06 12:43:40 UTC
Compatibility with this lack of feature in Linux was added in development version.
Comment 2 manj_k 2012-12-09 21:20:40 UTC
Fixed with 'Bug 36324 - Keeping Language for Paragraph Style (it switches with the input language of the keyboard)'.

*** This bug has been marked as a duplicate of bug 36324 ***