Download it now!
Bug 57953 - Page Columns Broken if "AutoWidth" not selected
Summary: Page Columns Broken if "AutoWidth" not selected
Status: RESOLVED DUPLICATE of bug 53525
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 53944 58188 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-06 18:52 UTC by Joel Madero
Modified: 2012-12-18 15:07 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file: two_columns.odt (17.37 KB, application/vnd.oasis.opendocument.text)
2012-12-08 16:42 UTC, manj_k
Details
FDO 57953 Bibisect Log (2.82 KB, text/plain)
2012-12-14 18:19 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2012-12-06 18:52:48 UTC
I found this one when triaging this bug: https://bugs.freedesktop.org/show_bug.cgi?id=53944

Steps to Reproduce:
Open a new writer document
Format -> Page -> Columns
Select 2 Columns and untick "AutoWidth"
Push Ok


Behavior: Tab stop shows up on the top ruler but columns aren't respected

Expected Behavior: Tab stops should show up and columns should be the result -- ie. you can't type across the tab stop

Version 4.1.0.0.alpha0+ (Build ID: dfd474710f959dcf78038deb990c3618b467ec6)

on Bodhi Linux
Comment 1 manj_k 2012-12-08 16:40:16 UTC
Confirmed on WinXP 32b
with:

LibO-Dev_4.0.0.0.alpha1+
Win-x86@6 MASTER
pull time 2012-12-03 09:03:45
core:ac4d26e3fc2728ee80f33a485540d50b48927ddc

LibO_Dev 4.0.0.0.beta1
Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)


Open the attached file:
two_columns.odt
(2 columns 84.40 mm / 75.62 mm · Spacing 9.98 mm)

Created with LibO 3.6.4.3,
and works fine with LibO 3.6.4.3.
Comment 2 manj_k 2012-12-08 16:42:03 UTC
Created attachment 71206 [details]
Sample file: two_columns.odt
Comment 3 Jared 2012-12-10 16:58:46 UTC
*** Bug 53944 has been marked as a duplicate of this bug. ***
Comment 4 pierre-yves samyn 2012-12-11 14:17:22 UTC
Hello

Confirmed on windows 7 64bits with LibO-Dev_4.0.0.0.beta1

Regards
Pierre-Yves
Comment 5 manj_k 2012-12-12 17:24:47 UTC
*** Bug 58188 has been marked as a duplicate of this bug. ***
Comment 6 Joel Madero 2012-12-12 17:30:28 UTC
I should have a bibisect for this shortly and then I'll get in touch with whoever made the patch that borked this :)
Comment 7 Joel Madero 2012-12-14 18:19:35 UTC
Created attachment 71518 [details]
FDO 57953 Bibisect Log
Comment 8 Björn Michaelsen 2012-12-14 18:26:46 UTC
# good: [778045e259d6c6cdd39e55feea1646e95eab8537] source-hash-6aeeca56daa9065f607cc7056e7d86d237c84a99
# bad: [3a336c0c31bf41ebaa40c23ee063bd38a8aa334f] source-hash-5695aea3bbe719881177b35c805920bee608751b

suggests this is introduced in the range 6aeeca56daa9065f607cc7056e7d86d237c84a99..5695aea3bbe719881177b35c805920bee608751b

git log 6aeeca56daa9065f607cc7056e7d86d237c84a99..5695aea3bbe719881177b35c805920bee608751b

show these, and esp. this suspicious (wrt the bug) commit:

commit de1c42d9f552bc57b28d50f4313bc982c63b84d4
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sun Jun 17 13:33:03 2012 -0500

    writer:crash(i118878) when adding columns and chang. properties in a frame
    
    when adding columns, GetNumCols() reflect the new number of columns
    before the actual columns available are updated.
    Due to the way and order in which properties are updated
    the code that adjust the columns can be run before the new columns
    are avialable.. and was using GetNumCols().
    This patch avoid using that api and rely on the column iterator
    to determine the acutal number of column available.
    
    Change-Id: I52e75ec82c1ace65b05b8df9e54f4689f2aec8d3

CC'ing Norbert to have a look ...
Comment 9 manj_k 2012-12-15 14:14:46 UTC
See also: mab4.0 'Bug 53525 - FILEOPEN existing document: 2 columns Table of contents exceeds page width'.

[Please select the duplicate.]
Comment 10 Michael Meeks 2012-12-18 13:37:53 UTC
I reverted that fix of Norbert's yesterday and applied a simpler version. Any chance you could re-test ?
Comment 11 pierre-yves samyn 2012-12-18 13:54:39 UTC
Hello

WORKSFORME with daily:
Version 4.0.0.0.beta1+ (Build ID: 315b9b4a5c53eed5fd283bc329e05d7d8fbc9eb)

Thank you

Regards
Pierre-Yves
Comment 12 Michael Meeks 2012-12-18 14:31:30 UTC
great - that contains the fix - so really this was a duplicate :-)

*** This bug has been marked as a duplicate of bug 53525 ***