Bug 57987 - Start Center appears in front of (and hides) document recovery window.
Summary: Start Center appears in front of (and hides) document recovery window.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Document-Recovery
  Show dependency treegraph
 
Reported: 2012-12-07 16:12 UTC by Shad Sterling
Modified: 2020-05-10 03:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shad Sterling 2012-12-07 16:12:54 UTC
After a crash (or a forcequit) with files open, restarting LibreOffice brings up first the document recovery window, then the Start Center opens in front of it, hiding the fact that LibreOffice has noticed a need to recover files.
It may be best to integrate document recovery into the Start Center.
Comment 1 Emir Sarı 2012-12-08 02:33:23 UTC
This is an enhancement request, so changing importance status to "enhancement".
Comment 2 Emir Sarı 2012-12-08 02:37:26 UTC
Sorry - I reread the sentence of yours and saw that you wrote: "LibreOffice brings up first the document recovery window, then the Start Center opens in front of it" - as far as I remember LO always brings up the recovery window, and start center keeps on the background. 

I'll try to crash LO and then see how it happens. :)
Comment 3 Jorendc 2013-06-27 20:31:42 UTC
Thanks for reporting!

I can reproduce this behavior using Mac OSX 10.8.4 with LibreOffice 4.0.4.2. I had a crash recently and can confirm this. First recovery window opens, a second after that the Start Center opens in front of it (hiding the recovery window).

Kind regards,
Joren
Comment 4 QA Administrators 2015-03-16 23:13:43 UTC Comment hidden (obsolete)
Comment 5 Jean-Baptiste Faure 2015-03-24 05:16:37 UTC
I did not experienced this problem with the crashes I recently had with LibreOffice 4.4.x under Linux. Is it still there under MacOS ?

Best regards. JBF
Comment 6 Shad Sterling 2015-05-19 13:22:18 UTC
No change in 4.4.2.2 on Mac OS X 10.10.3.

In 4.4.3.2, after a forcequit the Start Center does not appear, so document recovery is not hidden; I haven't yet seen a crash of 4.4.3.2.
Comment 7 Shad Sterling 2015-05-21 18:23:24 UTC
With 4.4.3.2, recovering from OS X 10.10.3 crashing, the Start Center does still appear and hide document recovery.
Comment 8 Shad Sterling 2015-07-10 21:43:40 UTC
It looks like when the app launches it only brings up the recovery window, but when it is brought to the foreground it opens the Start Center.  So when I forcequit and relaunch is starts in the foreground and, since it wasn't brought to the foreground, the Start Center doesn't appear.  When the OS crashes and upon reboot relaunches all open apps and LibreOffice does not start in the foreground, then when it is brought to the foreground I see the recovery window just for a moment before the Start Center appears in front.
Comment 9 Shad Sterling 2016-02-02 14:41:17 UTC
Still happens with 5.0.4.2 on OS X 10.11.2
Comment 10 QA Administrators 2017-03-06 15:36:42 UTC Comment hidden (obsolete)
Comment 11 Shad Sterling 2017-03-07 05:13:52 UTC
Still happens with 5.2.5.1 on OS X 10.12.3
Comment 12 QA Administrators 2018-10-08 02:47:58 UTC Comment hidden (obsolete)
Comment 13 eisa01 2020-05-09 22:08:03 UTC
Seems to work correctly now

Tested both only opening LO, and opening a file

Version: 7.0.0.0.alpha0+
Build ID: f14691683900f6b28737be8c599e1ee4e8386e14
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 14 Shad Sterling 2020-05-10 03:26:52 UTC
With 6.2.5, recovering from a forcequit doesn't open the startcenter, same as the start-in-foreground case in comment 8; I'm not going to crash my system to test the start-in-background case right now, I might be able to to try that tomorrow or next weekend.