Download it now!
Bug 58034 - Version details in About box for dailies are not the same in MSVC and MinGW builds
Summary: Version details in About box for dailies are not the same in MSVC and MinGW b...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Petr Mladek
URL:
Whiteboard: target:4.2.0 target:4.1.2 target:4.0.6
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-08 22:49 UTC by Pedro
Modified: 2013-08-29 15:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2012-12-08 22:49:50 UTC
The expected Version info in daily builds after Petr's modification should be

Version 4.1.0.0.alpha0+ (Build ID: e9b21193ed395061b155955e5098f69af92b4fc)
TinderBox: Win-x86@7-MinGW, Branch:master, Time: 2012-12-08_00:08:45

However in daily builds compiled with MSVC (as those from tinderbox @6) you only get

Version 4.1.0.0.alpha0+ (Build ID: 08d2a6532ece404f12dd5dbc84f0d6122db5abd)
Comment 1 Joel Madero 2012-12-11 17:03:23 UTC
Petr can you confirm this one and mark as NEW?
Comment 2 Petr Mladek 2012-12-12 16:24:15 UTC
The problem is that tinderbox @6 uses incremental build, so the about dialog is rebuilt only when there are changes in the sources.

We added a hack to always rebuild this file on this tinderbox, so the next build should be fine.

Hmm, I should come up with better solution and pass the value via config.h that was introduced in master.
Comment 3 Pedro 2012-12-30 20:23:55 UTC
Fixed in the Master branch

Version 4.1.0.0.alpha0+ (Build ID: c5132e30fb09477aa46d810dd86727b3aa8cf20)
TinderBox: Win-x86@6, Branch:master, Time: 2012-12-30_01:13:14

But not on dailies from the 4.0 branch...
Comment 4 Petr Mladek 2013-01-02 13:06:10 UTC
Lubos, could you please fix also the incremental build from libreoffice-4-0 branch?
Comment 5 Luboš Luňák 2013-01-03 13:17:16 UTC
EXTRA_BUILDID support itself doesn't work in 4.0.
Comment 6 Pedro 2013-04-22 09:38:19 UTC
Information in the daily Master About box has regressed to version 4.0 contents:

Version: 4.1.0.0.alpha0+
Build ID: 0b4315077a6827798e1d2bdae73298365ba9a01
TinderBox: Win-x86@6, Branch:master, Time: 2013-04-18_04:00:51

to

Version: 4.1.0.0.alpha0+
Build ID: 288c8b9d59024897e88b55b9001f9922998d130

(this is from master~2013-04-21_13.18.12_LibreOfficeDev_4.1.0.0.alpha0_Win_x86.msi downloaded from tinderbox #6)
Comment 7 Petr Mladek 2013-04-23 11:21:12 UTC
I see that it works in master again as mentioned in http://lists.freedesktop.org/archives/libreoffice-qa/2013-April/004321.html.

The build was broken for few days on the tinderbox #6. I guess that the regression was related to the first successful build which might have been partially hand made.
Comment 8 Pedro 2013-04-23 11:25:48 UTC
Hi Petr

> I see that it works in master again as mentioned in
> http://lists.freedesktop.org/archives/libreoffice-qa/2013-April/004321.html.

Yes, I meant to update it here as well (removed the regression keyword as well).

Maybe this bug can be closed when 4.1 is out.
Comment 9 Pedro 2013-04-26 10:47:25 UTC
Installed  master~2013-04-25_18.39.59_LibreOfficeDev_4.1.0.0.alpha0_Win_x86.msi

The About box shows the same regression as in comment #6.

Not installing any new Master builds until further notice.
Comment 10 V Stuart Foote 2013-05-10 15:02:35 UTC
Lack of the Build source and date/time stamp in the Help > About LibreOfficeDev panel is troubling because the daily builds have no external details as to the git commit tag and are only date/time titled. If routinely doing "server" /A administrative installations of the dev builds can be difficult to identify which build to report when triaging or filing issues. 

From comment to: http://nabble.documentfoundation.org/Libreoffice-qa-ANNOUNCE-libreoffice-4-1-0-0-alpha1-tag-created-tc4054044.html

Fixing the EXTRA_BUILDID details in the incremental daily builds would be helpful, but it does not prevent the effective use of the daily builds for QA.  Making the git commit ID directly available in the installer packaging would be a convenience--for Windows builds that would be in the .MSI as a Property table entry or perhaps in the Summary Information comments to supplement the CLSID/GUID
Comment 11 Pedro 2013-05-29 14:33:42 UTC
The About dialog from 

Version: 4.2.0.0.alpha0+
Build ID: 0bfb9e93346e0bcac1b7e228cc8860eec029559
TinderBox: Win-x86@6, Branch:master, Time: 2013-05-26_06:09:16

was correct. Sadly the same can't be said for the builds from yesterday (master~2013-05-28_00.20.43) and today (master~2013-05-29_00.08.39)

I always get my builds from the same Tinderbox... I can't understand why this works on and off...
Comment 12 Commit Notification 2013-08-29 11:30:35 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28cc89aad16e8ea3c9eec7f45749c1cfaaf1d7af

make the tinderbox information more reliable in the about dialog (fdo#58034)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Petr Mladek 2013-08-29 11:49:33 UTC
The information is passed via header file generated by configure. The about dialog will get rebuilt also by the incremental build. It should be more reliable.

There is still a risk. If a tinderbox runs configure without the extra ID option, it might trigger rebuild without this information.

Let's see if it helps in the real life or not.

I have nominated the fix also for 4-1 branch, see https://gerrit.libreoffice.org/5677
Comment 14 Commit Notification 2013-08-29 12:00:36 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ea316c964a8e4405ccbfdd0f27b5e07ede2c5239&h=libreoffice-4-1

make the tinderbox information more reliable in the about dialog (fdo#58034)


It will be available in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2013-08-29 13:01:17 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d9b62a48d75e596888fcf10f5f73fed93e7b88a3

Allow to set EXTRA_BUILDID also via environment variable (fdo#58034)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Pedro 2013-08-29 13:08:44 UTC
(In reply to comment #13)
> Let's see if it helps in the real life or not.

Hi Petr

I think that it is more important now than before since there are several tinderboxes for each branch (e.g. for the master branch under the Windows platform there are currently 3 "daily" builds...)

Thank you for fixing this!
Comment 17 Commit Notification 2013-08-29 15:02:46 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=181d0a163f8c8f744077021eb550f0e6304fb4da&h=libreoffice-4-1

Allow to set EXTRA_BUILDID also via environment variable (fdo#58034)


It will be available in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2013-08-29 15:03:10 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b665b58af200b51ec6d884168d3781899ed5ba0&h=libreoffice-4-0

make the tinderbox information more reliable in the about dialog (fdo#58034)


It will be available in LibreOffice 4.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.