Bug 58097 - FILESAVE .ppt (MSO97) retaining that format causes error message when trying to open with MSO
Summary: FILESAVE .ppt (MSO97) retaining that format causes error message when trying ...
Status: RESOLVED DUPLICATE of bug 58129
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-10 18:17 UTC by chefchenko
Modified: 2012-12-16 07:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Original PowerPoint 2003 File created with PowerPoint (2.00 MB, application/vnd.ms-powerpoint)
2012-12-10 18:17 UTC, chefchenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chefchenko 2012-12-10 18:17:22 UTC
Created attachment 71285 [details]
Original PowerPoint 2003 File created with PowerPoint

Problem description: 

Steps to reproduce:
1. Open PowerPoint Presentation and save it as PowerPoint 2003 (ppt)
2. Open the newly created file with Powerpoint 2010
3. Error Message

              
Operating System: Debian
Last worked in: 4.0.0.0.beta1
Comment 1 Rainer Bielefeld Retired 2012-12-10 21:28:07 UTC
[Reproducible] with parallel installation of  "LOdev  4.0.0.0.beta1   -  GERMAN UI / German Locale  [Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)]"  {tinderbox: @6, pull time 2012-12-06} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch.

Open attachment, save under new name as ppt (MSO97), try to open with MS PPT Viwer. Error Message (translated from German) "Office recognized a problem with this document. For protection of the Computer this document can not be opened"

I wonder why the original document (what does not work with my MS ppt viewer) with 2046 kB reduces size to 723 kB after having been saved with LibO. I remember we had a similar problem some time ago, I will check that.

My suspect: original document contains uncompressed pictures what are compressed after document has been saved from LibO.

Also with LibO4 the document saved from LibO4 looks cruelly damaged.

I will do further research tomorrow.
Comment 2 Michael Stahl (allotropia) 2012-12-12 18:41:33 UTC
Writer does not store PPT format
Comment 3 chefchenko 2012-12-12 19:27:50 UTC
(In reply to comment #2)
> Writer does not store PPT format

sorry, i changed it to presentation
Comment 4 Rainer Bielefeld Retired 2012-12-16 07:36:12 UTC
(In reply to comment #1)
I think my suspect was wrong. A .ppt saved from LibO 3.6.4.3 has a similar size, but MS PPT Viewer opens it without problems.

It's a general problem, even a blank new presentation without any contents saved as .ppt will be rejected by MSO.

Marking this one as DUP of "Bug 58129 - FILESAVE: Generic problem of exporting ppt file" because there research already has some more progress.

@chefchenko
Your sample document shows some more problems with LibO 4.0 presentations, I will report them and add you to CC.

*** This bug has been marked as a duplicate of bug 58129 ***