Bug 58184 - Can not add digital signature via digital signature management dialog
Summary: Can not add digital signature via digital signature management dialog
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected) Master
Hardware: x86-64 (AMD64) All
: high normal
Assignee: Not Assigned
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
Reported: 2012-12-12 11:11 UTC by Alex Thurgood
Modified: 2019-01-09 09:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2012-12-12 11:11:55 UTC
Version (Build ID: 217ba33cb02c86ea25bf62748e1bcbdd1218795)

The title says it all. Steps to reproduce :

1) Create a new Writer document. Type some text. Save the file.
2) File > Digital Signatures brings up the Digital Signature management dialog.
3) If no signatures are already present/listed, there is no way to add new digital certificates/signatures, or even to manage the existing ones.

So, how is this done ?
The only possibility I have found is via Tools > Options > Security

and then it only looks for NSS security certificates, i.e. in Firefox and Thunderbird profiles. Where have the other certificate support protocols gone ? Is there some kind of special build option I need to add in ?

Comment 1 Thomas Hackert 2013-05-09 15:10:32 UTC
Hello Alex, *,
I can confirm this bug with LO Version (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539) under Debian Testing AMD64 (and it was a problem with 4.0.2 as well ... :( ). I have tried to add my certificates, which I have imported from FF, but to no avail ... :(
Comment 2 Lampros Boukouvalas 2014-08-05 16:33:35 UTC
I tried to add my already installed certificate, but writer doesn't display it in certificates list.
Comment 3 Owen Genat (retired) 2014-10-05 13:08:31 UTC
Bug 82200 added to See Also list. Seems closely related, if not an actual duplicate.
Comment 4 QA Administrators 2015-10-14 19:56:44 UTC Comment hidden (obsolete)
Comment 5 Juan Picca 2015-11-17 19:40:29 UTC
It works for writer in

Steps followed (with certutil tool installed, package libnss3-tools in debian stretch):

1. Create a new certificate database using a password file
$ echo 123 > /tmp/user-certs.pass
$ mkdir /tmp/user-certs
$ certutil -N -f /tmp/user-certs.pass -d /tmp/user-certs

2. Create and add a certificate to the database
$ certutil -S -s "CN=My Issuer" -n myissuer -x -t "C,C,C" -f /tmp/user-certs.pass -d /tmp/user-certs

3. Add the database to libreoffice following steps described by Alex:
a. Go to Tools > Options > Security > "Certificate ..." button in "Certificate Path".
b. Add the path /tmp/user-certs
c. Restart writer

4. Sign the file
a. Open the file to sign
b. Go to File > Digital Signatures > "Sign document..." button
c. Use the previous password (123) to open the added certificate database and add the certificate.
Comment 6 Alex Thurgood 2016-07-22 15:24:44 UTC
@Juan : your description doesn't indicate how this should work on OSX, where I encounter the same problem. The point is, the dialog offers no way to add a certificate. This is, after all, supposed to be the digital signature management dialog (otherwise, why have an entry for it ?).
Comment 7 Markus Wernig 2017-01-30 09:48:43 UTC
The dialog under "File->Digital Signatures" is not for adding certificates to the certificate store. It is only for signing a document with existing certificates. The dialog to select the signing certificate comes after you hit "Sign Document".

You select the  certificate store to use under "Tools->Options>LibreOffice->Security->Certificate Path" (under Linux this is either from an existing thunderbird/firefox installation or a newly created one).

The type of certificate store available is OS-dependent, so it may differ on Windows and Mac.
Comment 8 Samuel Mehrbrodt (allotropia) 2017-06-27 08:09:48 UTC
There is now a "Start certificate manager" button in this dialog which starts an external certificate manager, if available.

I guess this is fixed then. LO is no certificate manager, it only uses existing certificates.
Comment 9 Caroline Webb 2019-01-09 09:55:42 UTC Comment hidden (spam)