Bug Hunting Session
Bug 58203 - : Bug in lists-the number ten object will go far from the line.
Summary: : Bug in lists-the number ten object will go far from the line.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: RTL-CTL Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2012-12-12 18:09 UTC by yinon
Modified: 2017-10-20 18:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
you can see the document in the left (1.07 MB, image/png)
2012-12-12 18:09 UTC, yinon
Details
no bug - success. thanks guys! (and girls P: ) (1.32 MB, image/png)
2016-04-17 02:23 UTC, yinon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yinon 2012-12-12 18:09:17 UTC
Created attachment 71400 [details]
you can see the document in the left

Problem description: look at list down here, I'll fill it till ten to describe:

Steps to reproduce:
1. ....
2. ....
3. ....
4.  bla bla
5.  bla bla
.   bla bla
.   bla bla 
.   bla bla
9.  bla bla
10.       bla bla
11.       bla bla
12.       bla bla
.         bla bla
.         bla bla
.         bla bla

and so on. getting to the object number twenty in the list is the same, so it may not be relate to every Tenth object.

here a copy from my document-it's in Hebrwe:

אופציות:
1. אדון השכפולים.
2. אדון אל-מוות
3. אדון הקרקעית
4. אדון הנקודות
5. אדון המים (לא נראה לי)
6. אדון הבועות?
7. אדון שחור?
8. אדון סגול?
9. אדון A ?
10. fdg
11. gdfgdf
12. dfgd
13. dgdf
14. dfg
15. dfg
16. dfg
17. df
18. gd
19. fgd
20. fgd
21. fgd
22. fg

well, you may not see it exectly, here a picture:
http://i.imgur.com/FrBfD.jpg

if you have some question, here is my gmail:
yinonzadok@gmail.com

if there someone who knows hebrew, it's better (:

Current behavior:

Expected behavior:

              
Operating System: Ubuntu
Last worked in: unspecified
Comment 1 Michael Stahl (CIB) 2012-12-13 14:01:34 UTC
trying this on current master, there is indeed additional spacing
after the list number in RTL text if that number is 2 digits...

the same thing happens in LTR text if the number is 3 digits.

perhaps these should behave in the same way?

maybe it's just some sort of "rounding error" where
we get slightly different widths for number in LTR vs RTL.
Comment 2 yinon 2012-12-14 13:29:46 UTC
OK, do you need me for any help?
I would like to help though I have no idea how.



2012/12/13 <bugzilla-daemon@freedesktop.org>

>  Michael Stahl <mstahl@redhat.com> changed bug 58203<https://bugs.freedesktop.org/show_bug.cgi?id=58203>
>  What Removed Added  CC   aalharthi@kacst.edu.sa, kaplanlior@gmail.com,
> mstahl@redhat.com  Keywords regression
>
>  *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=58203#c1> on bug
> 58203 <https://bugs.freedesktop.org/show_bug.cgi?id=58203> from Michael
> Stahl <mstahl@redhat.com> *
>
> trying this on current master, there is indeed additional spacing
> after the list number in RTL text if that number is 2 digits...
>
> the same thing happens in LTR text if the number is 3 digits.
>
> perhaps these should behave in the same way?
>
> maybe it's just some sort of "rounding error" where
> we get slightly different widths for number in LTR vs RTL.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 3 Lior Kaplan 2013-01-22 20:43:39 UTC
I could reproduce the problem when moving from 2 digits to 3 with text on both 3.6.5 rc2 and 4.0.0 rc1. This is regardless of which language, text directionality or interface we use.

Any way, seems like the fix when moving from 1 to 2 digits was done as part of 3.6.x. I didn't verify this, so just assuming.
Comment 4 QA Administrators 2015-02-19 15:31:06 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-03-06 15:09:16 UTC
Reproduced.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 6 tommy27 2016-04-16 07:27:39 UTC Comment hidden (obsolete)
Comment 7 yinon 2016-04-17 02:23:22 UTC
Created attachment 124419 [details]
no bug - success. thanks guys! (and girls P: )

retesting with lubuntu 15.04 and libreoffice 4.4.6.3
You all did a great job. be proud.
Comment 8 Buovjaga 2016-04-17 07:29:25 UTC
Nice to hear. Setting to WFM.