Bug Hunting Session
Bug 58204 - Textbox properties export to PPT bad (Impress)
Summary: Textbox properties export to PPT bad (Impress)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: bibisected40 target:4.1.0 target:4.0....
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-12 18:13 UTC by stfhell
Modified: 2013-01-30 12:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
PowerPoint textboxes (167.14 KB, application/zip)
2012-12-12 18:19 UTC, stfhell
Details
3.6 PPT Export (15.24 KB, application/pdf)
2013-01-08 19:39 UTC, Joel Madero
Details
latest master Ubuntu 12.10 (14.67 KB, application/pdf)
2013-01-08 19:42 UTC, Jorendc
Details
bisect log (2.90 KB, text/plain)
2013-01-22 14:42 UTC, Jorendc
Details
Bug document for n#404221 (38.50 KB, application/msword)
2013-01-24 13:56 UTC, Cédric Bosdonnat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stfhell 2012-12-12 18:13:46 UTC
If you open a presentation made with PowerPoint 14.0 (Office 2010), Impress imports properties for textboxes nearly correctly. On export to PPT, they are completely messed up:

- font sizes incorrect (PPT uses Calibri 14 and 12 pt; Impress has Calibri 18 pt everywhere)
- font colour incorrect (PPT subtitle has grey text; Impress black)
- the textboxes around the circle end with an additional empty paragraph
- textbox rotation for textboxes 3 (270°) and 7 (90°) wrong
- size of textbox 3 wrong

Export to PPTX works.

Tested with LOdev 4.0.0.0alpha1 (Ubuntu 12.04 AMD64).
Comment 1 stfhell 2012-12-12 18:19:25 UTC
Created attachment 71401 [details]
PowerPoint textboxes

Test files to reproduce:

- Open file PowerPoint_rotated_text_boxes.ppt. Import is nearly correct, only font size in subtitle should be 12pt instead of 8pt. (Verify with attached PDF made from PowerPoint.)

- Save (as PPT).

- Reopen: Textbox properties wrong.

(ZIP also contains PPTX version for comparisons. Import end export work as they should.)
Comment 2 stfhell 2012-12-12 18:26:23 UTC
Adding keyword regression. PPT import and export was much better in LO 3.6.2.2: Only font size in subtitle was wrong, the rotation of textboxes 5 and 7 and the sizes of the textboxes (should all be 0.8 x 2.5 cm).
Comment 3 Joel Madero 2013-01-08 19:39:39 UTC
Created attachment 72686 [details]
3.6 PPT Export

Here is how it looks after opening with 3.6 and exporting it
Comment 4 Jorendc 2013-01-08 19:42:00 UTC
Created attachment 72687 [details]
latest master Ubuntu 12.10

It looks even worse in current latest master: Version 4.1.0.0.alpha0+ (Build ID: 92afb61d8bb1b264a945371065115981ecaed0f)
Tested with Ubuntu 12.10 x64
Comment 5 Jorendc 2013-01-22 14:42:19 UTC
Created attachment 73452 [details]
bisect log
Comment 7 Michael Stahl (CIB) 2013-01-22 21:26:57 UTC
there is a regression in the range from comment #6,
this commit:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f5ec08d4d8ff64cbae83e47ac2159eb3a546bc79

but that is fixed already, it is bug 58129:

2395a3fb74a90cc3166dbe4722250376eff58547

but still on master it looks different than on buggy commit+fix applied,
in fact it looks the same on master as current 3.6,
unfortunately it is still wrong: west and east boxes have text rotated wrongly.

it seems that OOo 3.3 and 3.4beta do this right.
Comment 8 Michael Stahl (CIB) 2013-01-22 23:08:30 UTC
to make this even more annoying, MSO2010 displays the stored ppt differently,
for the "master" stored ppt there is only the East box wrongly rotated
(but at least in the same way as master),
so probably there is an import bug somewhere too...
Comment 9 Michael Stahl (CIB) 2013-01-23 13:01:42 UTC
the problem is that for the wrongly rotated frames
the properties 136 (ESCHER_Prop_txflTextFlow) are exported.

regression introduced by:

commit 24dd42f316e5cb16ba726c05ba486d53e033052d
Author: Cédric Bosdonnat <cedricbosdo@openoffice.org>
Date:   Mon Sep 13 17:15:50 2010 +0200

    sw-rtf-num-fix.diff:Fixes for RTF numbering export

    n#569266
Comment 10 Cédric Bosdonnat 2013-01-24 13:56:35 UTC
Created attachment 73584 [details]
Bug document for n#404221

Here is a document showing the problem initially fixed by this piece of code causing the problem.

To reproduce the bug, open n404221.doc, re-save it in doc format and open the saved file in Word: the vertical characters are no longer rotated after applying the patch.
Comment 11 Not Assigned 2013-01-24 22:36:17 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2823789bec0c029d9714aff0ed65923e23177ef9

fdo#58204: PPT export: fix text rotation in shapes:



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Michael Stahl (CIB) 2013-01-24 22:41:23 UTC
i'm hoping the export bug is fixed now, have tested
with the 2 ppt documents from bug 34897 as well,
one of which actually appears to be fixed by my commit.
Comment 13 Not Assigned 2013-01-25 14:56:41 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=666210dec152f8aa781b22495cf55e9a89d90d67&h=libreoffice-4-0

fdo#58204: PPT export: fix text rotation in shapes:


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Jorendc 2013-01-30 12:15:46 UTC
I can confirm this is fixed using latest master (pulled today) LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 9a39ae6d2d1eb1443bee95232c6b045d60f9052) using Linux Mint 14 x64

Thanks Michael!
Comment 15 Not Assigned 2013-01-30 12:18:47 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eae62710abb46e83376d38c259b98a2778a5bb72&h=libreoffice-3-6

fdo#58204: PPT export: fix text rotation in shapes:


It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.