Bug Hunting Session
Bug 58262 - FILEOPEN: ODT From MS Office Does Not Open
Summary: FILEOPEN: ODT From MS Office Does Not Open
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: (target:4.3.0)
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-13 20:41 UTC by Dave Richards
Modified: 2014-01-04 00:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Problem File (1.01 MB, application/vnd.oasis.opendocument.text)
2012-12-13 20:41 UTC, Dave Richards
Details
ODF validator output (95.54 KB, image/png)
2012-12-21 13:21 UTC, s-joyemusequna
Details
Original .doc the problem document was converted from. (1.22 MB, application/msword)
2013-01-02 14:27 UTC, Brian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Richards 2012-12-13 20:41:51 UTC
Created attachment 71465 [details]
Problem File

We got our users to request that outside contacts send us documents in ODT, which is great.  This file was created in MS Office and fails to open.  Opening this file in MS Office and exporting to DOC also does not open well.

Tested with 3.6 and 4.0 with same results.
Comment 1 Julien Nabet 2012-12-15 00:40:12 UTC
Comment on attachment 71465 [details]
Problem File

Fix mimetype
Comment 2 Korrawit Pruegsanusak 2012-12-16 11:39:55 UTC
REPRODUCIBLE with both 3.6.3.2 and 4.0beta1 on Windows 7 x64. The file can't open, LibO shows dialog that says:

> Read-Error.
> Error reading file.
Comment 3 Korrawit Pruegsanusak 2012-12-16 11:41:07 UTC
Note that the file could be opened in MS Word Starter 2010
Comment 4 s-joyemusequna 2012-12-21 13:21:30 UTC
Created attachment 71930 [details]
ODF validator output

This file seems to be an invalid ODF file. See the attached picture.
Comment 5 Brian 2013-01-02 14:27:12 UTC
Created attachment 72383 [details]
Original .doc the problem document was converted from.

We contacted the vendor and they sent us the original .doc file the problem file was converted from (see attached). They said MS Office 2010 was used to convert it.
Comment 6 Jorendc 2014-01-04 00:03:40 UTC
'Problem File' opens correctly, tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 5bf0a838e800605e95b5b03157bdf0780db497e6 TinderBox: Win-x86@39, Branch:master, Time: 2014-01-03_01:04:32

Might be fixed also with currently stable releases.

Please mark as VERIFIED WORKSFORME if you can confirm this bug seems fixed.

Kind regards,
Joren