Bug Hunting Session
Bug 58284 - UI: Number dropdown list in Tools > Outline Numbering is empty
Summary: UI: Number dropdown list in Tools > Outline Numbering is empty
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.0.0.0.beta2 target:4.1.0
Keywords: regression
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-12-14 12:34 UTC by Jean-Baptiste Faure
Modified: 2012-12-17 13:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
proposed patch (775 bytes, patch)
2012-12-16 00:25 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2012-12-14 12:34:38 UTC
Steps to reproduce:
1/ open a text document in LO 4.0 beta1
2/ go to menu Tools > Outline Numbering...

==> the list with label "Number" is empty
Expected : this list should propose several numbering choices

No problem in LO 3.6.4
Reproducible in LO 4.0 beta1+ (Build ID: 3c89d9c2b3f2a4bb260624ba97692879ccc3f5c)

NB: if Outline Numbering exists in the current document, it works as expected. The problem is only in the dialog used to define / modify outline numbering.

Best regards. JBF
Comment 1 sophie 2012-12-14 12:39:10 UTC
I can confirm the Number list is empty in LO 4.0 beta1+ (Build ID: 3c89d9c2b3f2a4bb260624ba97692879ccc3f5c) under Linux.
Numbering is working when already created in a document. 
Kind regards - Sophie
Comment 2 pierre-yves samyn 2012-12-14 12:42:15 UTC
Hello

I confirm with Version 4.0.0.0.beta1+ (Build ID: 58889b2f592658a6c68ed13fe604fbbe7eaad96) & Windows 7 64bits

Regards
Pierre-Yves
Comment 3 Roman Eisele 2012-12-15 19:36:03 UTC
Also reproducible with 4.0.0.0beta1 on Mac OS X (10.6.8, Intel).
Comment 4 Roman Eisele 2012-12-15 19:45:17 UTC
I can NOT reproduce this issue on Mac OS X with the master build
  master~2012-11-28_04.07.39_LibO-Dev_4.0.0.0.alpha1_MacOS_x86_install_en-US
but I can reproduce it with the build
  master~2012-12-06_09.19.57_LibO-Dev_4.1.0.0.alpha0_MacOS_x86_install_en-US
(no master builds for Mac OS in between, sorry!).

So this is a regression, introduced between
2012-11-28 04.07.39
and
2012-12-06 09.19.57 ...
This should help a little bit to fix the regression.
Comment 5 Julien Nabet 2012-12-16 00:25:22 UTC
Created attachment 71571 [details]
proposed patch

On pc Debian x86-64 with master sources updated today, I reproduced the problem.

I wonder if the problem doesn't come from this commit:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=84fd33b7c4e7bf5f8ceb2a8c25426a5b1c713489

Since numbering was linked to this class "swlo:SwNumberingTypeListBox", I searched about it and found 4 ui  (included outlinenumberingpage.ui modified in the patch), all located here:
sw/uiconfig/swriter/ui/
I noticed each time for the 3 others, these kinds of lines:
<property name="hexpand">True</property>
<property name="type">16</property>

I don't know what these properties correspond and for a reason I ignore, type 16 wouldn't work here since "None" is not in first place (not even in the list!).
 
So I tried at random different types and found that 17 was ok.

Obviously, even if numbering seems to work with the patch, I suppose the patch should be modified.
Comment 6 Julien Nabet 2012-12-16 00:27:46 UTC
Caolán: would you have some time to take a look? I attached a very simple and short patch but certainly there's something to update here.
Comment 7 Caolán McNamara 2012-12-17 12:44:06 UTC
yikes, oops.
Comment 8 Not Assigned 2012-12-17 12:58:52 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0238a46e0850150e68218734dda86d6bd08523f&g=libreoffice-4-0

Resolves: fdo#58284 outline numbering list is of wrong type


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Not Assigned 2012-12-17 12:59:13 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ec1f1c16e36b1fa5138604ca08fff1888cf7513c

Resolves: fdo#58284 outline numbering list is of wrong type



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2012-12-17 13:00:07 UTC
yup, that's the right fix with type 17 rather than type 16. Thanks for that.