Bug Hunting Session
Bug 58300 - FILEOPEN: lost bibliography entries/empty bibliography index when saving as .doc or .docx
Summary: FILEOPEN: lost bibliography entries/empty bibliography index when saving as ....
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect
Depends on:
Blocks:
 
Reported: 2012-12-14 16:03 UTC by d.hummel
Modified: 2016-04-16 07:38 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
typescript (3.11 KB, text/plain)
2012-12-15 13:30 UTC, Terrence Enger
Details
testkit with original ODF file and exported OOXML (11.80 KB, application/x-zip-compressed)
2016-04-16 07:35 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description d.hummel 2012-12-14 16:03:59 UTC
Writer loses all Bibliography entrees when saving to doc. oder docx.
Comment 1 d.hummel 2012-12-14 16:05:30 UTC
Writer loses all bibliography entrees when saving to doc. or docx.
Comment 2 Jorendc 2012-12-14 18:38:52 UTC
hi,

Could you be a bit more specific and provide us steps how we can reproduce this behavior/bug.

Thanks in advance,
Joren
Comment 3 d.hummel 2012-12-14 18:51:11 UTC
Of course, sorry.
Create a new text document, insert one or more bibliography entries from document content. Display them with a bibliography index/table. Save document as doc. or docx. and close it.
When you open the file, the bibliography entries are gone, so bibliography index/table is empty.
Comment 4 Jorendc 2012-12-14 19:19:06 UTC
Thanks for your report!

I can reproduce under Mac OSX 10.8.2; LibreOffice 3.6.4.3(Build ID: 2ef5aff) and LibreOffice Version 4.0.0.0.beta1 (Build-id: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-05_22:13:37
Both with Dutch-UI
Comment 5 Jorendc 2012-12-14 19:31:28 UTC
Reproducible with LibreOffice 3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b so change bug-version. This is NOT a regression so far...
Comment 6 Marco Menardi 2012-12-14 21:17:11 UTC
Version 3.6.1.2 (Build ID: 360m1(Build:2))
Debian GNU/Linux unstable

I can reproduce the bug.
Also I've tried to do half the steps needed to reproduce this bug, and my findings are that if you simply:
Insert -> indexes and tables -> bibliography entry...
select 'from document content'
New
added one
Insert
then I save as .docx and if I reopen it instead of the grayed background [MYRECORDNAME] I've the simple text "Bibliography entry", that is suspicious too.
Comment 7 Jorendc 2012-12-14 21:20:23 UTC
Detailed steps how to reproduce:
1) open Writer
2) insert -> indexes and tables -> bibliography entry
3) choose 'From document content' and click on 'New'
4) Enter a 'short name' ( and choose a 'type' (doesn't matter); you can add more information ... but it's reproducable with only that information
5) Click OK
6) Click Insert and then Close
7) insert -> indexes and tables -> indexes and tables...
8) In tab 'index/table' select 'Bibliography' as 'Type'
9) click OK
10) now you have a document with an entry and a table of contents with your entry in it
11) save file as .doc (or .docx)
12) close document and reopen it
Result: empty table of contents.

Expectation: table of contents with added entries.
Comment 8 Terrence Enger 2012-12-15 13:10:40 UTC
The bug is evident in all of bibisect 3.6 latest, 3.6 oldest, 3.5
latest, and 3.5 oldest when I saved the document as MS Word 2007/2010
XML (.docx).

Along the way, I accidentally saved once as--I think--Office Open XML
Text (.docx).  The result was different: Table heading changed to
"Table of Objects" and there was no grey line, but the table was still
empty.

HTH,
Terry.
Comment 9 Terrence Enger 2012-12-15 13:30:31 UTC
Created attachment 71548 [details]
typescript

I attach typescript of execution of master from 2012-12-07.  I do not
always pay attention to messages in the terminal, and I do not often
use a debug build for Writer documents, but there are a couple of
messages that I do not remember seeing before ...

(*) warn:legacy.osl:22041:1:/home/terry/lo_hacking/git/libo4/svtools/source/graphic/grfmgr2.cxx:1437:
    Missing implementation: Mtf-Transparency

(*) warn:legacy.osl:22041:1:/home/terry/lo_hacking/git/libo4/framework/source/fwi/threadhelp/transactionmanager.cxx:315: ASSERT:
        TransactionManager...
        "Owner instance stand in close method. Call was rejected!"

(*) warn:legacy.osl:22041:1:/home/terry/lo_hacking/git/libo4/oox/source/helper/storagebase.cxx:74:
    StorageBase::StorageBase - missing base input stream

I do not know whether these have anything to do with the reported
problem.

Terry.
Comment 10 Terrence Enger 2012-12-15 15:30:16 UTC
Having seen the bug in bibisect 3.5 oldest, which is commit d6cde02
2011-08-22, I am setting version 3.4.4 release.  IRC tells me that the
freeze of 3.5.0 was after that date.

Terry.
Comment 11 Jan Holesovsky 2013-03-07 15:50:17 UTC
It is older than the 1st bibisect commit, so it is bibisected35older...
Comment 12 Derek Atkins 2014-01-31 21:43:33 UTC
Any movement on this bug?  It's been a year since the last comment and I just hit it myself.
Comment 13 Björn Michaelsen 2014-02-28 12:45:54 UTC
Bulk change: Bibisected bugs can be assumed to be regressions.
Comment 14 Terrence Enger 2014-03-05 19:33:48 UTC
Let me offer this comment on the current state of affairs.  My
observations are based on commit 805f4d8, fetched 2014-03-04 15:19
UTC, configured with --enable-dbgutil among other things, built and
running on debian-wheezy.  Thus my build includes commit
598d02d... mentioned in bug 75133 and bug 75630.


I entered one bibliography entry and a bibliography.  Libreoffice
shows the bibliography entry as a field (i.e., grey background, the
cursor will not enter the field) and the bibliography table shows one
line.

(*) After save as .odt and reload, the appearance is as described
    before.

(*) After save as .docx and reload, the bibliography entry is replaced
    by ordinary text "Bibliography entry".

    The bibliography table is loaded correctly.  This is an
    improvement on what I oh-so-vaguely recall from 2012.


Bug 75133 "Bibliography field flags are not preserved in Round trip
file" is very similar to this one, with the advantage that it has an
attachment produced by Microsoft Word.  That bug report is not
perfectly explicit about the expected results; my LibreOffice running
on the attachment does not show the words "Bibliography entry", but it
does show plain text "(Kramer & Chen, 2006)", something which looks
like it might have been a bibliography entry.  I am not marking either
bug as a duplicate of the other, but it is a near thing.
Comment 15 marco.lackovic 2015-01-14 16:47:05 UTC
The bug is still present on LibreOffice 4.3.5.2 running on LMDE Cinnamon Edition, Linux sinope 3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13) x86_64 GNU/Linux.
Comment 16 tommy27 2015-01-23 04:39:14 UTC
(In reply to marco.lackovic from comment #15)
> The bug is still present on LibreOffice 4.3.5.2 running on LMDE Cinnamon
> Edition, Linux sinope 3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13)
> x86_64 GNU/Linux.

please do not change version field that way.
it has always to indicate the first version the bug appeared.
so I'm reverting it to 3.4.4 release
Comment 17 Robinson Tryon (qubit) 2015-12-14 05:40:10 UTC
Migrating Whiteboard tags to Keywords: (preBibisect)
[NinjaEdit]
Comment 18 Jean-Baptiste Faure 2016-04-16 07:35:06 UTC
Created attachment 124381 [details]
testkit with original ODF file and exported OOXML

Not reproducible for me with the current master (Version: 5.2.0.0.alpha0+
Build ID: d5e7eb0c2cad00ae88a9bacf88381f0177d09b61).

Additionally, this bug is not a regression: nobody said that is worked in a previous version.

Best regards. JBF
Comment 19 Jean-Baptiste Faure 2016-04-16 07:37:09 UTC
Removing regression keyword (see previous comment).

As it is not reproducible, I close it as WorksForMe.
Please, feel free to reopen if you disagree.

Best regards. JBF
Comment 20 Jean-Baptiste Faure 2016-04-16 07:38:45 UTC
Works in LO 5.1.3.0.0+ too.

Best regards. JBF