Download it now!
Bug 75133 - Bibliography field flags are not preserved in Round trip file
Summary: Bibliography field flags are not preserved in Round trip file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-18 06:33 UTC by Rohit Deshmukh
Modified: 2014-03-18 17:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Original file (16.27 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-02-18 06:33 UTC, Rohit Deshmukh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rohit Deshmukh 2014-02-18 06:33:49 UTC
Created attachment 94260 [details]
Original file

Steps to reproduce:

1. Load the attached DOCX in LO
2. Save as NEW.DOCX
3. Open the NEW.DOCX in Word
4. Citation should b preserved
Comment 1 Jorendc 2014-02-18 20:32:59 UTC
Reproducible, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha0+ Build ID: b540f9172814f51361cf31d2a4b03e34d1d375ef
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-02-15_00:28:42

Opened using Word for Mac 2011.

Kind regards,
Joren
Comment 2 Commit Notification 2014-02-26 11:51:18 UTC
Rohit Deshmukh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=598d02d71f40901eab9275704c8bc0e1641b56e3

fdo#75133: Preseved bibliography after round trip.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Terrence Enger 2014-03-05 19:34:37 UTC
Bug 58300 "FILEOPEN: lost bibliography entries/empty bibliography
index when saving as .doc or .docx" is very similar to this one.  I am
not marking either as a duplicate of the other, but it is a near
thing.
Comment 4 Jorendc 2014-03-17 11:20:47 UTC
Hi Rohit

Thanks for working on this :-)!
Tested using a build from March 15th, Word still doesn't handle the bibliography as expected. I mean: when I open th original file, and click on the bibliography list, a selection box is visible around the complete list, with a dropdown menu where I can update the list etc. With the roundtripped file: the bibliography list is handled as regular text (click on it doesn't result in a selection box).

Tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 88955714d345d8584e86ae34bf5f5d1f3f4af9f7
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-03-15_04:16:49

Not sure this is the behavior you tried to fix?

Kind regards,
Joren
Comment 5 Jacobo Aragunde Pérez 2014-03-17 20:17:33 UTC
(In reply to comment #4)
> 
> Tested using a build from March 15th, Word still doesn't handle the
> bibliography as expected. I mean: when I open th original file, and click on
> the bibliography list, a selection box is visible around the complete list,
> with a dropdown menu where I can update the list etc. With the roundtripped
> file: the bibliography list is handled as regular text (click on it doesn't
> result in a selection box).
> 

I'm working on a related topic -SDT blocks- and I've been able to check that the field marks for the bibliography and the citations are being correctly preserved. The selection box you mention is defined by an SDT block enclosing the bibliography list and the individual citations. I've been working on that and pushed a pair of patches, 55211e612d2cbed03dd81c039d07ea4e936c2804 and 6820dec8903b182260340c638c35b5a5ca207a85. Please check again :)

There are, though, still some issues related with citation that I've just detected and reported as bug #76279 and bug #76281.
Comment 6 Jorendc 2014-03-17 20:22:18 UTC
Thanks for your reply Jacobo!

(In reply to comment #5)
> I'm working on a related topic -SDT blocks- and I've been able to check that
> the field marks for the bibliography and the citations are being correctly
> preserved. The selection box you mention is defined by an SDT block
> enclosing the bibliography list and the individual citations. I've been
> working on that and pushed a pair of patches,
> 55211e612d2cbed03dd81c039d07ea4e936c2804 and
> 6820dec8903b182260340c638c35b5a5ca207a85. Please check again :)
> 
> There are, though, still some issues related with citation that I've just
> detected and reported as bug #76279 and bug #76281.

Nice! I surely will check! So if I understand it correctly, we can mark this bug report as RESOLVED FIXED :)?

Kind regards,
Joren
Comment 7 Jorendc 2014-03-18 17:11:21 UTC
(In reply to comment #5)
> I'm working on a related topic -SDT blocks- and I've been able to check that
> the field marks for the bibliography and the citations are being correctly
> preserved.

Lets mark this as RESOLVED FIXED anyway :-). Feel free to reopen if I'm wrong.

> The selection box you mention is defined by an SDT block
> enclosing the bibliography list and the individual citations. I've been
> working on that and pushed a pair of patches,
> 55211e612d2cbed03dd81c039d07ea4e936c2804 and
> 6820dec8903b182260340c638c35b5a5ca207a85. Please check again :)

I retest using a build from March 18 (today) (Build ID: 87efec9cc27b18aa09e50c289b503ba1127eb0b8) which includes this commit.
Looks indeed better. Now the 'SDT' block is indeed preserved. Only on the first paragraph (in this case it is the Bibliography title) but it is an improvement! Thanks :D!

Kind regards,
Joren