Bug 58301 - Controls in dialog Data > Sort invisible after starting
Summary: Controls in dialog Data > Sort invisible after starting
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:4.0.0.2
Keywords: regression
: 59073 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-14 16:13 UTC by Cor Nouws
Modified: 2013-01-11 20:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-12-14 16:13:50 UTC
Spreadsheet
some data in column, select that
choose menu Data > Sort
 > the dialog does not show the controls on the first tab page Sort criteria

change to second tab Options and back to Sort criteria
 > Now the controlas are visible
Comment 1 Cor Nouws 2012-12-14 17:21:49 UTC
 - seen it three times > confirm
 - was OK in 3.6.4 > regression
Comment 2 Markus Mohrhard 2012-12-26 19:14:47 UTC
Not reproducible in my own build.
Comment 3 Cor Nouws 2012-12-26 22:05:11 UTC
still a problem in Beta2
Comment 4 Caolán McNamara 2013-01-10 14:51:36 UTC
*** Bug 59073 has been marked as a duplicate of this bug. ***
Comment 5 Caolán McNamara 2013-01-10 15:23:00 UTC
I can reproduce this now
Comment 6 Caolán McNamara 2013-01-10 15:54:32 UTC
The scrollbar lies about its optimalsize if asked about it before the scrollbar is drawn. I had encountered this in some other circumstance in master a while ago and committed it as http://cgit.freedesktop.org/libreoffice/core/commit/?id=f41a2804dd4a23352b7af2dd28c03df02debfb13

So fixed in master, and submitted for 4-0 as https://gerrit.libreoffice.org/#/c/1630/
Comment 7 Not Assigned 2013-01-11 01:04:25 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5c22a10d41ae79b43edbf36962245c824a32e17&h=libreoffice-4-0

Resolves: fdo#58301 make sure ScrollBar OptimalSize is up to date


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Jean-Baptiste Faure 2013-01-11 20:32:29 UTC
Verified in Version 4.0.0.1+ (Build ID: f49e469d93749547520ae34c52d26f17bcc32cf)
under Ubuntu 12.04 x86-64.

Thank you very much :-)