Download it now!
Bug 58317 - UI Pivot Table - Choosing Results to <current sheetname> in More does not set the cell address field enabled
Summary: UI Pivot Table - Choosing Results to <current sheetname> in More does not set...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2012-12-14 21:57 UTC by Cor Nouws
Modified: 2013-06-18 13:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot showing problem (43.97 KB, image/png)
2013-05-30 22:19 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-12-14 21:57:53 UTC
Calc, some data
Start Data > Pivot table
Choose More
Select in dropdown 'Results to' <current sheet>

 > the field for the cell address is not enabled
   it does show the address top left of the data range

Changing  'Results to' to undefined / plaing with Less /  More, does set the field to enabled.
Comment 1 Joel Madero 2013-05-30 20:48:21 UTC
hm, Cor - is this still an issue? I don't have "current sheet" listed, only undefined & new sheet. 

Marking as NEEDINFO - if you can confirm it's still a problem let's just mark as NEW and prioritize however you see appropriate.
Comment 2 Cor Nouws 2013-05-30 22:19:42 UTC
Created attachment 80071 [details]
screen shot showing problem

Arghh, yes it is still a problem
tested in 4.1.0 beta.

thanks for nagging me, Joel.
Comment 3 retired 2013-05-30 22:59:15 UTC
Setting to NEW since Cor Nouws confirmed this is still valid for LO 4.1b1.
Comment 4 Michael Meeks 2013-06-18 12:40:32 UTC
I tried to reproduce this; it should be trivial to fix - but I don't understand the reproduction instructions. Lets assume I know next-to-nothing about PivotTables. Here is what I do:

New spreadsheet button
I enter a square at A1:C3 - 1 2 3 4 5 6 7 8 9
I select this
Data->Pivot Table->Create
  "Current selection" -> 'ok'

I drag '1' into "row fields", '2' into "Data fields", and '3' into "Column Fields".

I expand 'more'

I poke at the drop-down: "Results to" - and it contains the following entries:

"- undefined -" and "- new sheet -" - there is no semantic <current sheet> meaning I can unwind.

With "- undefined -" I could select the range selection for the current sheet and get data there; but ...

Whatsup ? it appears to behave like this in 4.0 as well - so I'm clearly missing something important here.

Thanks Cor !
Comment 5 Cor Nouws 2013-06-18 13:44:43 UTC
(In reply to comment #4)

> Whatsup ? it appears to behave like this in 4.0 as well - so I'm clearly
> missing something important here.

So you mean I'm possibly making a big mistake here ... :)

Ah well, checked the situation over various versions and found that it's a blunt user error ;\
Apologies.

In stead of selecting what I thought was the name of the curren sheet, I selected the name of a named range. Which was not empty etc. und so weiter.

Sorry for the noise!
& thanks for testing
Cor