Bug 58328 - FILESAVE: Creating a new document version no longer working
Summary: FILESAVE: Creating a new document version no longer working
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: All All
: high major
Assignee: Cédric Bosdonnat
QA Contact:
URL:
Whiteboard: BSA target:4.1.0 target:4.0.0.2
Keywords: regression
: 58437 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-12-15 09:54 UTC by Florian Heckl
Modified: 2013-05-28 03:23 UTC (History)
9 users (show)

See Also:


Attachments
Screenshot, LibO 4.0.0.0beta1 on Mac OS X 10.6.8 (150.15 KB, image/png)
2012-12-15 11:19 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Heckl 2012-12-15 09:54:16 UTC
Problem description: 
Creating a new document version does not work

Steps to reproduce:
1. Create a file (text, calc, type doesn't really matter)
2. Save the file
3. Select File > Versions... from the menu
4. Click on "Save new version"
5. Enter a comment
6. Click "OK"

Current behavior:
The Comment dialog is closed, but no version is created (at least not visible to the user)

Expected behavior:
A new entry appears in the "Existing versions" panel

Works OK in version3.6.4.3 
              
Operating System: Mac OS X
Last worked in: 3.6.4.3 release
Comment 1 Roman Eisele 2012-12-15 10:30:57 UTC
Thank you very much for your bug report!

REPRODUCIBLE with 4.0.0beta1 [*], German langpack installed, on Mac OS X 10.6.8 (Intel). Following the steps 1-6 given in comment #0,
* Expected: LibreOffice shows a new line in the “Existing versions”
  list box, just like LibreOffice up to 3.6.4.3 does
* Actual result: the “Existing versions” list box is still empty.
  Repeating steps 4-6 does not change this.

Of course, LibreOffice 4.0.0beta1 still shows the versions created in earlier versions. But adding new versions to such existing files does not work either.

(Removed triple “regression” keyword -- one is enought ;-); and the most important is the one in the “Keywords” field.)


[*] Full version information:
Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-05_22:13:37
Comment 2 Roman Eisele 2012-12-15 10:48:48 UTC
Checking my little collection of daily builds gives the following results:
* The version feature still works up to the daily build with
  pull time 2012-10-30 00.06.37
* But it fails, as described, beginning with the daily build with
  pull time 2012-11-02 23.47.02
So, if I have not made any mistake, the regression was introduced between these two dates. I hope this is a fairly limited count of commits to check ...
Comment 3 Roman Eisele 2012-12-15 11:19:59 UTC
Created attachment 71543 [details]
Screenshot, LibO 4.0.0.0beta1 on Mac OS X 10.6.8



To prevent any ambiguities of the description, this screenshot shows exactly where the new version should appear (be listed), but does not do so anymore ;-).
Comment 4 manj_k 2012-12-15 11:54:01 UTC
Reproducible on WinXP 32b
with:

LibO-Dev 4.0.0.0.beta1 
(Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)

LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-12 22:57:58
core:7eac2e42882fc36816b8b1f79e85abbe21bd40a0

LibO-Dev_4.0.0.0.beta1+
Win-x86@6 libreoffice-4-0
pull time 2012-12-13 00:58:30
core:dc709ddc8267ac594f7c9e7f70189e9a33a413f4



Works well with
LibO-Dev_3.6.5.0+
Win-x86@6 libreoffice-3-6
pull time 2012-12-12 16:56:03
core:8454a88e1818fa498c6860a2db434ad51591257c
Comment 5 manj_k 2012-12-15 13:49:17 UTC
Also reproducible (on WinXP 32b) with

LibO-Dev_4.0.0.0.alpha1+
Win-x86@6 MASTER
pull time 2012-12-01 19:01:32
core:3321acda38866be7bd45e70c0f1e674d093b7f30
Comment 6 Roman Eisele 2012-12-15 19:31:34 UTC
@ manj_k:
Thank you very much for testing and confirming this bug on Windows!
Comment 7 Jean-Baptiste Faure 2012-12-15 21:58:52 UTC
Also reproducible with LO 4.0 beta1+ (Build ID: 2988f4bbc9c381e91a372a6aad5d0334d713438) under Ubuntu 12.04 x86_64

Best regards. JBF
Comment 8 Terrence Enger 2012-12-16 21:18:29 UTC
A debug build of master commit id 8450a99 (2012-12-08) produced the following console messages when I tried unsuccessfully to save a "version" ...

    warn:legacy.tools:12062:1:/home/terry/lo_hacking/git/libo4/sfx2/source/doc/guisaveas.cxx:687: Unacceptable parameters are provided in Save request!

    warn:legacy.osl:12062:1:/home/terry/lo_hacking/git/libo4/svl/source/items/cenumitm.cxx:240: CntBoolItem::PutValue(): Wrong type
    warn:legacy.osl:12062:1:/home/terry/lo_hacking/git/libo4/sfx2/source/appl/appuno.cxx:396: Property not convertable: VersionComment
    warn:legacy.osl:12062:1:/home/terry/lo_hacking/git/libo4/svl/source/items/cenumitm.cxx:240: CntBoolItem::PutValue(): Wrong type
    warn:legacy.osl:12062:1:/home/terry/lo_hacking/git/libo4/sfx2/source/appl/appuno.cxx:396: Property not convertable: VersionComment


HTH,
Terry.
Comment 9 Michael Meeks 2012-12-17 22:12:42 UTC
Hi Roman: this is the best delta comment:

> * The version feature still works up to the daily build with
>  pull time 2012-10-30 00.06.37
> * But it fails, as described, beginning with the daily build with
>  pull time 2012-11-02 23.47.02

Actually - Roman do you still have those builds ? since the dates are not really in any strict chronological order and the timestamps from a tinderbox are not particularly helpful either ;-) would it be possible to have the git hashes from help->about in those builds ?
Comment 10 manj_k 2012-12-17 22:47:37 UTC
*** Bug 58437 has been marked as a duplicate of this bug. ***
Comment 11 Roman Eisele 2012-12-18 07:21:47 UTC
(In reply to comment #9)
> Actually - Roman do you still have those builds ? since the dates are not
> really in any strict chronological order and the timestamps from a tinderbox
> are not particularly helpful either ;-) would it be possible to have the git
> hashes from help->about in those builds ?

Yes, I still have those builds -- but they show only a short Build ID in their about box:

Last working build in my collection:
  “LOdev Version 3.7.0.0.alpha0+ (Build ID: ce2690)”
  pull time 2012-10-30 00.06.37
First failing build in my collection:
  “LOdev Version 3.7.0.0.alpha0+ (Build ID: c1b407)”
  pull time 2012-11-02_23.47.02

I don’t know if this helps. I did not copy the complete build info files, sorry ...
Comment 12 Michael Meeks 2012-12-21 16:04:41 UTC
Hi Roman - that's great ! the short versions are just fine for most purposes:

git log ce2690..c1b407

gets it down to 230 commits or so.

I'll have a poke ...
Comment 13 Michael Meeks 2012-12-21 16:08:47 UTC
Almost certainly a side-effect of Cedric's CMIS related changes around sfx2's docfile - any thoughts there Cedric ? I wonder what the UI for versioning inside files inside a versioned CMIS store feels like ;->
Comment 14 Cédric Bosdonnat 2012-12-21 16:25:45 UTC
(In reply to comment #13)
> Almost certainly a side-effect of Cedric's CMIS related changes around
> sfx2's docfile - any thoughts there Cedric ? I wonder what the UI for
> versioning inside files inside a versioned CMIS store feels like ;->

There is no UI for the versions on CMIS stores ATM. But indeed that may be related to the changes to handle Check-In operation. I'll have a look at that next year (sorry for the long delay, I need holidays)
Comment 15 Jorendc 2012-12-23 10:05:07 UTC
Still reproducible with LO 4.0.0.0.beta2 (Bouw-id: 4104d660979c57e1160b5135634f732918460a0)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-18_17:13:13
Comment 16 Not Assigned 2013-01-10 10:02:34 UTC
Cedric Bosdonnat committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f6cd9a3dc5e83e7394dfb35161abb94699e59fb

fdo#58328: fixed items types made versioning work again



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Michael Meeks 2013-01-10 10:12:33 UTC
Thanks Cedric - picked to -4-0 for rc2 :-) nice catch.
Comment 18 Not Assigned 2013-01-10 10:14:21 UTC
Cedric Bosdonnat committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6bfd791162fa392600ef8b8df6c1ac04bb4d4099&h=libreoffice-4-0

fdo#58328: fixed items types made versioning work again


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Jean-Baptiste Faure 2013-01-10 22:02:22 UTC
Verified in Version 4.0.0.1+ (Build ID: f0fd3bd8f8a13f6cbe2a27018b83eee24a694c0)

Thank you Cédric.
JBF