Download it now!
Bug 58330 - EDITING: Selecting text in formula bar sends LODev into spinning beachball land
Summary: EDITING: Selecting text in formula bar sends LODev into spinning beachball land
Status: VERIFIED DUPLICATE of bug 56937
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-15 10:10 UTC by Christoph Sold
Modified: 2012-12-23 17:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Mac OS X log file for bug 58330, created with LibO 4.0.0.0beta1 on Mac OS X 10.6.8 with RightZoom running (154.54 KB, text/plain)
2012-12-23 17:11 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Sold 2012-12-15 10:10:34 UTC
1. Enter text (Anything) into any cell
2. Select another cell
3. Select first cell
4. lick text in formula bar
=>> Spinning beachball cursor appears, LODev hangs
Comment 1 Roman Eisele 2012-12-15 10:55:19 UTC
Thank you very much for your bug report!

Well, I can not reproduce this problem -- for me (on Mac OS X 10.6.8), the steps work perfectly fine in LibreOffice 4.0.0beta1. But this bug is very similar to bug 56937 - “EDITING: freeze when drag-and-drop from Calc input line to anywhere on OSX”. Now bug 56937, like some similar issues, happens if and only if you have installed some utility etc. which uses and activates the Mac OS X accessibility API. So this could be true for this (present) bug, too.


We have some long-standing bugs in LibreOffice accessibility stuff which were inherited from OpenOffice and which become visible only when the Mac OS Accessibility API is used (see the comments in bug 55571 etc.) ... and it seems that your report is just about another one of these nasty issues.

Therefore, to confirm this idea and to find out what exactly triggers
the bug, please check and answer the following questions:

1) Do you have any accesibility features enabled? Apple’s accessibility
features like “VoiceOver” or “Enable access for assistive devices”, which get
enabled in “System Preferences > Universal Access” (in German:
“Systemeinstellungen > Bedienungshilfen”), are known to trigger many crashes and freezes in LibreOffice. So please try to disable any accesibility features, then check if the problem is still reproducible.

2) Do you have installed any window management/user interface utilities/apps/control panels/extensions for Mac OS X like 
   * AquaSnap                * BetterSnapTool
   * BetterTouchTool         * Breeze
   * Cinch                   * Divvy
   * DoublePane              * Flexiglass
   * HyperDock               * iSnap
   * Moom                    * RightZoom
   * ShiftIt                 * SizeUp
   * SizeWell                * Spectacle
   * Stay                    * TileWindows
   * WindowTidy            ... or something similar?

And/or do you use any mouse cursor/pointer utility, i.e. some little application or control panel etc. which animates or replaces etc. the mouse curser/pointer, like
   * LazyMouse?

And/or do you use any special software which could be related to accessibility stuff, e.g. a screen reader, screen magnifier, speech recognition software,
a text-to-speech (dictation) application, or similar?

All these and many similar utilities rely heavily on Mac OS accessibility features and therefore can cause LibreOffice to crash or freeze. So please check if you have installed any utility of this kind and try to disable it
(or to add LibreOffice to the list of excluded applications for the utility,
if there is such a thing).

And please report the results here. Thank you very much!
Comment 2 Christoph Sold 2012-12-15 11:08:56 UTC
> 1) Do you have any accesibility features enabled?
Yes.

> 2) Do you have installed any window management/user interface
> utilities/apps/control panels/extensions for Mac OS X like 

WindowTidy, BetterTouchTool

Disabling accessibility features masks this bug, but also removes lots of eyes candy from the system. Besides eye candy, I require the accessibility zoom features because of my bad eyes.
Comment 3 Roman Eisele 2012-12-20 09:23:05 UTC
(In reply to comment #2)
> Disabling accessibility features masks this bug, but also removes lots of
> eyes candy from the system. Besides eye candy, I require the accessibility
> zoom features because of my bad eyes.

Thank you very much for your answer! Especially thank you for the hint that you really *need* the accessibility zoom features; this increases the importance of this bug a lot. (Many people which activate the Mac OS accessibility features need them for eyes candy *only*.)

But there are good news! Very probably this bug has the same roots as bug 56937 - “EDITING: freeze when drag-and-drop from Calc input line to anywhere on OSX …”. Now bug 56937 has been fixed some days ago. The fix will appear in LibreOffice 3.6.5, which will be released about end of February 2013. Release candidates (which *should* be mostly usable for every day work) will be available earlier ...

So I hope this bug will be fixed in 3.6.5, too. Until then, I can only beg your pardon and ask you for patience ...

Thank you again!

*** This bug has been marked as a duplicate of bug 56937 ***
Comment 4 Roman Eisele 2012-12-23 17:11:53 UTC
Created attachment 72037 [details]
Mac OS X log file for bug 58330, created with LibO 4.0.0.0beta1 on Mac OS X 10.6.8 with RightZoom running


I want to verify if the patch for bug 56937 has really fixed the present bug, too. To do so, I first REPRODUCE the present bug, which is easy to do when I install and activate RightZoom. This triggers the bug e.g. in LibreOffice 4.0.0.0beta1. Tested on MacOS X 10.6.8 (Intel). Just for the record, I attach the log file created by Mac OS X when I had to force quit the frozen LibreOffice.
Comment 5 Roman Eisele 2012-12-23 17:14:31 UTC
VERIFIED as DUPLICATE:

I can no longer reproduce this bug beginning with the 1st available master build after the patch for bug 56937 has been committed:
  Version 4.1.0.0.alpha0+ (Build ID: 413d1a932eb4c47510dd05905c1ff467cb186d0)
  TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master,
  Time: 2012-12-19_04:13:37

This means that the present bug is really a duplicate of bug 56937, and was fixed by the same commit.