Bug 58368 - Change of margin when changing Page Layout
Summary: Change of margin when changing Page Layout
Status: RESOLVED DUPLICATE of bug 59779
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-16 16:03 UTC by westley52
Modified: 2013-04-24 22:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Enpty document, margin and cursor position (60.59 KB, image/png)
2012-12-18 19:17 UTC, Marco Menardi
Details
Illustration of the left bracket shifting issue (45.15 KB, application/pdf)
2012-12-23 12:35 UTC, westley52
Details
screen recording that shows the bug (944.38 KB, video/x-matroska)
2013-01-11 21:47 UTC, Marco Menardi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description westley52 2012-12-16 16:03:03 UTC
Problem description: 
When starting Writer, the cursor starts at approximately 1.5" from the left margin.  If format:Page:any other page layout is chosen, the cursor immediately changes to the proper margin from the left margin.

Steps to reproduce:
1. Open Writer document - the margin is 1.5" from left 
2. Go to Format:Page:Page Layout
3. Chose any other Page Layout and the cursor changes to proper margin from the left of page

Current behavior:
Cursor is not following margin rules

Expected behavior:
Cursor should follow margin rules

              
Operating System: Windows XP
Last worked in: 3.6.4.3 release
Comment 1 Marco Menardi 2012-12-18 19:16:54 UTC
XP 32, LiBo 4.0beta1 and also nighly build 2012/12/18, can't reproduce.
What do you mean with "choose any other page layout"? Do you mean page size i.e. from A4 to Letter? Or orientation from Portrait to Landscape? Or "Layout settings" to "Only left"?
I went in Format -> Page -> [Page] tab.
Or you mean the cursor position not regarding the page but the program window? What are your zoom settings?
View -> Zoom -> I've tested with 100% and Optimal, works fine.
In the attachment the situation when I run Writer (I have "non printing characters" ON).
Comment 2 Marco Menardi 2012-12-18 19:17:51 UTC
Created attachment 71746 [details]
Enpty document, margin and cursor position
Comment 3 westley52 2012-12-23 12:35:16 UTC
Created attachment 72026 [details]
Illustration of the left bracket shifting issue

Thank you for looking at this.  I am adding a PDF attachment to illustrate the issue.  The left page bracket ( not sure of its proper name ) shifts 1/2 inch to the left when the apply button is pressed on the Page Style: Default Style dialog box.  Since nothing changed in the box before the Apply button is pressed - nothing on the page should have changed.  But, please note the left page bracket has shifted to the left by 1/2 inch.
Comment 4 Marco Menardi 2013-01-02 21:13:16 UTC
Now I understand what you mean but can't reproduce.
Does it not happen with 3.6.x on the SAME pc but does with 4.0?
Could see if changing "default printer" changes this behaviour?
Could you test in another PC?
Thanks a lot for your input
Comment 5 westley52 2013-01-05 16:24:20 UTC
I tried installing the 4.0 beta on another XP machine and a Windows 7 machine - same results.  I also changed the default printer with exactly the same results.  This seems to be a problem with only a new document.  Once a document is created and saved - there is no problem as the page brackets line up with the margin setting properly.  However, File->New will create a document with the page brackets offset by about 1/2 inch.  Hope this helps.
Comment 6 westley52 2013-01-05 16:25:15 UTC
BTW, 3.6.4 works fine - seems to be a new issue with 4.0.
Comment 7 Marco Menardi 2013-01-11 21:47:23 UTC
Created attachment 72876 [details]
screen recording that shows the bug

I was going to give up but since I was sure the reporter was facing some strange behaviour I've insisted.
Today I've purged my distro installation of LiBo (3.6.x), removed 4.0beta2, installed 4.0RC1 and run with LANG=C on front.
I can confirm the issue, see attachment!
Without LANG=C, no bug, the cursor is in the right position since the beginning.
My locale is Italian, and I've faced the bug under Debian GNU/Linux 64, KDE 4.8.4.
Comment 8 Michael Stahl (allotropia) 2013-04-24 22:17:36 UTC
that one should be fixed already

*** This bug has been marked as a duplicate of bug 59779 ***