Download it now!
Bug 58399 - CRASH when FILEOPEN particular .docx (MSO2007)
Summary: CRASH when FILEOPEN particular .docx (MSO2007)
Status: RESOLVED DUPLICATE of bug 58267
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0 target:4.0.0.0.beta2
Keywords: haveBacktrace, regression
: 58110 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-12-17 09:23 UTC by vulcain
Modified: 2012-12-19 07:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash report Mac OSX 10.8.2 (58.57 KB, text/plain)
2012-12-17 10:10 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vulcain 2012-12-17 09:23:50 UTC
Steps:
1) Open the docxfiles on this wiki pages: http://wiki.documentfoundation.org/File:SmartArt2007listes.docx
2) Crash

Expected: Open and see the document with SmartArt.

Environnement Ubuntu 12.04.1 x86_64 LibreOffice 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)

My first try give me in my terminal:
" 
me@pc-portable:~$  /opt/lodev4.0/program/soffice
raptor error - XML parser error: Document is empty
"
Comment 1 Rainer Bielefeld Retired 2012-12-17 09:37:55 UTC
MOT Reproducible with parallel installation of  "LOdev  4.0.0.0.beta1   -  GERMAN UI / German Locale  [Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)]"  {tinderbox: @6, pull time 2012-12-06} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch.

No crash when I open document, but it's shown empty (for what I submitted "Bug 58400 - FILEOPEN particular .docx (MSO2007) shows empty document"

Linux only?
Comment 2 Jorendc 2012-12-17 10:09:36 UTC
Also a crash with Mac OSX 10.8.2  LO 4.0.0.0.beta1 (Bouw-id: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-05_22:13:37; 

NO CRASH with LibreOffice 3.6.4.3 (Bouw-id: 2ef5aff)

(both with Dutch helppack installed)

So, not linux only and regression.
Comment 3 Jorendc 2012-12-17 10:10:13 UTC
Created attachment 71640 [details]
Crash report Mac OSX 10.8.2
Comment 4 Michael Meeks 2012-12-17 13:11:31 UTC
thanks ! :-)

*** This bug has been marked as a duplicate of bug 58267 ***
Comment 5 Not Assigned 2012-12-17 19:57:43 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb3f2900a867fdcb6df916fff58199b4ce94dd05

fdo#58399 - revert attempts to untangle and accelerate this mess.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Not Assigned 2012-12-17 20:04:44 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=51ecd2f55d608f853852335808b643f61b9a844e&g=libreoffice-4-0

fdo#58399 - revert attempts to untangle and accelerate this mess.


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Markus Mohrhard 2012-12-18 20:00:14 UTC
*** Bug 58110 has been marked as a duplicate of this bug. ***
Comment 8 Not Assigned 2012-12-19 07:06:21 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=756159812e267b6d1a81dac9d960b9c9eedbb668&g=libreoffice-4-0

Revert "fdo#58399 - revert attempts to untangle and accelerate this mess."


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Not Assigned 2012-12-19 07:06:54 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3fed9f4ea354427c205bd407fcfa3d04093ba50

Revert "fdo#58399 - revert attempts to untangle and accelerate this mess."



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.